Common F15 bugs

From FedoraProject

Revision as of 03:28, 9 May 2011 by Pwouters (Talk | contribs)

Jump to: navigation, search

This page documents common bugs in Fedora 15 and, if available, fixes or workarounds for these problems. If you find your problem in this page, do not file a bug for it, unless otherwise instructed. Where appropriate, a reference to the current bug(s) in Bugzilla is included.

Note.png
Fedora 15 pre-release
Fedora 15 has not yet been released. During this pre-release period, this page will cover known issues in the Fedora 15 pre-releases. Issues that are fixed will be removed from the page once a fix is available (for instance, an issue that affects the Beta but is fixed in the final release will be removed at the time of that release).

Contents

Release Notes

Read the F15 Beta Announcement and the Fedora 15 release notes for specific information about changes in Fedora 15: known issues, and other general information.

My bug is not listed

Not every bug is listed in this page, but Bugzilla should be a comprehensive database of known bugs. This page is a sampling of the bugs most commonly discussed on our mailing lists and forums.

To see if your bug has already been reported, you can search Bugzilla. If it has not yet been reported, we encourage you to do so to help improve Fedora for yourself and others. A guide to Bugs and feature requests has been prepared to assist you.

If you believe an already-reported bug report should be added to this page because it is commonly encountered, you can:

  • Add it yourself, if you have wiki access. Please follow the style and guidelines explained in the comments in the page source.
  • Or, add the CommonBugs keyword to the bug report. Someone from the QA team will then inspect the issue to determine whether the bug should be listed as a common bug. To expedite your request, please add a comment to the bug that includes
    1. a summary of the problem
    2. any known workarounds
    3. an assessment on the impact to Fedora users

For reference, you can query Bugzilla for bugs tagged CommonBugs:

  • CommonBugs? (bugs with CommonBugs keyword, but do not yet have a link to this page)
  • CommonBugs+ (bugs with CommonBugs keyword and contain a link to this page)


Installation Issues

Installation in Turkish language crashes at custom partitioning screen

link to this item - Bugzilla: #694928

Due to a bug in Python, when installing Fedora 15 Beta in Turkish, if you access the custom partitioning screen by selecting either the 'Create a custom partition layout' radio button or the 'Review and modify partitions prior to installing' checkbox at the partition options screen, the installer will crash. You can work around this issue by installing in another language (if you must use the custom partitioning screen) or by installing in Turkish but not selecting either of the options that causes the custom partitioning screen to display.

This issue will be resolved in the final Fedora 15 release.

Installer media check always fails in 32-bit Fedora 15 Beta

link to this item - Bugzilla: #692135

Due to a bug in the image checking library, the media check function of the Fedora 15 Beta installer will always fail on 32-bit images, even if the medium is in fact correct. The 64-bit images are unaffected. To work around this issue, simply do not use the media check function of the installer; you can verify the integrity of the image outside of the installer.

This issue will be resolved in the final Fedora 15 release.

Software Issues

General buggy or missing functions in GNOME Shell network applet (hidden networks, WPA2 Enterprise, multiple configurations per interface, mobile broadband etc)

link to this item

GNOME Shell features an integrated NetworkManager configuration interface, provided by an applet in the top panel and a configuration interface in System Settings. However, as of Fedora 15 Beta, these tools have not yet achieved feature parity with the configuration interface from GNOME 2, provided by the old nm-applet. Some features are still missing and there are known bugs with others. Major ones will be listed individually here, but as a general principle, if you encounter problems or missing features trying to configure your network using the GNOME 3 applet and System Settings interface, you can run the standalone nm-connection-editor tool, which makes all the operations not yet implemented in the GNOME 3 interface available. You can launch nm-connection-editor from a console, from the alt-f2 Run dialog, or from the overview (type nm-connection-editor or search for an entry named Network Connections).

GNOME 3's fallback mode uses the old nm-applet, and is not subject to this issue.

Unable to connect to hidden wireless networks

link to this item - Bugzilla: #691139

The GNOME 3 NetworkManager configuration interface in Fedora 15 Beta (the applet by the user menu, and the control center Network entry) contain a bug which causes them to hang if you try to configure a hidden wireless network by typing in its SSID. To work around this bug, you can run the standalone configuration tool nm-connection-editor, either by running it from a console, from the alt-f2 dialog, or by finding it in the Overview (it has the name Network Connections). This tool is able to configure hidden networks correctly. This tool is a useful fallback for any situation where the GNOME 3 configuration interface is problematic or incomplete.

This issue was fixed in the updated control-center-3.0.0.1-3.fc15 package. To solve the issue, update your Fedora 15 Beta installation as usual. You should no longer encounter this issue after updating to that version or later of Package-x-generic-16.pngcontrol-center.

Unable to connect to Cisco AnyConnect VPN

link to this item - Bugzilla: #696107

The NetworkManager-openconnect package in Fedora 15 Beta has not been updated to work with NetworkManager 0.9, and connecting to a Cisco AnyConnect VPN is only possible using the command-line openconnect tool.

This issue was fixed in the updated NetworkManager-openconnect-0.8.1-9.git20110419.fc15 package. You should no longer encounter this issue after updating to that version of later of Package-x-generic-16.pngNetworkManager-openconnect.

Oh no! Something has gone wrong error screen always appears shortly after login

link to this item - Bugzilla: #698190

Due to a problem with the Fedora update system, for a short time in the Fedora 15 repositories the Package-x-generic-16.pnggnome-shell package was at version 3.0.0.2-2.fc15 while the Package-x-generic-16.pnggnome-menus package was at version 3.0.0-1.fc15, despite the fact that gnome-shell-3.0.0.2-2.fc15 and gnome-menus 3.0.0-2.fc15 are part of a single update. This combination of packages results in an unavoidable crash in GNOME Shell shortly after it starts up. The first time it crashes, it will re-start itself and a crash notification will appear. The second time it crashes, the GNOME 3 Oh no! Something has gone wrong error screen will appear.

If you updated to packages from the Fedora 15 repository without the Fedora 15 updates-testing repository enabled between 2011-04-15 and 2011-04-21, you may have encountered this issue. The most likely scenario in which this would occur is using the preupgrade tool to upgrade from Fedora 14 to Fedora 15, as preupgrade does not use the updates-testing repository by default.

To resolve this issue, update to gnome-menus-3.0.0-2.fc15 or later. You may need to use an alternative desktop to manage this. If you do not have one available, leave the GNOME session at the error message screen (to ensure a network connection will be available), switch to a console with ctrl-alt-f2, log in as root, and run yum update gnome-menus (or just yum update). Then log in to GNOME again.

Note that the Oh no! Something has gone wrong is a general-purpose error screen and may occur due to other bugs; this is just one case which is known to have affected several users. If you are seeing the screen and you have gnome-menus-3.0.0-2.fc15 or later installed, you are experiencing a different issue.

repomd.xml file reported missing or broken

link to this item - Bugzilla: #703025

When Adding F15 TC1 to a PXE server and using a PXE boot menu to upgrade, the installer will complain about a bad or missing repomd.xml file. This happens when the PXE upgraded machine has no internet connectivity (for example because it is crosscabled to a PXE server). You can hit the "edit" button, and then fix the url to your local http server (usually running on the PXE server) Then you will hit the same issue again, as the installer also searches for the "updates testing" repo. Just point it with url to the same "base" f15 repo on your PXE/http server. Don't forget the unselect the "is mirror URL" tickbox.