Common F15 bugs

From FedoraProject

Revision as of 14:10, 24 May 2011 by Adamwill (Talk | contribs)

Jump to: navigation, search

This page documents common bugs in Fedora 15 and, if available, fixes or workarounds for these problems. If you find your problem in this page, do not file a bug for it, unless otherwise instructed. Where appropriate, a reference to the current bug(s) in Bugzilla is included.

Contents

Release Notes

Read the F15 Beta Announcement and the Fedora 15 release notes for specific information about changes in Fedora 15: known issues, and other general information.

My bug is not listed

Not every bug is listed in this page, but Bugzilla should be a comprehensive database of known bugs. This page is a sampling of the bugs most commonly discussed on our mailing lists and forums.

To see if your bug has already been reported, you can search Bugzilla. If it has not yet been reported, we encourage you to do so to help improve Fedora for yourself and others. A guide to Bugs and feature requests has been prepared to assist you.

If you believe an already-reported bug report should be added to this page because it is commonly encountered, you can:

  • Add it yourself, if you have wiki access. Please follow the style and guidelines explained in the comments in the page source.
  • Or, add the CommonBugs keyword to the bug report. Someone from the QA team will then inspect the issue to determine whether the bug should be listed as a common bug. To expedite your request, please add a comment to the bug that includes
    1. a summary of the problem
    2. any known workarounds
    3. an assessment on the impact to Fedora users

For reference, you can query Bugzilla for bugs tagged CommonBugs:

  • CommonBugs? (bugs with CommonBugs keyword, but do not yet have a link to this page)
  • CommonBugs+ (bugs with CommonBugs keyword and contain a link to this page)


Resolved issues

System fan runs constantly on laptops with Intel integrated graphics

link to this item - GNOME Bugzilla: #703511

On some laptops with Intel integrated graphics, a bug in the intel_ips kernel module may cause the system load to appear permanently high, resulting in the system fan running constantly at high speed. The system load reading is in error, so the system is not in any danger of temperature-related damage, but the constant fan noise may be annoying.

This issue was fixed in the updated kernel-2.6.38.6-27.fc15 package. To solve the issue, update your Fedora 15 installation as usual and reboot. You should no longer encounter this issue after updating to that version or later of Package-x-generic-16.pngkernel.

Installation issues

Unable to retrieve FTP repodata

link to this item - Bugzilla: #679709

Due to a bug in the installer, when adding FTP-based package repositories during installation, the installer may report a failure while attempting to access FTP-based repository. No fix is available at this time. To workaround the problem, users are advised to first add an HTTP-based package repository URL (such as http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os). Once added, you may edit the newly created package repository, and change the repository URL to the desired FTP-based repository URL.

For additional guidance on installation package repositories, consult the installation guide.

Installation failure when using ksdevice=bootif without bootif=

link to this item - Bugzilla: #704188

When installing Fedora 15 while using the boot argument ksdevice=bootif, the installer will fail abnormally if no BOOTIF= value is provided by the PXE server. Future versions of Fedora will not exhibit this failure. In the meantime, ensure your PXE server is making proper use of the IPAPPEND configuration variable. This variable controls what networking arguments are passed to the kernel, and is typically responsible for providing a BOOTIF= value.

For additional guidance, consult the syslinux IPAPPEND documentation.

repomd.xml file reported missing or broken

link to this item - Bugzilla: #703025

When adding Fedora 15 to a PXE server and using a PXE boot menu to upgrade, the installer will complain about a bad or missing repomd.xml file. This happens when the PXE upgraded machine has no internet connectivity (for example because it is crosscabled to a PXE server). You can hit the "edit" button, and then fix the url to your local http server (usually running on the PXE server). Then you will hit the same issue again, as the installer also searches for the "updates testing" repo. Just point it with url to the same "base" f15 repo on your PXE/http server. Don't forget to unselect the "is mirror URL" tickbox.

Issues when upgrading from previous releases

Service not enabled after upgrading from Fedora 14

link to this item - Bugzilla: #703234, #703221, #703227, #703230, #703236, #703235, #703233, #703232

In Fedora 15, upstart has been replaced by a service called systemd. Due to improper rpm package upgrade scripts, some system services previously enabled in Fedora 14, may not be enabled after upgrading to Fedora 15. To determine if a service is impacted, run the systemctl status command as shown below.

# systemctl is-enabled foo.service && echo "Enabled on boot" || echo "Disabled on boot"

To enable a service on boot, run the following systemctl command (where foo is replaced with the name of the service):

# systemctl enable foo.service

Corrected packages may be available in the Fedora 15 updates repository. Depending on how you upgrade your Fedora 14 system (DVD-upgrade, or network upgrade), if the updates repository is included, packages with corrected upgrade scripts will be included and properly transfer your Fedora 14 service configuration to Fedora 15.

Graphical login does not start after upgrade

link to this item - Bugzilla: #698654

Depending on how Fedora 14 was initially installed, your system may not select the appropriate systemd boot target after upgrading to Fedora 15. The problem is caused by the %postinstall rpm script from the Fedora 14 package Package-x-generic-16.pngsystemd-units. Since Package-x-generic-16.pngsystemd isn't the default in Fedora 14, the problem will not manifest until you upgrade to Fedora 15.

If you change the Fedora 14 default runlevel at any time by modifying the file /etc/inittab, those changes will not affect the configured systemd default target. After upgrade, you may need to manually adjust the configured systemd default target links using the following procedure.

To configure systemd to start a graphical login menu on boot (similar to runlevel 5 in Fedora 14):

# ln -sf /lib/systemd/system/graphical.target /etc/systemd/system/default.target
# ln -sf graphical.target /lib/systemd/system/default.target<pre>

To configure systemd to start a text login prompt on boot (similar to runlevel 3 in Fedora 14):

# ln -sf /lib/systemd/system/runlevel3.target /etc/systemd/system/default.target
# ln -sf runlevel3.target /lib/systemd/system/default.target<pre>

Software issues

General buggy or missing functions in GNOME Shell network applet

link to this item

GNOME Shell features an integrated NetworkManager configuration interface, provided by an applet in the top panel and a configuration interface in System Settings. However, as of Fedora 15 Beta, these tools have not yet achieved feature parity with the configuration interface from GNOME 2, provided by the old nm-applet. Some features are still missing and there are known bugs with others. Major ones will be listed individually here, but as a general principle, if you encounter problems or missing features trying to configure your network using the GNOME 3 applet and System Settings interface, you can run the standalone nm-connection-editor tool, which makes all the operations not yet implemented in the GNOME 3 interface available. You can launch nm-connection-editor from a console, from the alt-f2 Run dialog, or from the overview (type nm-connection-editor or search for an entry named Network Connections).

GNOME 3's fallback mode uses the old nm-applet, and is not subject to this issue.

Laptop screen dims when switching to battery power or idle mode but never brightens again

link to this item - GNOME Bugzilla: #650405

Due to a bug in the screen brightness control logic in gnome-power-manager, laptop screens will dim as expected when switching from mains to battery power and dim further when the system is idle in battery mode, but will never brighten again when the system is no longer idle, or when you connect back to the mains. Eventually the screen will end up at its lowest possible brightness and be stuck there.

The only workaround is to disable screen dimming via the control center, or to manually reset the brightness to 100% via the keyboard (if you have brightness keys) or the control center every so often.

An updated gnome-power-manager package has been submitted to the updates-testing repository for testing. Users experiencing this problem are encouraged to test this update and report to Bodhi whether it solves the problem. To test the update, run this command:
su -c 'yum --enablerepo=updates-testing update gnome-power-manager'