Documentation Java Beat

From FedoraProject

Revision as of 14:13, 24 May 2008 by ImportUser (Talk)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
#!html
==OpenJDK==

Contents

OpenJDK 6

Fedora 9 includes OpenJDK 6, a Free Software implementation of the Java Platform, Standard Edition. OpenJDK 6 is not yet Java compatible; work is underway to certify it.

Fedora will track Sun's stable OpenJDK 6 branch.

OpenJDK Replaces IcedTea

The OpenJDK 6 packages, java-1.6.0-openjdk*, replace their IcedTea counterparts, java-1.7.0-icedtea*. The Fedora 8 IcedTea packages track the unstable OpenJDK 7 branch, whereas the java-1.6.0-openjdk* packages track the stable OpenJDK 6 branch. The decision to have OpenJDK 6 replace IcedTea was made for several reasons:

  • Sun has replaced most of the encumbrances for which IcedTea was providing replacements. For the rest of the encumbrances, replacements have been merged from the IcedTea project.
  • IcedTea's mandate is to merge as much as possible with OpenJDK, so the differences between IcedTea and OpenJDK should diminish over time.
  • OpenJDK 6 is a stable branch, whereas OpenJDK 7 is unstable, and is not expected to ship a stable release until 2009.
  • Sun has licensed the OpenJDK trademark for use in Fedora.
  • Shipping both OpenJDK 6 and IcedTea would have been confusing, and would have added size to the distribution.

IcedTea continues to provide autotools support (autoconf, automake, libtool, and so on), a portable interpreter for PowerPC and 64-bit PowerPC architectures, plugin support, Web Start support, and patches to integrate OpenJDK into Fedora. The IcedTea sources are included in the java-1.6.0-openjdk SRPM.

If IcedTea is already installed, the package changeover does not happen automatically. The packages related to IcedTea based on OpenJDK 7 must first be erased, then the new OpenJDK 6 packages installed.

su -c "yum erase java-1.7.0-icedtea{,-plugin}"
su -c "yum install java-1.6.0-openjdk{,-plugin}"

Handling Java Applets

Upstream OpenJDK does not provide a plugin. The Fedora OpenJDK packages include an adaptation of gcjwebplugin, that runs untrusted applets safely in a Web browser. The plugin is packaged as java-1.6.0-openjdk-plugin.

  • The gcjwebplugin adaptation has no support for the bytecode-to-JavaScript bridge (LiveConnect) . Applets that rely on this bridge will not work. Experimental LiveConnect support exists in the IcedTea repository, but is not ready for deployment in Fedora.
  • The gcjwebplugin adaptation does not support signed applets . Signed applets will run in untrusted mode. Experimental support for signed applets is present in the IcedTea repository, but it is not ready for deployment in Fedora.
  • The gcjwebplugin security policy may be too restrictive. To enable restricted applets, run the firefox -g command in a terminal window to see what is being restricted, and then grant the restricted permission in the /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/security/java.policy file.

Handling Web Start Applications

Upstream OpenJDK does not provide Web Start support. Experimental Web Start support via NetX is present in the IcedTea repository, but is not ready for deployment in Fedora.

Fedora and JPackage

Fedora includes many packages derived from the JPackage Project . Some of these packages are modified in Fedora to remove proprietary software dependencies, and to make use of GCJ's ahead-of-time compilation feature. Use the Fedora repositories to update these packages, or use the JPackage repository for packages not provided by Fedora. Refer to the JPackage website for more information about the project, and the software it provides.

Admonition("warning", "Mixing Packages from Fedora and JPackage", "Research package compatibility before you install software from both the Fedora and JPackage repositories on the same system. Incompatible packages may cause complex issues.")

An incompatibility between Fedora and the JPackage jpackage-utils, that prevented installing JPackage's jpackage-utils on Fedora, is resolved in this release.