Eucalyptus

From FedoraProject

(Difference between revisions)
Jump to: navigation, search
(Packaging Progress)
(Packaging Progress)
Line 107: Line 107:
 
|{{bz|796462}}
 
|{{bz|796462}}
 
|[[User:Gholms|gholms]]
 
|[[User:Gholms|gholms]]
|'''<span style="color:orange">Awaiting Review</span>'''
+
|'''<span style="color:orange">In Review</span>'''
 
|
 
|
 
|-
 
|-
Line 233: Line 233:
 
|{{bz|804048}}
 
|{{bz|804048}}
 
|[[User:Jhernand|jhernand]]
 
|[[User:Jhernand|jhernand]]
|'''<span style="color:orange">Awaiting Review</span>'''
+
|'''<span style="color:green">In Rawhide</span>'''
 
|Direct dep; also blocks mule. Currently only aop, beans, context, expression, instrument, jdbc and transaction modules. More will be added later.
 
|Direct dep; also blocks mule. Currently only aop, beans, context, expression, instrument, jdbc and transaction modules. More will be added later.
 
|-
 
|-

Revision as of 15:39, 19 March 2012

This page is for tracking progress on the packaging of (primarily Java-based) dependencies for Eucalyptus 3.x. This project will have some overlap with JBossAS7. Other required Java packages include:

  • Axiom
  • Google Web Toolkit
  • HA-JDBC
  • Mule

The majority of other required packages are either already part of Fedora or are transitive dependencies of the above dependencies. These packages require large parts of jboss, geronimo, and springframework, among other things.

SPEC and SRPM files up for review will live under https://downloads.eucalyptus.com/software/devel/fedora-17/

Note: this page is focused on java dependencies, but for completeness, there are two other necessary packages which Eucalyptus currently maintains but should submit to Fedora:

  • axis2c (and axis2c-devel)
  • rampartc (and rampartc-devel)

Packaging Progress

These are the packages still in progress which are necessary for the Eucalyptus build:

# Package Version POM Review request Packager Status Comments
1 wss4j 1.5.12 RHBZ #787738 arg In Rawhide
2 aspectjweaver 1.6.12 RHBZ #790519 arg In Rawhide Indirect dep: Blocks spring
3 ha-jdbc 2.0.16 RHBZ #790256 arg In Rawhide Direct dep
4 hamcrest12 1.2 RHBZ #790258 arg In Rawhide Direct dep; also blocks ehcache-core
5 hessian 4.0.7 RHBZ #790551 arg In Rawhide Indirect dep: blocks Spring
6 jamonapi 2.73 RHBZ #791222 arg In Rawhide Indirect dep: blocks Spring
7 xml-maven-plugin RHBZ #782250 ke4qqq In Rawhide Indirect dep; blocks ehcache-core
8 axis2c 1.6.0 RHBZ #735225 gholms In Rawhide
9 rampartc 1.3.0 RHBZ #796462 gholms In Review
10 jexcelapi 2.6.12 RHBZ #791312 arg In Rawhide Indirect dep: blocks Spring
11 axiom 1.2.12 RHBZ #791053 arg In Rawhide Direct dep; also blocks axis2
12 neethi 3.0.1 RHBZ #794941 arg In Rawhide Indirect dep: blocks axis2
13 XmlSchema 1.4.7 RHBZ #794946 arg In Rawhide Indirect dep: blocks axis2
14 apache-commons-ognl 3.0.4 RHBZ #794715 arg In Rawhide Indirect dep: blocks mule. Renamed from ognl to apache-commons-ognl during review.
15 annogen 0.1.0 RHBZ #790990 arg In Rawhide Indirect dep: blocks axis2
16 geronimo-commonj RHBZ #799392 jhernand In Rawhide Indirect dep; blocks spring
17 netty3.1 3.1.5 RHBZ #795492 arg Awaiting Review Direct dep
18 stax-utils 20110309 RHBZ #794923 arg In Review, on hold Indirect dep; blocks mule -- maybe unnecessary?
19 woden 1.0M9 RHBZ #795566 arg In Rawhide Indirect dep: blocks axis2; blocked by axiom, XmlSchema
20 axis2 1.6.1 RHBZ #802549 arg Awaiting Review blocked by neethi, woden, XmlSchema
21 jboss-connector-1.6-api 1.0.1 RHBZ #801614 In Rawhide Direct dep
22 mule 2.0.2 arg Clean-up Required Direct dep
23 springframework 3.1.1 RHBZ #804048 jhernand In Rawhide Direct dep; also blocks mule. Currently only aop, beans, context, expression, instrument, jdbc and transaction modules. More will be added later.
24 hibernate-validator 4.2.0 RHBZ #799976 jhernand In Rawhide Direct dep; also blocks ehcache, hibernate, gwt, ...
25 hibernate3 3.6.10 RHBZ #803546 arg Awaiting Review Direct dep; also blocks ehcache
26 ehcache-core 2.5.1 RHBZ #803558 arg Awaiting Review Direct dep, blocked by hibernate3
27 gwt 2.4.0 arg Clean-up Required Direct dep, blocked by hibernate-validator
28 jsf implementation - Is mojarra ok? 2.1.7 RHBZ #800890 jhernand In Rawhide Indirect dep; blocks spring-web

The above dependencies should be enough the complete most of the required spring modules, including:

  • spring-beans
  • spring-context
  • spring-context-support

I have *not* determined the full list of dependencies required for spring-web, nor the transitive dependencies for myfaces-core. From the pom, it appears spring-web will need:

  • javax.portlet:portlet-api
  • axis2-saaj-api (but I suspect this is optional)

Optional dependencies and sub-dependencies

ActiveMQ and JasperReports are only necessary for reporting, which, while it's a nice new feature of Eucalyptus 3, can easily be omitted from the build.

Infinispan dependencies

  • rhq

ActiveMQ 5 dependencies:

  • easymock-classextension
  • spring 2
  • apacheds
  • etc. (I am unsure of the full dep chain at this time

JasperReports dependencies:

  • barcode4j
  • eigenbase-properties (for mondrian)
  • eigenbase-resgen (for mondrian)
  • jexcelapi
  • olap4j (for mondrian)
  • TODO: mondrian
  • TODO: commons-javaflow
  • TODO: png-encoder
  • TODO: barbecue
  • TODO: jdt-compiler (is this already in as part of eclipse??)
  • TODO: hibernate