Features/Blender25

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Mark Feater 'Ready for Wrangler')
(Add addtional package req. blender. More progressive contigency plan.)
Line 10: Line 10:
 
== current Status ==
 
== current Status ==
 
* Targedted Release: [[Release/16/Schedule|Fedora 16]]
 
* Targedted Release: [[Release/16/Schedule|Fedora 16]]
* Last Update: 2011-04-12
+
* Last Update: 2011-05-17
 
* Percentage of completion: 30%
 
* Percentage of completion: 30%
  
Line 41: Line 41:
 
LuxRender
 
LuxRender
 
YafaRay
 
YafaRay
 +
yofrankie-bge
 
</pre>
 
</pre>
  
Line 48: Line 49:
  
 
== Documentation ==
 
== Documentation ==
Documentation may be found on the developement page of the blender project:
+
Create a blender249 package which can use for the packages which could not
 +
migrated to blender-2.57b or above.
  
 
[http://www.blender.org/Development/ Blender Devlopment Page]
 
[http://www.blender.org/Development/ Blender Devlopment Page]

Revision as of 16:40, 17 May 2011

Contents

Update to Blender 2.5 serires

This feature bring blender-2.57 or later on Fedora 16. the aim of the blender 2.5 project is to provide a new release of blender with a new desingned UI. Enhanced tools and animations.

Owner

current Status

  • Targedted Release: Fedora 16
  • Last Update: 2011-05-17
  • Percentage of completion: 30%

Detailed Description

Blender-2.5 provide a new designed UI and tools. It's based on python-3.2 and have a changed ABI for third-party scripts.

Currently existng packages which depend on blender have to migrate to make sure, that they are works together with this new release.

One packaging related change is the move of the script directory to %{_datadir}/blender/<BLENDERVERSION>/scripts. Additionaly there is no need for a wrapper which created symlinks in the ~/.blender directory anymore.


Benefit for Fedora

Providing a release of blender which was ported to python-3.2 or above.

How to Test

  • Try out primary blender package
  • Try out addon packages which require blender

User Experience

  • New improved user interface
  • new tools.

Depecdencies

There are two packages wich requires blender:

LuxRender
YafaRay
yofrankie-bge


Contigency Plan

Revert to blender-2.49b. Provide additional blender25 package if possible.

Documentation

Create a blender249 package which can use for the packages which could not migrated to blender-2.57b or above.

Blender Devlopment Page

Release Notes

Blender-2.5 provides a new release of blender with a new desingned user Interface and tools which is based on python-3.2.