Features/F19Boost153/RebuildProcess

From FedoraProject

Jump to: navigation, search

Contents

Reference

Dependent packages

The dependent packages are derived from:

BOOST_DEPLIST=`repoquery --whatrequires boost\* --source | uniq`
rm -f boost_deplist_pack.txt
for _pack in $BOOST_DEPLIST
do
  echo ${_pack} | grep -v "boost" | sed -e "s/^\(.\+\)-\([0-9]\+\).\([0-9a-z.]\+\)-\(.\+\)\.fc\([0-9]\+\)\(.*\)\.src\.rpm$/\1/g" >> boost_deplist_pack.txt
done
uniq boost_deplist_pack.txt > boost_deplist_pack_uniq.txt
rm -f boost_deplist_pack.txt
NB_PACKS=`wc -l boost_deplist_pack_uniq.txt| cut -d' ' -f1`
echo "To browse the list of (${NB_PACKS}) packages depending on Boost, just do:"
echo "less boost_deplist_pack_uniq.txt"

0-9

0ad

A-B

adobe-source-libraries
airinv
airrac
airsched
akonadi
aqsis
armadillo
asc
asio
avogadro
barry
bastet
blender
bombono-dvd

C-E

cclive
cegui
CGAL
collada-dom
condor
curlpp
diet
dmlite
dolphin-connector
dyninst
easystroke
ekiga
ember
enblend
esteid-browser-plugin

F-G

fatrat
fawkes
Field3D
fife
flann
FlightCrew
flowcanvas
flush
freecad
frogatto
fusecompress
fuse-encfs
gearmand
glob2
glogg
glom
gnash
gnuradio
gource
guitarix

H-L

HippoDraw
hugin
iwhd
k3d
kalzium
kdepimlibs
kdepim-runtime
kdevplatform
kig
leechcraft
libcmis
libkolab
libkolabxml
liborcus
libpst
libreoffice
licq
lightspark
LuxRender
lyx

M-O

mapnik
mbox2eml
mdds
milia
minion
mkvtoolnix
mlpack
mmseq
mongodb
mrpt
mygui
nss-gui
ogre
ompl
OpenImageIO
openlierox
openscad

P-Q

pathfinder
pcl
pdns
permlib
pingus
pion-net
player
plee-the-bear
pokerth
polybori
pyexiv2
pymilia
python-tag
python-visual
qbittorrent
qpid-cpp
qt-gstreamer
QuantLib

R-S

rb_libtorrent
rcsslogplayer
rcssmonitor
rcssserver
rcssserver3d
rmol
roboptim-core
roboptim-trajectory
rocs
schroot
sevmgr
sigil
simcrs
simfqt
simspark
smc
source-highlight
spring
springlobby
stdair
swift
sympol

T-Z

tncfhh
trademgen
travelccm
twinkle
uhd
undertaker
urg
vegastrike
vigra
votca-csg
votca-tools
wesnoth
wt
xmms2
xsd
xylib
zarafa

Failed builds

Because of Boost

libboost-system-mt-1.50.0 dependency issue

Compilation issue

FTBFS (because of other reasons)