Features/HalRemoval

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Other packages outside the DVD: Add rel-eng ticket for ohm)
(General tasks)
 
(25 intermediate revisions by 2 users not shown)
Line 5: Line 5:
 
== Summary ==
 
== Summary ==
  
HAL is a behemoth, do-it-all, daemon to access hardware. It is now [http://lists.freedesktop.org/archives/hal/2008-May/011560.html obsoleted] by udisks (né DeviceKit-disks) and upower (né DeviceKit-power), as well as libudev for device discovery.
+
HAL is a behemoth, do-it-all, daemon to access hardware. It is now [http://lists.freedesktop.org/archives/hal/2008-May/011560.html obsoleted] by {{package|udisks}} and {{package|upower}}, as well as libudev for device discovery.
  
 
See also:
 
See also:
Line 24: Line 24:
 
== Current status ==
 
== Current status ==
 
* Targeted release: [[Releases/16 | Fedora 16]]  
 
* Targeted release: [[Releases/16 | Fedora 16]]  
* Last updated: 2011-07-28
+
* Last updated: 2011-09-27
* Percentage of completion: 95%
+
* Percentage of completion: 100%
  
This feature originally proposed the removal of HAL from the Fedora Desktop spin. This goal has already been accomplished and we also completed the removal from the Fedora DVD. In the meantime, hal package maintainer deprecated it for Fedora 16, and later it was also blocked from composes. So, unless somebody volunteers to maintain it again, this feature will track the complete removal of HAL from the distribution.
+
This feature originally proposed the removal of HAL from the Fedora Desktop spin. This goal has already been accomplished and we also completed the removal from the Fedora DVD. In the meantime, {{package|hal}} package maintainer deprecated it for Fedora 16, and later it was also blocked from composes. So this feature is tracking the complete removal of HAL from the distribution.
  
 
== Detailed Description ==
 
== Detailed Description ==
Line 34: Line 34:
  
 
<pre>
 
<pre>
$ repoquery --repofrompath=fedora-rawhide-i386,http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/ --repoid=fedora-rawhide-i386 --qf '%{NAME}' --whatrequires hal hal-devel hal-info hal-libs hal-storage-addon | sort -u
+
$ repoquery --repofrompath=fedora-16-i386,http://download.fedoraproject.org/pub/fedora/linux/development/16/i386/os/ --repoid=fedora-16-i386 --qf '%{NAME}' --whatrequires hal hal-devel hal-info hal-libs hal-storage-addon | sort -u
 
</pre>
 
</pre>
  
Line 41: Line 41:
 
! Task !! Status !! Bug reports or discussions
 
! Task !! Status !! Bug reports or discussions
 
|-
 
|-
| Block <code>hal</code> from composes || done || <s>[https://fedorahosted.org/rel-eng/ticket/4557 rel-eng ticket 4557]</s>
+
| Block {{package|hal}} from composes || done || <del>[https://fedorahosted.org/rel-eng/ticket/4557 rel-eng ticket 4557]</del>
 
|-
 
|-
| Block <code>hal-info</code> from composes || done || <s>[https://fedorahosted.org/rel-eng/ticket/4724 rel-eng ticket 4724]</s>
+
| Block {{package|hal-info}} from composes || done || <del>[https://fedorahosted.org/rel-eng/ticket/4724 rel-eng ticket 4724]</del>
 
|-
 
|-
| Remove references to hal in kickstart files || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=706505 Fedora bug 706505]</s>
+
| Remove references to hal in kickstart files || done || <del>[[rhbug:706505|Fedora bug 706505]]</del>
 
|}
 
|}
  
Line 53: Line 53:
 
! Package name !! Status !! Bug reports or discussions
 
! Package name !! Status !! Bug reports or discussions
 
|-
 
|-
| abrt-gui || done || <s>Requires <code>gnome-python2-gnomevfs</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=652423 Fedora bug 652423]</s>)
+
| {{package|abrt}} || done || <del><code>abrt-gui</code> subpackage requires <code>gnome-python2-gnomevfs</code></del> (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=652423 Fedora bug 652423]</del>)
 
|-
 
|-
| cheese || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=594966 upstream bug 594966]</s>
+
| {{package|cheese}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=594966 upstream bug 594966]</del>
 
|-
 
|-
| evolution || done ||
+
| {{package|evolution}} || done ||
 
|-
 
|-
| evolution-data-server || done ||  
+
| {{package|evolution-data-server}} || done ||  
 
|-
 
|-
| gdm || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=572765 upstream bug 572765]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=567432 Fedora bug 567432]</s>
+
| {{package|gdm}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=572765 upstream bug 572765]</del>, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=567432 Fedora bug 567432]</del>
 
|-
 
|-
| gnome-power-manager || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=593933 upstream bug 593933]</s>
+
| {{package|gnome-power-manager}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=593933 upstream bug 593933]</del>
 
|-
 
|-
| gnome-vfs2 || done || GnomeVFS has been deprecated since 2008, applications should use gvfs instead. Since >100 other packages depend on <code>gnome-vfs2</code>, its HAL support was disabled (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=698638 Fedora bug 698638]</s>), as was recently done also by Debian (<s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599020 Debian bug 599020]</s>), but the [http://lists.fedoraproject.org/pipermail/devel/2011-March/149572.html goal] is to get rid of GnomeVFS too.
+
| {{package|gnome-vfs2}} || done || GnomeVFS has been deprecated since 2008, applications should use {{package|gvfs}} instead. Since >80 other packages still depend on <code>gnome-vfs2</code>, its HAL support was disabled (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=698638 Fedora bug 698638]</del>), as was recently done also by Debian (<del>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599020 Debian bug 599020]</del>), but the [http://lists.fedoraproject.org/pipermail/devel/2011-March/149572.html goal] is to get rid of GnomeVFS too.
 
|-
 
|-
| gstreamer-plugins-good || done ||
+
| {{package|gstreamer-plugins-good}} || done ||
 
|-
 
|-
| gvfs || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=586410 upstream bug 586410]</s>
+
| {{package|gvfs}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=586410 upstream bug 586410]</del>, <del>[https://bugzilla.gnome.org/show_bug.cgi?id=586411 upstream bug 586411]</del> and [https://bugzilla.gnome.org/show_bug.cgi?id=511671 upstream bug 511671]
 
|-
 
|-
| gvfs-obexftp || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=586411 upstream bug 586411]</s> and [https://bugzilla.gnome.org/show_bug.cgi?id=511671 upstream bug 511671]
+
| {{package|hal-info}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=700446 Fedora bug 700446]</del>
 
|-
 
|-
| hal-info || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=700446 Fedora bug 700446]</s>
+
| {{package|libfprint}} || done || <del>Requires <code>hal-filesystem</code></del>
 
|-
 
|-
| libfprint || done || <s>Requires <code>hal-filesystem</code></s>
+
| {{package|libgpod}} || done ||
 
|-
 
|-
| libgpod || done ||
+
| {{package|libmtp}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=711422 Fedora bug 711422]</del>
 
|-
 
|-
| libmtp || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=711422 Fedora bug 711422]</s>
+
| {{package|pm-utils}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=636382 Fedora bug 636382]</del>
 
|-
 
|-
| pm-utils || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=636382 Fedora bug 636382]</s>
+
| {{package|rhythmbox}} || done || <del>Requires <code>hal-libs</code></del> (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=597202 Fedora bug 597202]</del>) <del>and <code>gnome-vfs2</code></del> (<del>[https://bugzilla.gnome.org/show_bug.cgi?id=604186 upstream bug 604186]</del>)
 
|-
 
|-
| rhythmbox || done || <s>Requires <code>hal-libs</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=597202 Fedora bug 597202]</s>) <s>and <code>gnome-vfs2</code></s> (<s>[https://bugzilla.gnome.org/show_bug.cgi?id=604186 upstream bug 604186]</s>)
+
| {{package|setroubleshoot}} || done || <del>Requires <code>gnome-python2-gnome</code></del> (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=678543 Fedora bug 678543]</del>)
 
|-
 
|-
| setroubleshoot || done || <s>Requires <code>gnome-python2-gnome</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=678543 Fedora bug 678543]</s>)
+
| {{package|smolt}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=634883 Fedora bug 634883]</del>
 
|-
 
|-
| smolt || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=634883 Fedora bug 634883]</s>
+
| {{package|system-setup-keyboard}} || done ||
 
|-
 
|-
| system-setup-keyboard || done ||
+
| {{package|xorg-x11-server}} || done ||  
 
|-
 
|-
| xorg-x11-server-Xorg || done ||
+
| {{package|xulrunner}} || done || <del>Requires <code>gnome-vfs2</code></del> (<del>[https://bugzilla.mozilla.org/show_bug.cgi?id=494163 upstream bug 494163]</del>)
|-
+
| xulrunner || done || <s>Requires <code>gnome-vfs2</code></s> (<s>[https://bugzilla.mozilla.org/show_bug.cgi?id=494163 upstream bug 494163]</s>)
+
 
|}
 
|}
  
Line 101: Line 99:
 
! Package name !! Status !! Bug reports or discussions
 
! Package name !! Status !! Bug reports or discussions
 
|-
 
|-
| amarok || done || Works fine without <code>libmtp-hal</code> on F15/F16 (which is needed on F14 for some reason)
+
| {{package|amarok}} || done || Works fine without <code>libmtp-hal</code> on F15/F16 (which is needed on F14 for some reason)
 
|-
 
|-
| blueman || done || [https://bugzilla.redhat.com/show_bug.cgi?id=561019 Fedora bug 561019]
+
| {{package|blueman}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=561019 Fedora bug 561019]</del>
 
|-
 
|-
| eclipse || done || <s>Requires <code>gnome-vfs2</code></s>, <s>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=333759 upstream bug 333759]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=667998 Fedora bug 667998]</s>
+
| {{package|eclipse}} || done || <del>Requires <code>gnome-vfs2</code></del>, <del>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=333759 upstream bug 333759]</del>, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=667998 Fedora bug 667998]</del>
 
|-
 
|-
| exo || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=699714 Fedora bug 699714]</s>
+
| {{package|exo}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=699714 Fedora bug 699714]</del>
 
|-
 
|-
| gimp || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=592364 upstream bug 592364]</s>
+
| {{package|gimp}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=592364 upstream bug 592364]</del>
 
|-
 
|-
| glade3-libgladeui || done || <s>Requires <code>gnome-vfs2</code></s>
+
| {{package|glade3}} || done || <del><code>glade3-libgladeui</code> subpackage requires <code>gnome-vfs2</code></del>
 
|-
 
|-
| gnome-pilot || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=593936 upstream bug 593936]</s>
+
| {{package|gnome-pilot}} || done || <del>[https://bugzilla.gnome.org/show_bug.cgi?id=593936 upstream bug 593936]</del>
 
|-
 
|-
| hplip || done || [https://bugs.launchpad.net/hplip/+bug/401091 upstream bug 401091]
+
| {{package|hplip}} || done || [https://bugs.launchpad.net/hplip/+bug/401091 upstream bug 401091]
 
|-
 
|-
| k3b || done ||
+
| {{package|k3b}} || done ||
 
|-
 
|-
| kdebase-runtime || done ||
+
| {{package|kdebase-runtime}} || done ||
 
|-
 
|-
| kdelibs || done ||
+
| {{package|kdelibs}} || done ||
 
|-
 
|-
| libvirt || done ||
+
| {{package|libvirt}} || done ||
 
|-
 
|-
| lxsession || done || <s>[http://sourceforge.net/tracker/index.php?func=detail&aid=2987941&group_id=180858&atid=894872 upstream bug]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=688959 Fedora bug 688959]</s>
+
| {{package|lxsession}} || done || <del>[http://sourceforge.net/tracker/index.php?func=detail&aid=2987941&group_id=180858&atid=894872 upstream bug]</del>, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=688959 Fedora bug 688959]</del>
 
|-
 
|-
| pcmanfm || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=698652 Fedora bug 698652]</s>
+
| {{package|pcmanfm}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=698652 Fedora bug 698652]</del>
 
|-
 
|-
| pcsc-lite || done || <s>Requires <code>hal-libs</code></s>, <s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587979 Debian bug 587979]</s>
+
| {{package|pcsc-lite}} || done || <del>Requires <code>hal-libs</code></del>, <del>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587979 Debian bug 587979]</del>
 
|-
 
|-
| Thunar || done ||
+
| {{package|Thunar}} || done ||
 
|-
 
|-
| thunar-volman || done ||
+
| {{package|thunar-volman}} || done ||
 
|-
 
|-
| xine-lib || done ||
+
| {{package|xine-lib}} || done ||
 
|}
 
|}
  
Line 143: Line 141:
 
! Package name !! Status !! Bug reports or discussions
 
! Package name !! Status !! Bug reports or discussions
 
|-
 
|-
| beldi || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=698656 Fedora bug 698656]</s>
+
| {{package|beldi}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=698656 Fedora bug 698656]</del>
 
|-
 
|-
| camcardsync || done || Dead upstream, leaf package, deprecated (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=698662 Fedora bug 698662]</s>)
+
| {{package|camcardsync}} || done || Dead upstream, leaf package, deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=698662 Fedora bug 698662]</del>)
 
|-
 
|-
| epiphany || done ||
+
| {{package|epiphany}} || done ||
 
|-
 
|-
| exaile || TODO || Leaf package ([https://bugs.launchpad.net/exaile/+bug/625209 upstream bug 625209], [https://bugzilla.redhat.com/show_bug.cgi?id=698667 Fedora bug 698667])
+
| {{package|exaile}} || done || [https://bugs.launchpad.net/exaile/+bug/625209 upstream bug 625209], <del>[https://bugzilla.redhat.com/show_bug.cgi?id=698667 Fedora bug 698667]</del>
 
|-
 
|-
| gnomad2 || done || <s>Requires <code>hal-libs</code> and <code>libmtp-hal</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=677323 Fedora bug 677323]</s>)
+
| {{package|gnomad2}} || done || <del>Requires <code>hal-libs</code> and <code>libmtp-hal</code></del> (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=677323 Fedora bug 677323]</del>)
 
|-
 
|-
| gnome-device-manager || done || Dead upstream, leaf package, deprecated (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=698685 Fedora bug 698685]</s>, <s>[https://fedorahosted.org/rel-eng/ticket/4845 rel-eng ticket 4845]</s>)
+
| {{package|gnome-device-manager}} || done || Dead upstream, leaf package, deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=698685 Fedora bug 698685]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4845 rel-eng ticket 4845]</del>)
 
|-
 
|-
| gparted || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=586377 Fedora bug 586377]</s>
+
| {{package|gparted}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=586377 Fedora bug 586377]</del>
 
|-
 
|-
| gxine || done ||
+
| {{package|gxine}} || done ||
 
|-
 
|-
| halevt || TODO || Dead upstream, leaf package ([https://bugzilla.redhat.com/show_bug.cgi?id=700405 Fedora bug 700405]), [[FTBFS]]
+
| {{package|halevt}} || done || Dead upstream, leaf package, deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=700405 Fedora bug 700405]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4928 rel-eng ticket 4928]</del>)
 
|-
 
|-
| ifuse || done ||
+
| {{package|ifuse}} || done ||
 
|-
 
|-
| libconcord || done ||
+
| {{package|libconcord}} || done ||
 
|-
 
|-
| librapi || done ||
+
| {{package|librapi}} || done ||
 
|-
 
|-
| libsynce || done ||
+
| {{package|libsynce}} || done ||
 
|-
 
|-
| matahari || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=677367 Fedora bug 677367]</s>
+
| {{package|matahari}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=677367 Fedora bug 677367]</del>
 
|-
 
|-
| nut || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=698134 Fedora bug 698134]</s>
+
| {{package|nut}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=698134 Fedora bug 698134]</del>
 
|-
 
|-
| odccm || TODO || [http://www.synce.org/moin/ComponentOverview#odccm Deprecated upstream], partially obsoleted by <code>synce-hal</code>, will be deprecated/obsoleted by under-review package <code>synce-connector</code> ([https://bugzilla.redhat.com/show_bug.cgi?id=701257 Fedora bug 701257]), [[FTBFS]]
+
| {{package|odccm}} || done || [http://www.synce.org/moin/ComponentOverview#odccm Deprecated upstream], obsoleted by new package <code>synce-connector</code>, deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=701257 Fedora bug 701257]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4895 rel-eng ticket 4895]</del>)
 
|-
 
|-
| ohm || TODO || Dead upstream, leaf package, deprecated ([https://bugzilla.redhat.com/show_bug.cgi?id=698964 Fedora bug 698964], [https://fedorahosted.org/rel-eng/ticket/4871 rel-eng ticket 4871])
+
| {{package|ohm}} || done || Dead upstream, leaf package, deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=698964 Fedora bug 698964]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4871 rel-eng ticket 4871]</del>)
 
|-
 
|-
| olpc-kbdshim || TODO || [http://dev.laptop.org/ticket/10980 upstream bug 10980], [https://bugzilla.redhat.com/show_bug.cgi?id=700866 Fedora bug 700866], [http://dev.laptop.org/git/users/pgf/olpc-kbdshim/commit/?id=2af9d5be2475531bcbb7c144cac925244003116b fixed upstream in version 18], [[FTBFS]]
+
| {{package|olpc-kbdshim}} || done || <del>[http://dev.laptop.org/ticket/10980 upstream bug 10980]</del>, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=700866 Fedora bug 700866]</del>
 
|-
 
|-
| ovirt-server || done || [https://fedorahosted.org/ovirt/wiki/FAQ Dead upstream], deprecated (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=700455 Fedora bug 700455]</s>, <s>[https://fedorahosted.org/rel-eng/ticket/4843 rel-eng ticket 4843]</s>)
+
| {{package|ovirt-server}} || done || [https://fedorahosted.org/ovirt/wiki/FAQ Dead upstream], deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=700455 Fedora bug 700455]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4843 rel-eng ticket 4843]</del>)
 
|-
 
|-
| oxine || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=700758 Fedora bug 700758]</s>
+
| {{package|oxine}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=700758 Fedora bug 700758]</del>
 
|-
 
|-
| pmount || done ||
+
| {{package|pmount}} || done ||
 
|-
 
|-
| razertool || done || Deprecated (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=700756 Fedora bug 700756]</s>, <s>[https://fedorahosted.org/rel-eng/ticket/4766 rel-eng ticket 4766]</s>)
+
| {{package|razertool}} || done || Deprecated (<del>[https://bugzilla.redhat.com/show_bug.cgi?id=700756 Fedora bug 700756]</del>, <del>[https://fedorahosted.org/rel-eng/ticket/4766 rel-eng ticket 4766]</del>)
 
|-
 
|-
| synce-hal || TODO || Will be deprecated/obsoleted by under-review package <code>synce-connector</code> ([https://bugzilla.redhat.com/show_bug.cgi?id=678728 Fedora bug 678728]), [[FTBFS]]
+
| {{package|synce-hal}} || done || Obsoleted by new package <code>synce-connector</code>, deprecated (<del>[https://fedorahosted.org/rel-eng/ticket/4895 rel-eng ticket 4895]</del>)
 
|-
 
|-
| synce-trayicon || done ||
+
| {{package|synce-trayicon}} || done ||
 
|-
 
|-
| thunar-vfs || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=699682 Fedora bug 699682]</s>
+
| {{package|thunar-vfs}} || done || <del>[https://bugzilla.redhat.com/show_bug.cgi?id=699682 Fedora bug 699682]</del>
 
|-
 
|-
| xchat-gnome || done || <s>Requires <code>gnome-vfs2</code></s>
+
| {{package|xchat-gnome}} || done || <del>Requires <code>gnome-vfs2</code></del>
 
|-
 
|-
| xfburn || done || <s>[http://bugzilla.xfce.org/show_bug.cgi?id=5965 upstream bug 5965]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=699692 Fedora bug 699692]</s>
+
| {{package|xfburn}} || done || <del>[http://bugzilla.xfce.org/show_bug.cgi?id=5965 upstream bug 5965]</del>, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=699692 Fedora bug 699692]</del>
 
|-
 
|-
| xfce4-cddrive-plugin || done || Dead upstream, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=707783 Fedora bug 707783]</s>
+
| {{package|xfce4-cddrive-plugin}} || done || Dead upstream, <del>[https://bugzilla.redhat.com/show_bug.cgi?id=707783 Fedora bug 707783]</del>
 
|-
 
|-
| xfce4-power-manager || done ||
+
| {{package|xfce4-power-manager}} || done ||
 
|-
 
|-
| xfce4-volstatus-icon || done || Deprecated since Fedora 15
+
| {{package|xfce4-volstatus-icon}} || done || Deprecated since Fedora 15
 
|}
 
|}
  
Line 215: Line 213:
  
 
Need to test:
 
Need to test:
* '''yum remove hal-filesystem hal-libs'''
+
* <code>yum remove hal-filesystem hal-libs</code>
 
* Check that nothing gets removed because it depends on hal
 
* Check that nothing gets removed because it depends on hal
 
* Check that applications that access hardware still work as before
 
* Check that applications that access hardware still work as before
Line 236: Line 234:
  
 
== Release Notes ==
 
== Release Notes ==
* Fedora now does not ship with the HAL daemon, and libhal by default. If a specific application require libhal to function, please file a bug against it to be ported to the new technology.
+
HAL, a hardware abstraction layer which has been a deprecated component for several releases, has been completely removed from Fedora. Software components using HAL have moved over to using '''udisks''' and '''upower''' as well as '''libudev''' for device discovery. This results in faster system bootup and faster startup for applications depending on device discovery.
  
 
== Comments and Discussion ==
 
== Comments and Discussion ==

Latest revision as of 15:08, 9 January 2012


Contents

[edit] HAL Removal

[edit] Summary

HAL is a behemoth, do-it-all, daemon to access hardware. It is now obsoleted by Package-x-generic-16.pngudisks and Package-x-generic-16.pngupower, as well as libudev for device discovery.

See also:

GNOME upstream tracker

Ubuntu tracker

Debian tracker

[edit] Owner

[edit] Current status

  • Targeted release: Fedora 16
  • Last updated: 2011-09-27
  • Percentage of completion: 100%

This feature originally proposed the removal of HAL from the Fedora Desktop spin. This goal has already been accomplished and we also completed the removal from the Fedora DVD. In the meantime, Package-x-generic-16.pnghal package maintainer deprecated it for Fedora 16, and later it was also blocked from composes. So this feature is tracking the complete removal of HAL from the distribution.

[edit] Detailed Description

To generate the list of packages still depending on hal in rawhide:

$ repoquery --repofrompath=fedora-16-i386,http://download.fedoraproject.org/pub/fedora/linux/development/16/i386/os/ --repoid=fedora-16-i386 --qf '%{NAME}' --whatrequires hal hal-devel hal-info hal-libs hal-storage-addon | sort -u

[edit] General tasks

Task Status Bug reports or discussions
Block Package-x-generic-16.pnghal from composes done rel-eng ticket 4557
Block Package-x-generic-16.pnghal-info from composes done rel-eng ticket 4724
Remove references to hal in kickstart files done Fedora bug 706505

[edit] Packages in the Desktop spin

Package name Status Bug reports or discussions
Package-x-generic-16.pngabrt done abrt-gui subpackage requires gnome-python2-gnomevfs (Fedora bug 652423)
Package-x-generic-16.pngcheese done upstream bug 594966
Package-x-generic-16.pngevolution done
Package-x-generic-16.pngevolution-data-server done
Package-x-generic-16.pnggdm done upstream bug 572765, Fedora bug 567432
Package-x-generic-16.pnggnome-power-manager done upstream bug 593933
Package-x-generic-16.pnggnome-vfs2 done GnomeVFS has been deprecated since 2008, applications should use Package-x-generic-16.pnggvfs instead. Since >80 other packages still depend on gnome-vfs2, its HAL support was disabled (Fedora bug 698638), as was recently done also by Debian (Debian bug 599020), but the goal is to get rid of GnomeVFS too.
Package-x-generic-16.pnggstreamer-plugins-good done
Package-x-generic-16.pnggvfs done upstream bug 586410, upstream bug 586411 and upstream bug 511671
Package-x-generic-16.pnghal-info done Fedora bug 700446
Package-x-generic-16.pnglibfprint done Requires hal-filesystem
Package-x-generic-16.pnglibgpod done
Package-x-generic-16.pnglibmtp done Fedora bug 711422
Package-x-generic-16.pngpm-utils done Fedora bug 636382
Package-x-generic-16.pngrhythmbox done Requires hal-libs (Fedora bug 597202) and gnome-vfs2 (upstream bug 604186)
Package-x-generic-16.pngsetroubleshoot done Requires gnome-python2-gnome (Fedora bug 678543)
Package-x-generic-16.pngsmolt done Fedora bug 634883
Package-x-generic-16.pngsystem-setup-keyboard done
Package-x-generic-16.pngxorg-x11-server done
Package-x-generic-16.pngxulrunner done Requires gnome-vfs2 (upstream bug 494163)

[edit] Other packages in the DVD

Package name Status Bug reports or discussions
Package-x-generic-16.pngamarok done Works fine without libmtp-hal on F15/F16 (which is needed on F14 for some reason)
Package-x-generic-16.pngblueman done Fedora bug 561019
Package-x-generic-16.pngeclipse done Requires gnome-vfs2, upstream bug 333759, Fedora bug 667998
Package-x-generic-16.pngexo done Fedora bug 699714
Package-x-generic-16.pnggimp done upstream bug 592364
Package-x-generic-16.pngglade3 done glade3-libgladeui subpackage requires gnome-vfs2
Package-x-generic-16.pnggnome-pilot done upstream bug 593936
Package-x-generic-16.pnghplip done upstream bug 401091
Package-x-generic-16.pngk3b done
Package-x-generic-16.pngkdebase-runtime done
Package-x-generic-16.pngkdelibs done
Package-x-generic-16.pnglibvirt done
Package-x-generic-16.pnglxsession done upstream bug, Fedora bug 688959
Package-x-generic-16.pngpcmanfm done Fedora bug 698652
Package-x-generic-16.pngpcsc-lite done Requires hal-libs, Debian bug 587979
Package-x-generic-16.pngThunar done
Package-x-generic-16.pngthunar-volman done
Package-x-generic-16.pngxine-lib done

[edit] Other packages outside the DVD

Package name Status Bug reports or discussions
Package-x-generic-16.pngbeldi done Fedora bug 698656
Package-x-generic-16.pngcamcardsync done Dead upstream, leaf package, deprecated (Fedora bug 698662)
Package-x-generic-16.pngepiphany done
Package-x-generic-16.pngexaile done upstream bug 625209, Fedora bug 698667
Package-x-generic-16.pnggnomad2 done Requires hal-libs and libmtp-hal (Fedora bug 677323)
Package-x-generic-16.pnggnome-device-manager done Dead upstream, leaf package, deprecated (Fedora bug 698685, rel-eng ticket 4845)
Package-x-generic-16.pnggparted done Fedora bug 586377
Package-x-generic-16.pnggxine done
Package-x-generic-16.pnghalevt done Dead upstream, leaf package, deprecated (Fedora bug 700405, rel-eng ticket 4928)
Package-x-generic-16.pngifuse done
Package-x-generic-16.pnglibconcord done
Package-x-generic-16.pnglibrapi done
Package-x-generic-16.pnglibsynce done
Package-x-generic-16.pngmatahari done Fedora bug 677367
Package-x-generic-16.pngnut done Fedora bug 698134
Package-x-generic-16.pngodccm done Deprecated upstream, obsoleted by new package synce-connector, deprecated (Fedora bug 701257, rel-eng ticket 4895)
Package-x-generic-16.pngohm done Dead upstream, leaf package, deprecated (Fedora bug 698964, rel-eng ticket 4871)
Package-x-generic-16.pngolpc-kbdshim done upstream bug 10980, Fedora bug 700866
Package-x-generic-16.pngovirt-server done Dead upstream, deprecated (Fedora bug 700455, rel-eng ticket 4843)
Package-x-generic-16.pngoxine done Fedora bug 700758
Package-x-generic-16.pngpmount done
Package-x-generic-16.pngrazertool done Deprecated (Fedora bug 700756, rel-eng ticket 4766)
Package-x-generic-16.pngsynce-hal done Obsoleted by new package synce-connector, deprecated (rel-eng ticket 4895)
Package-x-generic-16.pngsynce-trayicon done
Package-x-generic-16.pngthunar-vfs done Fedora bug 699682
Package-x-generic-16.pngxchat-gnome done Requires gnome-vfs2
Package-x-generic-16.pngxfburn done upstream bug 5965, Fedora bug 699692
Package-x-generic-16.pngxfce4-cddrive-plugin done Dead upstream, Fedora bug 707783
Package-x-generic-16.pngxfce4-power-manager done
Package-x-generic-16.pngxfce4-volstatus-icon done Deprecated since Fedora 15

[edit] Benefit to Fedora

Faster boot-up, and removal of obsoleted technology.

[edit] Scope

Loads of applications require HAL itself, or libhal. Applications should not rely on HAL, or libhal being available.

[edit] How To Test

Need to test:

  • yum remove hal-filesystem hal-libs
  • Check that nothing gets removed because it depends on hal
  • Check that applications that access hardware still work as before

[edit] User Experience

  • Faster boot-up
  • Possibly faster applications startup when switching from libhal to libgudev for device enumeration

[edit] Dependencies

  • See description

[edit] Contingency Plan

  • Undeprecate hal.

[edit] Documentation

N/A

[edit] Release Notes

HAL, a hardware abstraction layer which has been a deprecated component for several releases, has been completely removed from Fedora. Software components using HAL have moved over to using udisks and upower as well as libudev for device discovery. This results in faster system bootup and faster startup for applications depending on device discovery.

[edit] Comments and Discussion