Features/Java-Gnome4

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Release Notes)
(Contingency Plan)
Line 63: Line 63:
 
== Contingency Plan ==
 
== Contingency Plan ==
 
<!-- If you cannot complete your feature by the final development freeze, what is the backup plan?  This might be as simple as "None necessary, revert to previous release behaviour."  Or it might not.  If you feature is not completed in time we want to assure others that other parts of Fedora will not be in jeopardy.  -->
 
<!-- If you cannot complete your feature by the final development freeze, what is the backup plan?  This might be as simple as "None necessary, revert to previous release behaviour."  Or it might not.  If you feature is not completed in time we want to assure others that other parts of Fedora will not be in jeopardy.  -->
* FIXME
+
* None: Packages that cannot be build against 4.x stack must be pointed to compat-java-gnome (current stack)
 +
* If something really go to hell, remove java-gnome 4.x stack and back to current stack (2.x)
  
 
== Documentation ==
 
== Documentation ==

Revision as of 01:29, 26 November 2009

Contents

Java-Gnome 4.x

Summary

Fedora is currently including part of 2.x java-gnome stack. The idea is to include 4.x stack and move 2.x to compat-. due to incompatibility between apis.

Owner

  • email: ottorey@gmail.com

Current status

  • Targeted release: Fedora 13
  • Last Updated: 2009-11-25
  • Percentage of completion: 0%

Detailed Description

Java-gnome is a Gtk wrapper/implementation for Java Applications that allow to develop gtk applications using Java. To stay in sync with Upstream, we need to move to 4.x release.

Benefit to Fedora

Stay in sync with upstream with latest patches, features and add capabilities to Java-Gtk applications

Scope

Changes to do:

  • Build 4.x version packages as java-gnome
  • Move 2.x stack to compat-java-gnome
  • List packages with depends on the current version of stack (2.x)
  • Build packages against 4.x stack if it possible
  • Packages that not fit with 4.x must be marked to depends on compat-

How To Test

  • FIXME

User Experience

  • FIXME

Dependencies

  • FIXME

Contingency Plan

  • None: Packages that cannot be build against 4.x stack must be pointed to compat-java-gnome (current stack)
  • If something really go to hell, remove java-gnome 4.x stack and back to current stack (2.x)

Documentation

  • FIXME

Release Notes

Comments and Discussion