Features/Ruby 1.9.1

From FedoraProject

< Features
Revision as of 15:09, 16 March 2009 by Kanarip (Talk | contribs)

Jump to: navigation, search

Contents

Ruby 1.9.1

Summary

Release Ruby-1.9.1

Owner

Current status

  • Targeted release: Fedora 12
  • Last updated: Mon Mar 16 2009
  • Percentage of completion: 0%

Detailed Description

Ruby-1.9.1 is upstream's new major release of Ruby.

Benefit to Fedora

The usual... we'd be the first to release Ruby-1.9.1, unless another distro beats us to it.

Scope

Requires rebuilding numerous packages that depend on ruby(abi) = 1.8, or have Requires or BuildRequires for package dependent on ruby(abi) = 1.8

Packages that require "ruby(abi) = 1.8"

  • 80 in total
repoquery -c rawhide-i386.conf --qf="%{SOURCERPM}" --whatrequires "ruby(abi) = 1.8" | sort | uniq

Packages that require "*ruby*"

  • 119 in total (80 matches from previous query, of course)
repoquery -c rawhide-i386.conf --qf="%{SOURCERPM}" --whatrequires "*ruby*" | sort | uniq

Test Plan

  1. Make a compatibility package available: compat-ruby1.8-1.8.6.287
    1. Rebuild packages requiring ruby(abi) = 1.8 against the compat- package
  2. Release ruby-1.9.1
    1. Start moving packages to requiring ruby(abi) = 1.9 and test functionality
    2. Fix upstream whereever possible

User Experience

  1. None whatsoever, or I just don't care

Dependencies

  • Maintainers of packages dependent on ruby need to be in the loop
  • provenpackager membership for /me

Contingency Plan

  • Revert compat-ruby1.8-1.8.6.287 to just ruby-1.8.6.287

Documentation

Release Notes

...