Features/Xfce48

From FedoraProject

< Features
Revision as of 16:42, 4 November 2010 by Poelstra (Talk | contribs)

Jump to: navigation, search

Contents

Xfce 4.8

Summary

Update Xfce to the upstream 4.8 release with many new improvements and features.

Owners

  • email: kevin@tummy.com, cwickert@fedoraproject.org

Current status

  • Targeted release: Fedora 15
  • Last updated: 2010-11-03
  • Percentage of completion: 10%

Detailed Description

The Xfce project has been working on a new version, 4.8 for quite a while now.

The Xfce 4.8 schedule is currently estimated to have a release on 2011-01-16.

Benefit to Fedora

Xfce 4.8 has a number of improvements and new features. A few of the more notable ones:

  • Xfce menu will support menu merging.
  • (Hopefully) bring back the graphical menu editor known from Xfce 4.4
  • Thunar is ported from thunar-vfs to gvfs
  • PolicyKit support in xfce4-session
  • Multilib enhancements for xfce4-panel plugins.

Scope

Existing packages will need to be updated to 4.8 in rawhide.

All needed packages are already reviewed and in rawhide, but will need to be updated to the new 4.8 versions.

Two packages will need to be Obsoleted and blocked from Fedora 14:

  • libxfce4menu (replaecd by garcon)
  • libxfcegui4 (replaced by libxfce4ui)

At least the following will need to be updated:

  • libxfce4ui
  • xfce4-settings
  • exo
  • libxfce4util
  • xfce-utils
  • xfce4-appfinder
  • xfce4-panel
  • xfce4-session

How To Test

New installs:

  • install rawhide/Fedora 15 on any machine.
  • yum install @xfce-desktop
  • confirm gdm offers Xfce4 as a session type
  • confirm you can select this session and login
  • confirm settings changes can be made and saved, and are found after a logout/login cycle.
  • confirm day to day desktop functions are working.
  • confirm all settings dialogs come up and work.

(More specifics can be added when final changelogs are available)

Updates:

  • confirm yum groupupdate 'XFCE' works and all packages are properly updated/obsoleted.
  • confirm the updated desktop works fine.

User Experience

  • FIXME

Dependencies

  • FIXME

Contingency Plan

Revert to older Xfce 4.6 version. This may require a Epoch and rebuilding packages and plugins. Or if the dist-f14-xfce tag has not yet been merged back into rawhide, only reverts in cvs will be required.

Documentation

  • FIXME

Release Notes

  • Xfce has been updated to version 4.8. This version includes many enhancements and bug fixes. See the tour at http://www.xfce.org/about/tour for more information.

Comments and Discussion