Features/perl5.12

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Items still to be done - other packages)
(Items still to be done - perl modules: perl-DBI-Dumper Fixed)
(29 intermediate revisions by 5 users not shown)
Line 9: Line 9:
  
 
== Current status ==
 
== Current status ==
* Targeted release: [[Releases/Fedora14 |  Fedora 14 ]]  
+
* Targeted release: [[Releases/14 |  Fedora 14 ]]  
* Last updated: 2010-06-01
+
* Last updated: 2010-06-09
* Percentage of completion: 80%
+
* Percentage of completion: 100%
  
 
=== Completed items ===
 
=== Completed items ===
 
* rewritten spec for perl 5.12
 
* rewritten spec for perl 5.12
* rebuild of almost all perl modules
+
* rebuild all perl modules and some related packages
  
 
=== Items still to be done - perl modules ===
 
=== Items still to be done - perl modules ===
 
{|
 
{|
| perl-Archive-RPM|| [https://bugzilla.redhat.com/show_bug.cgi?id=599859 Bug #599859]
+
| perl-Archive-RPM|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=175952 Done]
 
|-
 
|-
 
| perl-Catalyst-Controller-BindLex|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=169625 Done]
 
| perl-Catalyst-Controller-BindLex|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=169625 Done]
Line 25: Line 25:
 
| perl-Config-Model-CursesUI || [http://koji.fedoraproject.org/koji/taskinfo?taskID=2249338 Done]
 
| perl-Config-Model-CursesUI || [http://koji.fedoraproject.org/koji/taskinfo?taskID=2249338 Done]
 
|-
 
|-
| perl-Data-Alias || broken, can't be fix easily, according repoquery no dependencies-> remove?
+
| perl-Data-Alias || [https://rt.cpan.org/Public/Bug/Display.html?id=36165 broken], [https://bugzilla.redhat.com/show_bug.cgi?id=611014 RHBZ report] -> retire
 
|-
 
|-
 
| perl-DateTime-Format-Strptime || [http://koji.fedoraproject.org/koji/taskinfo?taskID=2251546 Done]
 
| perl-DateTime-Format-Strptime || [http://koji.fedoraproject.org/koji/taskinfo?taskID=2251546 Done]
 
|-
 
|-
| perl-DBI-Dumper || buggy, last release in 2006 -> remove?
+
| perl-DBI-Dumper || [http://koji.fedoraproject.org/koji/buildinfo?buildID=186350 Done], last release in 2006 [https://bugzilla.redhat.com/show_bug.cgi?id=555496 RHBZ report]
 
|-
 
|-
 
| perl-Devel-LexAlias || [http://koji.fedoraproject.org/koji/buildinfo?buildID=170170 Done]
 
| perl-Devel-LexAlias || [http://koji.fedoraproject.org/koji/buildinfo?buildID=170170 Done]
Line 35: Line 35:
 
| perl-Fedora-Bugzilla|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=178325 Done]
 
| perl-Fedora-Bugzilla|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=178325 Done]
 
|-
 
|-
| perl-forks|| [https://rt.cpan.org/Public/Bug/Display.html?id=56263 cpan] tests hang -> update should fix it
+
| perl-forks|| [http://koji.fedoraproject.org/koji/taskinfo?taskID=2255268 Done]
 
|-
 
|-
 
| perl-GDGraph3d|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=170514 Done]
 
| perl-GDGraph3d|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=170514 Done]
Line 63: Line 63:
 
| perl-POE-Component-Server-Bayeux|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171780 Done]
 
| perl-POE-Component-Server-Bayeux|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171780 Done]
 
|-
 
|-
| perl-POE-Component-Server-SimpleHTTP|| [https://bugzilla.redhat.com/show_bug.cgi?id=602616 Bug #602616]
+
| perl-POE-Component-Server-SimpleHTTP|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=179350 Done]
 
|-
 
|-
| perl-POE-Component-Server-SOAP|| depends on perl-POE-Component-Server-SimpleHTTP >= 1.54
+
| perl-POE-Component-Server-SOAP|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171785 Done]
 
|-
 
|-
 
| perl-POE-Component-Server-XMLRPC|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171787 Done]
 
| perl-POE-Component-Server-XMLRPC|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171787 Done]
 
|-
 
|-
| perl-Pugs-Compiler-Rule|| One test unit fails because of different Data::Dumper indentation. The strange thing is it should fail even on localhost with perl-5.10.1. Data::Dumper indents local and package (AST) structure in different way. I don't know how is it possible. However it does not fail.
+
| perl-Pugs-Compiler-Rule|| [https://bugzilla.redhat.com/show_bug.cgi?id=611015 Bug report], one test unit fails because of different Data::Dumper indentation. The strange thing is it should fail even on localhost with perl-5.10.1. Data::Dumper indents local and package (AST) structure in different way. I don't know how is it possible. However it does not fail. -> retire
 
|-
 
|-
 
| perl-SVG-Parser|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171948 Done]
 
| perl-SVG-Parser|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=171948 Done]
 
|-
 
|-
| perl-SVN-Mirror|| [https://rt.cpan.org/Public/Bug/Display.html?id=51088 RT#51088] broken with svn >= 1.6; upstream seems unresponsive
+
| perl-SVN-Mirror|| [https://fedorahosted.org/rel-eng/ticket/3796 Removed]
 
|-
 
|-
| perl-Test-AutoBuild|| depends on rebuild perl-SVN-Mirror with perl5.12
+
| perl-Test-AutoBuild|| [http://koji.fedoraproject.org/koji/buildinfo?buildID=183886 Done]
 
|-
 
|-
 
| perl-Test-WWW-Selenium|| [http://koji.fedoraproject.org/koji/taskinfo?taskID=2227287 Done]
 
| perl-Test-WWW-Selenium|| [http://koji.fedoraproject.org/koji/taskinfo?taskID=2227287 Done]
Line 85: Line 85:
 
|}
 
|}
  
=== Items still to be done - other packages ===
+
=== Other packages ===
 
{|
 
{|
| gnumeric || not perl issue - already [http://lists.fedoraproject.org/pipermail/devel/2010-May/136977.html FTBFS]  
+
| gnumeric || not perl issue - already [http://lists.fedoraproject.org/pipermail/devel/2010-May/136977.html FTBFS] -> Done
 
|-
 
|-
 
| grepmail || Builds fine -> Done
 
| grepmail || Builds fine -> Done
 
|-
 
|-
| krazy2 || not perl issue - already [http://lists.fedoraproject.org/pipermail/devel/2010-May/136977.html FTBFS]  
+
| krazy2 || not perl issue - already [http://lists.fedoraproject.org/pipermail/devel/2010-May/136977.html FTBFS] -> Done
 
|-
 
|-
| lcgdm || not perl issue, will be fixed by maintainer
+
| lcgdm || not perl issue, will be fixed by maintainer -> Done
 
|-
 
|-
| ocaml-perl4caml || [http://lists.fedoraproject.org/pipermail/devel/2010-June/137150.html Already fixed upstream]
+
| ocaml-perl4caml || [http://lists.fedoraproject.org/pipermail/devel/2010-June/137150.html Already fixed upstream] -> Done
 
|-
 
|-
| virt-v2v || http://koji.fedoraproject.org/koji/getfile?taskID=2224478&name=build.log
+
| virt-v2v || failure is due to old version of libguest in this buildroot. In rawhide it should pass -> Done
 
|-
 
|-
| Zim || now is in Fedora Zim in python!
+
| Zim || now is in Fedora Zim in python! -> Done
 
|-
 
|-
 
| zarafa || build by maintainer -> Done
 
| zarafa || build by maintainer -> Done
Line 112: Line 112:
  
 
== Scope ==
 
== Scope ==
Everything will be rebuild in testing buildroot dist-f14-perltest. 'make build TARGET=dist-f14-perltest'
+
Everything will be rebuilt in testing buildroot dist-f14-perltest. 'make build TARGET=dist-f14-perltest'
 
* update perl to 5.12.1
 
* update perl to 5.12.1
 
* update/fix/rebuild all perl modules
 
* update/fix/rebuild all perl modules
 
* rebuild all other dependent packages -> file bugs to maintainers
 
* rebuild all other dependent packages -> file bugs to maintainers
* in case no basic components are broken, then packages could be tagged into dist-f14 buildroot
+
* in case no basic component is broken, then the packages could be tagged into dist-f14 buildroot
  
 
== How To Test ==
 
== How To Test ==
Line 122: Line 122:
  
 
== User Experience ==
 
== User Experience ==
User could notice warnings about soon to be removed modules e.g. Class::ISA will be removed, install from CPAN and errors in syntax e.g. defined(%hash) isn't supported anymore.
+
User could notice warnings about soon to be removed modules e.g. Class::ISA will be removed, install from CPAN and errors in syntax e.g. defined(%hash) isn't supported anymore. These warnings are fixed in Fedora's modules, but it could be still found in users scripts.
  
 
== Dependencies ==
 
== Dependencies ==
Line 138: Line 138:
  
 
== Release Notes ==
 
== Release Notes ==
 +
Notable changes in Perl 5.12 include:
 +
 +
* Perl now conforms much more closely to the Unicode standard. Additionally, this release includes an upgrade to version 5.2 of the standard.
 +
 +
* New experimental APIs allow developers to extend Perl with "pluggable" keywords and syntax.
 +
 +
* Perl now has a better sense of time and will be able to keep accurate time well past the "Y2038" barrier.
 +
 +
* New syntax allows developers to specify package version numbers directly in "package" statements
 +
 +
* Perl now warns the user about the use of deprecated features by default.
 +
 +
Perl 5.12.x features numerous new features, optimizations and bugfixes.
 +
You can find a complete list of these changes on the web at:
 +
 +
http://search.cpan.org/~jesse/perl-5.12.0/pod/perl5120delta.pod
 +
 +
Original release note: http://www.nntp.perl.org/group/perl.perl5.porters/2010/04/msg158820.html
 +
 +
== Comments and Discussion ==
 +
* See [[Talk:Features/perl5.12]]
 +
 +
[[Category:FeatureAcceptedF14]]

Revision as of 09:19, 26 July 2010

Contents

Perl 5.12

Summary

Perl 5.12 brings a lot of changes. Details about them could be found at perl [delta]

Owner

Current status

  • Targeted release: Fedora 14
  • Last updated: 2010-06-09
  • Percentage of completion: 100%

Completed items

  • rewritten spec for perl 5.12
  • rebuild all perl modules and some related packages

Items still to be done - perl modules

perl-Archive-RPM Done
perl-Catalyst-Controller-BindLex Done
perl-Config-Model-CursesUI Done
perl-Data-Alias broken, RHBZ report -> retire
perl-DateTime-Format-Strptime Done
perl-DBI-Dumper Done, last release in 2006 RHBZ report
perl-Devel-LexAlias Done
perl-Fedora-Bugzilla Done
perl-forks Done
perl-GDGraph3d Done
perl-GSSAPI Done
perl-HTTP-Server-Simple-Mason Done
perl-IO-Compress-Bzip2 package is obsoleted by perl-IO-Compress
perl-MasonX-Request-WithApacheSession Done
perl-MooseX-Params-Validate Done
perl-Net-GitHub Done
perl-Olson-Abbreviations Done
perl-Padre Done
perl-PDL Done
perl-PDL-Graphics-PLplot Done
perl-POE-Component-Client-HTTP Done
perl-POE-Component-Server-Bayeux Done
perl-POE-Component-Server-SimpleHTTP Done
perl-POE-Component-Server-SOAP Done
perl-POE-Component-Server-XMLRPC Done
perl-Pugs-Compiler-Rule Bug report, one test unit fails because of different Data::Dumper indentation. The strange thing is it should fail even on localhost with perl-5.10.1. Data::Dumper indents local and package (AST) structure in different way. I don't know how is it possible. However it does not fail. -> retire
perl-SVG-Parser Done
perl-SVN-Mirror Removed
perl-Test-AutoBuild Done
perl-Test-WWW-Selenium Done
perl-WebService-Validator-CSS-W3C Done
perl-YAML-LibYAML Done

Other packages

gnumeric not perl issue - already FTBFS -> Done
grepmail Builds fine -> Done
krazy2 not perl issue - already FTBFS -> Done
lcgdm not perl issue, will be fixed by maintainer -> Done
ocaml-perl4caml Already fixed upstream -> Done
virt-v2v failure is due to old version of libguest in this buildroot. In rawhide it should pass -> Done
Zim now is in Fedora Zim in python! -> Done
zarafa build by maintainer -> Done

Detailed Description

Perl releases will be now every year and updates during year will be containing mainly bug fixes. The release 5.12.1 should be stable release.

Benefit to Fedora

Fedora as bleeding edge distribution should be shipping new release of perl as one of the first distributions.

Scope

Everything will be rebuilt in testing buildroot dist-f14-perltest. 'make build TARGET=dist-f14-perltest'

  • update perl to 5.12.1
  • update/fix/rebuild all perl modules
  • rebuild all other dependent packages -> file bugs to maintainers
  • in case no basic component is broken, then the packages could be tagged into dist-f14 buildroot

How To Test

Download packages from koji's buildroot dist-f14-perltest or try your packages with rebuild build requirements related to perl.

User Experience

User could notice warnings about soon to be removed modules e.g. Class::ISA will be removed, install from CPAN and errors in syntax e.g. defined(%hash) isn't supported anymore. These warnings are fixed in Fedora's modules, but it could be still found in users scripts.

Dependencies

repoquery --whatrequires --alldeps 'perl(:MODULE_COMPAT_5.1?.?)' | sort -u

Contingency Plan

In case some essential packages couldn't be fixed, then would be used perl-5.10.?.

Some packages seem to be unfixable, therefore they should be removed if they don't have any other dependencies.

Documentation

Release Notes

Notable changes in Perl 5.12 include:

  • Perl now conforms much more closely to the Unicode standard. Additionally, this release includes an upgrade to version 5.2 of the standard.
  • New experimental APIs allow developers to extend Perl with "pluggable" keywords and syntax.
  • Perl now has a better sense of time and will be able to keep accurate time well past the "Y2038" barrier.
  • New syntax allows developers to specify package version numbers directly in "package" statements
  • Perl now warns the user about the use of deprecated features by default.

Perl 5.12.x features numerous new features, optimizations and bugfixes. You can find a complete list of these changes on the web at:

http://search.cpan.org/~jesse/perl-5.12.0/pod/perl5120delta.pod

Original release note: http://www.nntp.perl.org/group/perl.perl5.porters/2010/04/msg158820.html

Comments and Discussion