Features/perl5.12

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Items still to be done - perl modules)
(Items still to be done - perl modules)
Line 31: Line 31:
 
| perl-DBI-Dumper || buggy, last release in 2006 -> remove?
 
| perl-DBI-Dumper || buggy, last release in 2006 -> remove?
 
|-
 
|-
| perl-Devel-LexAlias || http://koji.fedoraproject.org/koji/getfile?taskID=2221782&name=build.log
+
| perl-Devel-LexAlias || [http://koji.fedoraproject.org/koji/buildinfo?buildID=170170 Done]
 
|-
 
|-
 
| perl-Fedora-Bugzilla||
 
| perl-Fedora-Bugzilla||

Revision as of 09:52, 5 June 2010

Contents

Perl 5.12

Summary

Perl 5.12 brings a lot of changes. Details about them could be found at perl [delta]

Owner

Current status

  • Targeted release: Fedora 14
  • Last updated: 2010-06-01
  • Percentage of completion: 50%

Completed items

  • rewritten spec for perl 5.12
  • rebuild of almost all perl modules

Items still to be done - perl modules

perl-Archive-RPM - depend on missing package
perl-Catalyst-Controller-BindLex
perl-Config-Model-CursesUI missing 598362, ignore
perl-Data-Alias broken, can't be fix easily, according repoquery no dependencies-> remove?
perl-DateTime-Format-Strptime update this and perl-DateTime bundle
perl-DBI-Dumper buggy, last release in 2006 -> remove?
perl-Devel-LexAlias Done
perl-Fedora-Bugzilla
perl-forks There is problem with tests. It does work in dist-f14, it `does not work' in dist-f14-perltest. Scratch build runs one day still and some tests failed.
perl-GDGraph3d Done
perl-GSSAPI Done
perl-HTTP-Server-Simple-Mason
perl-IO-Compress-Bzip2 package is obsoleted by perl-IO-Compress
perl-MasonX-Request-WithApacheSession
perl-MooseX-Params-Validate http://koji.fedoraproject.org/koji/getfile?taskID=2227324&name=build.log
perl-Net-GitHub Done
perl-Olson-Abbreviations Done
perl-Padre - will be updated by ppisar Bug #598539
perl-PDL Running scratch build with fixed spec file
perl-PDL-Graphics-PLplot
perl-POE-Component-Client-HTTP
perl-POE-Component-Server-Bayeux
perl-POE-Component-Server-SimpleHTTP
perl-POE-Component-Server-SOAP
perl-POE-Component-Server-XMLRPC
perl-Pugs-Compiler-Rule One test unit fails because of different Data::Dumper indentation. The strange thing is it should fail even on localhost with perl-5.10.1. Data::Dumper indents local and package (AST) structure in different way. I don't know how is it possible. However it does not fail.
perl-SVG-Parser Done
perl-SVN-Mirror RT#51088 broken with svn >= 1.6; upstream seems unresponsive
perl-Test-AutoBuild http://koji.fedoraproject.org/koji/getfile?taskID=2227309&name=build.log
perl-Test-WWW-Selenium Done
perl-WebService-Validator-CSS-W3C Done
perl-YAML-LibYAML Done

Items still to be done - other packages

gnumeric not perl issue - already FTBFS

http://koji.fedoraproject.org/koji/getfile?taskID=2222760&name=build.log

grepmail http://koji.fedoraproject.org/koji/getfile?taskID=2222816&name=build.log
krazy2 not perl issue - already FTBFS

http://koji.fedoraproject.org/koji/getfile?taskID=2223005&name=build.log

lcgdm not perl issue, will be fixed by maintainer
ocaml-perl4caml Already fixed upstream
virt-v2v http://koji.fedoraproject.org/koji/getfile?taskID=2224478&name=build.log
Zim http://koji.fedoraproject.org/koji/getfile?taskID=2224567&name=build.log
zarafa

Detailed Description

Perl releases will be now every year and updates during year will be containing mainly bug fixes. The release 5.12.1 should be stable release.

Benefit to Fedora

Fedora as bleeding edge distribution should be shipping new release of perl as one of the first distributions.

Scope

Everything will be rebuild in testing buildroot dist-f14-perltest. 'make build TARGET=dist-f14-perltest'

  • update perl to 5.12.1
  • update/fix/rebuild all perl modules
  • rebuild all other dependent packages -> file bugs to maintainers
  • in case no basic components are broken, then packages could be tagged into dist-f14 buildroot

How To Test

Download packages from koji's buildroot dist-f14-perltest or try your packages with rebuild build requirements related to perl.

User Experience

User could notice warnings about soon to be removed modules e.g. Class::ISA will be removed, install from CPAN and errors in syntax e.g. defined(%hash) isn't supported anymore.

Dependencies

repoquery --whatrequires --alldeps 'perl(:MODULE_COMPAT_5.1?.?)' | sort -u

Contingency Plan

In case some essential packages couldn't be fixed, then would be used perl-5.10.?.

Some packages seem to be unfixable, therefore they should be removed if they don't have any other dependencies.

Documentation

Release Notes