Features/perl5.16

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Current status: xrootd done)
(Current status: mapserver done)
 
(35 intermediate revisions by 3 users not shown)
Line 13: Line 13:
 
== Current status ==
 
== Current status ==
 
* Targeted release: [[Releases/18 | Fedora 18 ]]  
 
* Targeted release: [[Releases/18 | Fedora 18 ]]  
* Last updated: 2012-07-12
+
* Last updated: 2012-11-06
* Percentage of completion: 95 %
+
* Percentage of completion: 100 %
  
 
=== Completed items ===
 
=== Completed items ===
Line 24: Line 24:
 
* Rebuild packages needed for building source packages from git repository
 
* Rebuild packages needed for building source packages from git repository
 
* Remove old perl(:MODULE_COMPAT_5.14.*) from perl
 
* Remove old perl(:MODULE_COMPAT_5.14.*) from perl
 +
* Rebuild other packages: Use Fedora::Rebuild dependency solver or ordered sets computed by Paul
 
* Undefine perl_bootstrap
 
* Undefine perl_bootstrap
 
* Rebuild packages having perl_bootstrap condition in spec file again
 
* Rebuild packages having perl_bootstrap condition in spec file again
 
* Synchronize packages upgraded in ''f18'' build root
 
* Synchronize packages upgraded in ''f18'' build root
 
* Merge dedicated build-root to rawhide and remove the dedicated one [https://fedorahosted.org/rel-eng/ticket/5234 by rel-engs]
 
* Merge dedicated build-root to rawhide and remove the dedicated one [https://fedorahosted.org/rel-eng/ticket/5234 by rel-engs]
 
+
* Rebuilt Perl packages: 2115 of 2115 done (100.00 %)
=== Items in progress ===
+
* Rebuild other packages: Use Fedora::Rebuild dependency solver or ordered sets computed by Paul
+
* Rebuilt Perl packages: 2101 of 2116 done (99.29 %)
+
 
+
=== Items still to be done ===
+
 
+
* gpsdrive – build-time dependencies conflicts: compat-libgda-devel pulls obsolete libdb4-devel in
+
* libprelude – compilation fails (undefined gets)
+
* libpreludedb – compilation fails (undefined gets)
+
* mapserver – does not compile, 'zend_class_entry' has no member named 'default_properties'
+
* openscap – does not compile, undefined gets from bundled stdio.h
+
* perl-Class-InsideOut – tests fail, incompatibilities with Scalar-List-Utils-1.25, [https://rt.cpan.org/Public/Bug/Display.html?id=77860 known to upstream].
+
* perl-eperl – does not compile with perl 5.16.0 (symbol PL_defoutgv redefined, symbol defoutgv undefined)
+
* perl-Hardware-Verilog-Parser – compilation fails
+
* perl-Hardware-Vhdl-Parser – a test fails, not compatible with perl-Parse-RecDescent-1.967006 and newer, pass with perl-Parse-RecDescent-1.967003, [https://rt.cpan.org/Public/Bug/Display.html?id=77946 upstream notified]
+
* perl-PDL – failed due to missing projects.h. It is not provided by latest proj-devel. New version exists which should fix it, but it doesn't. [http://sourceforge.net/tracker/index.php?func=detail&aid=3515759&group_id=612&atid=100612 Upstream bug].
+
* perl-PDL-Graphics-PLplot – requires broken perl-PDL
+
* perl-Unix-Statgrab – a test fails
+
* pidgin – broken dependencies (sane-backends-drivers-cameras-1.0.22-10.fc18 is missing libgphoto2_port.so.0())
+
* xchat-gnome – fails to link (undefined reference to symbol 'IceProcessMessages', 'IceProcessMessages' is defined in DSO /lib/libICE.so.6)
+
* zoneminder – does not compile because of incompatibility with v4l2
+
  
 
== Detailed Description ==
 
== Detailed Description ==
Perl releases will be now every year and updates during year will be containing mainly bug fixes. The release 5.16.0 should be stable release, but 5.16.1 should contain bugfixes for issues introduced in 5.16.0.
+
New perl is released every year and updates containing mainly bug fixes follow during the year. The release 5.16.0 should be stable release, but 5.16.1 should follow very soon fixing issues introduced in 5.16.0.
  
 
== Benefit to Fedora ==
 
== Benefit to Fedora ==

Latest revision as of 08:06, 6 November 2012

Contents

[edit] Perl 5.16

[edit] Summary

Perl 5.16 brings a lot of changes. Details about them can be found in 5.16.0 perldelta document.

[edit] Owner

[edit] Current status

  • Targeted release: Fedora 18
  • Last updated: 2012-11-06
  • Percentage of completion: 100 %

[edit] Completed items

  • Get dedicated build-root from rel-engs (f18-perl)
  • Define perl_bootstrap in perl-srpm-macros
  • Build new perl 5.16 keeping old COMPAT Provides
  • Rebuild packages needed for minimal build-root
  • Rebuild dual-lived packages (otherwise yum recommends --skip-broken and fails)
  • Rebuild packages needed for building source packages from git repository
  • Remove old perl(:MODULE_COMPAT_5.14.*) from perl
  • Rebuild other packages: Use Fedora::Rebuild dependency solver or ordered sets computed by Paul
  • Undefine perl_bootstrap
  • Rebuild packages having perl_bootstrap condition in spec file again
  • Synchronize packages upgraded in f18 build root
  • Merge dedicated build-root to rawhide and remove the dedicated one by rel-engs
  • Rebuilt Perl packages: 2115 of 2115 done (100.00 %)

[edit] Detailed Description

New perl is released every year and updates containing mainly bug fixes follow during the year. The release 5.16.0 should be stable release, but 5.16.1 should follow very soon fixing issues introduced in 5.16.0.

[edit] Benefit to Fedora

Fedora as bleeding edge distribution should be shipping new release of perl as one of the first distributions.

[edit] Scope

Every Perl package will be rebuilt in testing build root f18-perl against perl 5.16.0 and then if no major problem emerges the packages will be merged back to f18 build root.

[edit] How to Test

Download packages from koji buildroot f18-perl or try building or using your packages with requirements related to perl.

[edit] User Experience

[edit] Dependencies

repoquery --whatrequires --alldeps 'perl(:MODULE_COMPAT_5.1?.?)' | sort -u

[edit] Contingency Plan

Revert changes in perl git master branch before 5.16 upgrade commit and drop f18-perl koji build-root.

[edit] Documentation

[edit] Release Notes

[edit] New Features

  • Unicode 6.1
  • More consistent eval controlled with unicode_eval and evalbytes feature
  • 2- and 3-argument substr called in left-value context is evaluted even after changing original string
  • New T_*REF_REFCOUNT_FIXED XS typemap fixing reference counter decremetion
  • New is_utf8_char_buf XS-callable function replaces broken is_utf8_char function
  • $$ variable is writable
  • Improved debugger: tracing mode can be restricted to certain level, breakpoints can be disabled temporarily, breakpoints can be set by file name
  • sort subroutines can be autoloaded
  • $[ variable is provided by arybase module
  • mmaped PerlIO layer is now a separate module PerlIO::mmap

[edit] Deprecated Features

  • Accessing Unicode database files directly is deprecated now; use Unicode::UCD instead
  • Version::Requirements is deprecated in favor of CPAN::Meta::Requirements

[edit] Incompatible Changes

  • Special blocks (e.g. BEGIN) are called in void context
  • Unoverloaded stringification of regular expression does not return the expression literal
  • T_DATAUNIT and T_CALLBACK XS typemaps removed
  • User defined case-changing has been removed in favor of Unicode::Casing
  • XSUB C functions are static now and they are not exported from their object files
  • Read-only references cannot be weaken
  • $$, $<, $>, $(, and $) do not cache their value
  • Devel::DProf, Shell have been removed from Perl core
  • perl4 libraries removed: abbrev.pl, assert.pl, bigfloat.pl, bigint.pl, bigrat.pl, cacheout.pl, complete.pl, ctime.pl, dotsh.pl, exceptions.pl, fastcwd.pl, flush.pl, getcwd.pl, getopt.pl, getopts.pl, hostname.pl, importenv.pl, lib/find{,depth}.pl, look.pl, newgetopt.pl, open2.pl, open3.pl, pwd.pl, hellwords.pl, stat.pl, tainted.pl, termcap.pl, timelocal.pl

[edit] Comments and Discussion