IgnacioVazquezAbrams/YumIntegration

From FedoraProject

< IgnacioVazquezAbrams
Revision as of 18:30, 1 August 2008 by Poelstra (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
Stop (medium size).png THIS IS A DRAFT. DO NOT RELY ON IT FOR ANYTHING UNTIL THIS NOTICE DISAPPEARS AND THE DOCUMENT IS PLACED IN ITS FINAL NAMESPACE

Contents

Yum Integration

Summary

Rewrite various system tools to invoke system-install-packages whenever they need specific additional packages

Owner

  • Name: unowned

Current status

  • Targeted release: Fedora X
  • Last updated: 2007-07-18
  • Percentage of completion: XX%

Detailed Description

Currently in order to use some Fedora software (particularly administration tools such as authconfig et al) a large number of other associated packages must be installed in order for all of the features within the package to work. Without the proper packages installed the software may either go through the motions ineffectually, or in the worst cases just outright crash. These tools can be modified to call system-install-packages in order to make sure the necessary packages are downloaded and installed.

Benefit to Fedora

The initial package payload can be reduced since the system can install packages on demand instead of requiring them to already be in place.

Scope

There are several tools that can be rewritten to take advantage of this. Among them are:

  • authconfig
  • system-config-network
  • desktop-effects

Test Plan

User Experience

Dependencies

Contingency Plan

Software modified to use system-install-packages should degrade gracefully if the package(s) cannot be installed.

A text/TUI version of system-install-packages will be required in order to be fully effective.

A "proxy" executable may be required to ask the user if they would like to proceed with attempting to download and install the packages in order to allow for graceful degradation.

Documentation

Release Notes

  • Would Richard Hughies PackageKit be of any use here?