OLPC/Packages for F11

From FedoraProject

< OLPC
Revision as of 10:10, 17 April 2009 by Pbrobinson (Talk | contribs)

Jump to: navigation, search

Contents

Goal

The goal is to make the next release of what was "OLPC 9.1" into a "Fedora 11 release", and to bring the packages outside of the current Fedora process inside of it. If we can get it done by feature freeze on 3/3, so much the better.  :) For background context, see http://wiki.laptop.org/go/Software_discussion_2009-01-09.

Koji Packages

The following packages in Koji exist in the OLPC-4 collection but not in the Fedora-devel (Fedora 11) collection. Our job is to integrate them.

GConf2-dbus-2.16.0-14.fc10 (rnorwood)

Rainbow is broken with the version of GConf in F10 because of the way Rainbow preforks activities. Since preforking is now turned off, we can try to use the GConf that's shipped in F10 and see what happens.

abiword-2.6.5-3.olpc4 (gregdek)

Minimalized compilation options? The real issue is that abiword was built monolithically in Fedora because we could, and there was no reason not to. For OLPC, a lot of functionality was stripped for space reasons. The goal should be to make Abiword in Fedora be built in a more modular way, allowing users (and derivatives) to pick and choose which chunks are installed.

  • PBR: abiword in Fedora is now build as modular as possible. The OLPC version of abiword has the following removed " --disable-bonobo --disable-gnomevfs --disable-gnomeui --disable-gucharmap --disable-printing" which tend to be useful for most people. With abiword 2.7/2.8 it should remove gnomevfs, bonobo, gnomeui requirements and use gtkprint so we should be able to use standard abiword with few issues.

csound/olpcsound

Once csound is updated from 5.03 to 5.10 in fedora olpc can be marked obsolete and removed. There's a RHBZ request for this providing an initial package RHBZ 493107. Awaiting the maintainer to respond.

fedora-release-10-1.2 (gregdek)

Forced to fork because it's currently a different distro. When the Fedora fixes are implemented, this package just goes away.

hippo-canvas-0.3.0-5.20081014svn.olpc4 (bpepple)

So it appears that maybe the online desktop stuff is using a different (older?) version. We should figure out if anyone inside of RH/Fedora actually cares about maintaining this stuff, and if not, hand it over to OLPC/Sugar folks for maintenance. Otherwise, we need to ask the owner to merge changes in.

initscripts-8.86-1.olpc4.3 (gregdek)

Probably complicated and a bunch of reasons. One big one: OLPC doesn't use GDM to start Sugar. Use Slim instead? ctyler thinks maybe this can be refactored, and will explain how.  :) NEEDINFO. gregdek will sit down with notting, the owner of initscripts for Fedora.

telepathy-gabble-0.7.16-1.olpc4 (gregdek)

Is a problem with Rainbow: the OLPC version requires changes to dbus+kernel because of socket security issues. We need to make decisions about whether we're going to get these changes upstream, and if not, what our other options are.

telepathy-salut-0.3.6-1.olpc4 (gregdek)

Same rainbow problem

totem-2.24.3-5.olpc4 (gregdek)

Removes deps. scrollkeeper, gnome-desktop, gnome-themes, libglade2-devel, nautilus-devel, lirc, gmyth, tracker, gvfs-fuse. Owner in Fedora: hadess.

  • PBR: With 2.26.x the only relevant of the ones listed above are: gnome-themes, gvfs-fuse and scrollkeeper. All the rest are either no longer relevant or are dependencies of plugins subpackages which don't need to be installed. Scrollkeeper is an install dep.

totem-pl-parser-2.24.2-5.olpc4 (gregdek)

camel dep.

upstart-0.3.9-19.olpc4.1 (rnorwood)

need to check with dgilmore why we have an old version of upstart

Joyride Packages

The following packages exist in Joyride, but not in Koji -- usually because they are too new and haven't made their way into Koji, or conflict directly with packages in Fedora.

Mothanna-fonts (kennyp)

Needs conversion to Fedora packaging guidelines. Existing review request (stalled due to lack of action of the reporter).

Thabit-fonts (kennyp)

Needs conversion to Fedora packaging guidelines. Existing review request (stalled due to lack of action of the reporter).

bootanim

Not sure about this one, might need to convert the boot animation to plymouth as a plugin

bootfw

The openfirmware used by OLPC is in the public domain.

  • Details on how to compile it are in this post.
  • It doesn't currently support ext4 for though.

cerebro (rnorwood)

Needs import and review

ds-backup-client (kennyp)

Needs import and review

kernel (cjb)

open issues:

  • open firmware interface (arch/x86/kernel/ofw.[ch]): Need to reevaluate in the context of latest work that has been done on ofw upstream by Dave Miller and Steven Rothwell.
  • geode GPIO driver (used by DCON and suspend/resume): eyeball the gpio work that's been done lately to see if it's acceptable, and figure out strategy for going forward if it isn't.
  • dcon driver (drivers/video/olpc_dcon.[ch])
  • suspend/resume code (arch/x86/kernel/olpc_pm.*)
  • parts of the HGPK touchpad: drivers/input/mouse/olpc.c i believe it's been upstreamed, but there are outstanding patches that need reworking before resubmission.

Updated from the messages on fedora-olpc here and here

olpc-library-common (awagner83)

Library indexing script and HTML templates. Needs import and review.

olpc-licenses (gregdek)

OLPC strips out a bunch of documentation to save space, and olpc-licenses is provided to put the licenses back for GPL and other license compliance. Long-term fix: fix Fedora to separate docs from license by tagging license as a special flavor of licensedoc. Short-term fix: Spot waves his wand and says "put olpc-licenses into Fedora."

olpcrd (katzj via gregdek)

Will we be creating a separate initrd for Fedora? We know that the biggest difference in initrd was the security stuff, which Chris Ball has made clear that OLPC will be dropping. Still need to figure out what needs to be done here.

olpcsudo (cjb)

This is essentially a Python version of sudo. Built to solve the problem of "root password being empty", which is shared by the Fedora Live CD. Current recommendation is to drop olpcsudo, but we need to verify with cjb. (This is C. Scott's package.) (this should be dropped for several reasons -- it's incompatible with "real" sudo, for instance.)

rainbow (m_stone)

Already packaged in Fedora, just need to check version in joyride vs. Fedora. mstone is maintainer in Fedora, so this should be easy.

glibc/glibc-common (sayamindu)

Forked by Sayamindu to make language packs work. Five lines, but contains OLPC-specific stuff. The fundamental problem: translation happens on a systemwide application level, but activities would like to use gettext to allow activity localization at the user application level. Seems like this should be a problem that everyone is interested in solving. Ask Sayamindu about this.

pygtk2/pygtk2-libglade (probinson)

Upstream patches are now committed. Waitind to see what release its going to hit. BGO 397544

Build hacks

Even after all packages are integrated into Fedora, there are likely a few hacks introduced when the OLPC image is built. We will need to identify these, describe them, and eliminate them if possible.

Fixed in Fedora 11 Rawhide

abyssinica-fonts (bochecha)

Imported in Fedora by Bernie Innocenti, recently orphaned. In good shape overall (but adding fontconfig rules to the package would be nice, and needs a renaming to conform to guidelines).

nafees-web-naskh-fonts (bochecha)

Imported in Fedora by Bernie Innocenti, recently orphaned. In good shape overall (but adding fontconfig rules to the package would be nice).

etoys (gavinRK)

requires squeak

libertas-usb8388-firmware (gregdek)

Binary firmware blob -- no policy issue, we just need the latest. Or is there a policy issue? gregdek will find out.

  • Already in Fedora. Original package review here. Also has the same type of licensing as the Intel wifi firmwares so should be OK - PBR 2/3/09

numpy (perobinson)

Depends on python-devel and fortran. RHBZ 494113

SDL_mixer-1.2.8-9.olpc4.1 (bpepple)

timidity++-patches required, which pulls in PersonalCopy-lite; need to split out SDL_mixer. RHBZ 471623 Fixed in build SDL_mixer-1.2.8-12.fc11

squeak-vm (gavinRK)

This is a packaging issue, iirc: since squeak is a binary that produces its own source code thru introspection (boggle) it falls out of our traditional packaging guidelines. We need to consider an excpetion thru fesco. gavin r-k was dirving this; we will follow up. Let us produce a source RPM for Spot to puke upon, if puking is required.

sugar-artwork (quaid)

Status update due

sugar-base

sugar-datastore

sugar-evince-2.24.1-1.olpc4 (smparrish)

New evince is supposed to land in GNOME 2.26 to incorporate upstream fixes. Once gnome-desktop2-evince is built, this can be cut. Conflicts with Fedora evince -- need to do more analysis. Unlike abiword issues which involve configuration of code that is all upstream, sugar-evince carries patches that are not upstream. The first problem to solve is to get patches upsteam if possible. If this is hard, we'll figure something else out.  :)

We'll discover soon how hard it is: http://sugarlabs.org/go/Evince ;) Tomeu 09:33, 15 January 2009 (UTC)

  • All the changes are now in upstream Evince (and hence rawhide) so sugar-evince is now obsolete. There's a RHBZ 480729 to split the libs out of the main evince package so its smaller (a lot) but that's not a blocker. - PBR 2/3/09

sugar-presence-service

sugar-toolkit

sugar-update-control (smparrish)

This package is awaiting review. See http://wiki.laptop.org/go/Software_update, http://dev.laptop.org/ticket/4951, and http://dev.laptop.org/git?p=users/cscott/sugar-update-control;a=summary; c_scott's work. This depends heavily on infrastructure that may no longer be maintained, since it's a full standalone update mechanism. UPDATE: just scrapes the wiki for latest activities. It updates only activities. Relatively harmless.

sugar-* (Activities)

In rawhide already, but we need an owner to update them when upstream does releases.

  • I'm quite happy to do this. Just let me know what packages and I'll request co-maintainer on them - PBR 2/3/09

telepathy-glib-0.7.20-1.olpc4 (gregdek)

No patches -- a false fork. Should just be untagging.

  • The reason for this 'fork' was so they could get a later version than the one in F-10 for features. Obv not an issue in rawhide - PBR 2/3/09