OpenShift Origin

From FedoraProject

(Difference between revisions)
Jump to: navigation, search
(Package Versions)
(Package Versions)
 
(12 intermediate revisions by one user not shown)
Line 3: Line 3:
 
This page tracks [[Cloud SIG|Fedora Cloud SIG]]'s effort to import and maintain OpenShift Origin in Fedora.
 
This page tracks [[Cloud SIG|Fedora Cloud SIG]]'s effort to import and maintain OpenShift Origin in Fedora.
  
OpenShift Origin has been accepted to be a Feature in Fedora 19Track our progress on our [[Features/OpenShift_Origin| OpenShift Origin Feature]] page.
+
OpenShift Origin release 4 no longer supports Fedora, only RHEL/CentOS/SLThe reason is that the ruby in Fedora has progressed so fast that it is no longer compatible with the code in OpenShift Origin.
 
+
  
 +
There is currently no plans to update the current code in OpenShift Origin to a newer ruby, instead efforts are being targeted towards [http://origin.openshift.com/blog/openshift-v3-platform-combines-docker-kubernetes-atomic-and-more OpenShift v3].  (Not to be confused with OpenShift Origin release 3.
  
 +
OpenShift v2 packages will be removed from Fedora 21+.  When it is considered stable enough, the OpenShift v3 packages will be added into Fedora.
  
 
== Source ==
 
== Source ==
Line 19: Line 20:
 
== OpenShift Origin Community ==
 
== OpenShift Origin Community ==
  
The OpenShift Origin community is thriving at the [https://www.openshift.com/products/origin OpenShift Origin community web site].
+
The OpenShift Origin community is thriving at the [http://origin.openshift.com/ OpenShift Origin community web site].
  
 
All of the code is at [https://github.com/openshift/origin-server Github openshift/origin-server] repository
 
All of the code is at [https://github.com/openshift/origin-server Github openshift/origin-server] repository
Line 30: Line 31:
 
== OpenShift Origin Releases ==
 
== OpenShift Origin Releases ==
  
OpenShift Origin has official stable releases every three months (quarterly).  We will be pushing these quarterly, stable releases to Fedora.
+
OpenShift Origin has official stable releases every three months (quarterly).  Release 3 was the last one that supported Fedora, and that was Fedora 19.
  
OpenShift Origin also has a nightly build for the latest release of Fedora.  There is no guarantee of stability on their nightly releases, but they are nice to see what is up and coming.
+
:* [https://mirror.openshift.com/pub/openshift-origin/release/1/ Release 1]
 
+
:* [https://mirror.openshift.com/pub/openshift-origin/release/1/ Version 1]
+
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/1/fedora-18/ Fedora 18]
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/1/fedora-18/ Fedora 18]
:* [https://mirror.openshift.com/pub/openshift-origin/release/2/ Version 2]
+
:* [https://mirror.openshift.com/pub/openshift-origin/release/2/ Release 2]
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/2/fedora-19/ Fedora 19]
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/2/fedora-19/ Fedora 19]
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/2/documentation/ Documentation]
 
::* [https://mirror.openshift.com/pub/openshift-origin/release/2/documentation/ Documentation]
 
+
:* [https://mirror.openshift.com/pub/openshift-origin/release/3/ Release 3]
 +
::* [https://mirror.openshift.com/pub/openshift-origin/release/3/fedora-19/ Fedora 19]
 +
::* [https://mirror.openshift.com/pub/openshift-origin/release/3/documentation/ Documentation]
 +
:* [https://mirror.openshift.com/pub/openshift-origin/release/4/ Release 4]
 +
::* There were no Fedora versions for release 4
  
 
== OpenShift Origin Packages ==
 
== OpenShift Origin Packages ==
Line 99: Line 102:
 
!Latest
 
!Latest
 
!Rawhide
 
!Rawhide
 +
!F20 stable
 +
!F20 test
 
!F19 stable
 
!F19 stable
 
!F19 test
 
!F19 test
!F18 stable
 
!F18 test
 
|-
 
|avahi-cname-manager
 
|0.0.2.1
 
|
 
|
 
|
 
|
 
|
 
 
|-
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14422 mcollective-qpid-plugin] ++
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14422 mcollective-qpid-plugin] ++
Line 119: Line 114:
 
|1.3.2
 
|1.3.2
 
|1.3.2
 
|1.3.2
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14688 openshift-origin-broker]
 
|1.10.2.1
 
|1.10.2.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15116 openshift-origin-broker-util]
 
|1.13.0.2
 
!1.13.0.1
 
|1.5.12
 
|1.5.12
 
|1.5.12
 
|1.5.12
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14420 openshift-origin-cartridge-abstract] ++
 
|1.10.1
 
|1.10.1
 
|1.5.9
 
|1.5.9
 
|1.5.9
 
|1.5.9
 
|-
 
|[https://bugzilla.redhat.com/show_bug.cgi?id=908116 openshift-origin-console]
 
|1.10.2.2
 
!Review
 
!Review
 
!Review
 
!Review
 
!Review
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15231 openshift-origin-msg-common]
 
|1.13.0.1
 
|1.13.0.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14581 openshift-origin-msg-node-mcollective]
 
|1.13.0.1
 
|1.13.0.1
 
|1.5.10
 
|1.5.10
 
|1.5.10
 
|1.5.10
 
|-
 
|[https://bugzilla.redhat.com/show_bug.cgi?id=917149 openshift-origin-node-proxy]
 
|1.11.1.1
 
|1.11.1.1
 
|1.11.1.1
 
|1.11.1.1
 
|1.11.1.1
 
|1.11.1.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15222 openshift-origin-node-util]
 
|1.13.0.1
 
|1.13.0.1
 
|1.5.6
 
|1.5.6
 
|1.5.6
 
|1.5.6
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14880 openshift-origin-port-proxy]
 
|1.8.1.1
 
|1.8.1.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15260 openshift-origin-util]
 
|1.10.2.1
 
|1.10.2.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15059 pam_openshift]
 
|1.9.0.1
 
|1.9.0.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|1.4.1
 
|-
 
|rubygem-openshift-origin-admin-console
 
|0.1.0.1
 
|
 
|
 
|
 
|
 
|
 
|-
 
|[https://bugzilla.redhat.com/show_bug.cgi?id=894482 rubygem-openshift-origin-auth-kerberos]
 
|1.10.2.1
 
!Review
 
!Review
 
!Review
 
!Review
 
!Review
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14492 rubygem-openshift-origin-auth-mongo]
 
|1.10.2.1
 
|1.10.2.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=15845 rubygem-openshift-origin-auth-remote-user]
 
|1.13.0.1
 
|1.13.0.1
 
|1.5.6
 
|1.5.6
 
|1.5.6
 
|1.5.6
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14540 rubygem-openshift-origin-common]
 
|1.13.0.1
 
|1.13.0.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|-
 
|[https://bugzilla.redhat.com/show_bug.cgi?id=894524 rubygem-openshift-origin-console]
 
|1.13.0.2
 
!Review
 
!Review
 
!Review
 
!Review
 
!Review
 
|-
 
|rubygem-openshift-origin-container-selinux
 
|0.2.0.1
 
|
 
|
 
|
 
|
 
|
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14576 rubygem-openshift-origin-controller]
 
|1.13.0.2
 
!1.13.0.1
 
|1.5.15
 
|1.5.15
 
|1.5.15
 
|1.5.15
 
|-
 
|rubygem-openshift-origin-dns-avahi
 
|1.10.2.1
 
|
 
|
 
|
 
|
 
|
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14491 rubygem-openshift-origin-dns-bind]
 
|1.10.2.1
 
|1.10.2.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|1.5.1
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=17151 rubygem-openshift-origin-dns-nsupdate]
 
|1.10.2.1
 
|1.10.2.1
 
|1.10.2.1
 
|1.10.2.1
 
| -
 
| -
 
|-
 
|rubygem-openshift-origin-dns-route53
 
|1.10.2.1
 
|
 
|
 
|
 
|
 
|
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14733 rubygem-openshift-origin-msg-broker-mcollective]
 
|1.13.0.1
 
|1.13.0.1
 
|1.5.12
 
|1.5.12
 
|1.5.12
 
|1.5.12
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14563 rubygem-openshift-origin-node]
 
|1.13.0.2
 
|1.13.0.1
 
|1.5.17
 
|1.5.17
 
|1.5.17
 
|1.5.17
 
 
|-
 
|-
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=12233 rubygem-rhc]
 
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=12233 rubygem-rhc]
|1.11.4
+
|1.19.1
|1.11.4
+
|1.19.1
|1.11.4
+
|1.19.1
|1.11.4
+
|1.19.1
|1.11.4
+
|1.19.1
|1.11.4
+
|1.19.1
|-
+
!Cartidge V1
+
!Latest
+
!Rawhide
+
!F18 stable
+
!F18 test
+
!F17 stable
+
!F17 test
+
|-
+
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14579 openshift-origin-cartridge-cron-1.4] ++
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|-
+
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=14580 openshift-origin-cartridge-diy-0.1] ++
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|1.9.1
+
|-
+
!Cartidge V2
+
!Latest
+
!Rawhide
+
!F18 stable
+
!F18 test
+
!F17 stable
+
!F17 test
+
|-
+
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=17152 openshift-origin-cartridge-cron]
+
|1.11.0.1
+
|1.11.0.1
+
|1.11.0.1
+
|1.11.0.1
+
| -
+
| -
+
|-
+
|[http://koji.fedoraproject.org/koji/packageinfo?packageID=17150 openshift-origin-cartridge-diy]
+
|0.8.0.1
+
|0.8.0.1
+
|0.8.0.1
+
|0.8.0.1
+
| -
+
| -
+
|-
+
|openshift-origin-cartridge-jbossas
+
|1.6.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-mariadb
+
|0.0.2.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-mock
+
|0.8.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-mock-plugin
+
|0.7.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|[https://bugzilla.redhat.com/show_bug.cgi?id=1031191 openshift-origin-cartridge-mongodb]
+
|1.12.0.1
+
!Review
+
!Review
+
!Review
+
!Review
+
!Review
+
|-
+
|[https://bugzilla.redhat.com/show_bug.cgi?id=1031198 openshift-origin-cartridge-mysql]
+
|0.7.0.1
+
!Review
+
!Review
+
!Review
+
!Review
+
!Review
+
|-
+
|openshift-origin-cartridge-nodejs
+
|1.14.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-perl
+
|0.8.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-php
+
|0.8.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-phpmyadmin
+
|1.13.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-postgresql
+
|0.6.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-python
+
|0.8.0.1
+
|
+
|
+
|
+
|
+
|
+
|-
+
|openshift-origin-cartridge-ruby
+
|0.8.0.1
+
|
+
|
+
|
+
|
+
|
+
 
|-
 
|-
 
|}
 
|}
  
++ These packages are not in OpenShift Origin v2
+
* ++ These packages are not in OpenShift Origin v2
 +
* +++ These packages are retired from Fedora
  
 
=== OpenShift Origin Package Dependencies ===
 
=== OpenShift Origin Package Dependencies ===
 
OpenShift Origin packages currently depend on the following packages not yet in Fedora
 
OpenShift Origin packages currently depend on the following packages not yet in Fedora
  
:* rubygem-openshift-origin-node (version 1.16)
+
:*
::* rubygem-parallel (https://bugzilla.redhat.com/show_bug.cgi?id=1016863)
+
::*
 
+
:* openshift-origin-cartridge-nodejs (no review request yet)
+
::* nodejs-bignumber.js (https://bugzilla.redhat.com/show_bug.cgi?id=966222) - DONE
+
::* nodejs-mongodb (https://bugzilla.redhat.com/show_bug.cgi?id=996202) - DONE
+
::* nodejs-mysql (https://bugzilla.redhat.com/show_bug.cgi?id=966223) - DONE
+
::* nodejs-node-static (https://bugzilla.redhat.com/show_bug.cgi?id=965895) - DONE
+
::* nodejs-bson (https://bugzilla.redhat.com/show_bug.cgi?id=1016753)
+
::* nodejs-nan (https://bugzilla.redhat.com/show_bug.cgi?id=1016770) - DONE
+
  
 
== Installation and Configuration ==
 
== Installation and Configuration ==

Latest revision as of 18:30, 3 October 2014

OpenShift Origin is a cloud application platform as a service (PaaS). It is the open sourced, community supported version of OpenShift

This page tracks Fedora Cloud SIG's effort to import and maintain OpenShift Origin in Fedora.

OpenShift Origin release 4 no longer supports Fedora, only RHEL/CentOS/SL. The reason is that the ruby in Fedora has progressed so fast that it is no longer compatible with the code in OpenShift Origin.

There is currently no plans to update the current code in OpenShift Origin to a newer ruby, instead efforts are being targeted towards OpenShift v3. (Not to be confused with OpenShift Origin release 3.

OpenShift v2 packages will be removed from Fedora 21+. When it is considered stable enough, the OpenShift v3 packages will be added into Fedora.

Contents

[edit] Source

The main GitHub pages for OpenShift have links to all the sub-projects. These include:

  • OpenShift Origin source tarballs - These are created daily if there has been a change.


[edit] OpenShift Origin Community

The OpenShift Origin community is thriving at the OpenShift Origin community web site.

All of the code is at Github openshift/origin-server repository

There are devel and user Mail Lists.

We are on on IRC at #openshift and #openshift-dev on freenode.

[edit] OpenShift Origin Releases

OpenShift Origin has official stable releases every three months (quarterly). Release 3 was the last one that supported Fedora, and that was Fedora 19.

  • There were no Fedora versions for release 4

[edit] OpenShift Origin Packages

OpenShift Packages

OpenShift V1 Cartridges

OpenShift V2 Cartridges

  • openshift-origin-cartridge-cron
  • openshift-origin-cartridge-diy
  • openshift-origin-cartridge-haproxy
  • openshift-origin-cartridge-jbossas
  • openshift-origin-cartridge-mariadb
  • openshift-origin-cartridge-mock
  • openshift-origin-cartridge-mock-plugin
  • openshift-origin-cartridge-mongodb
  • openshift-origin-cartridge-mysql
  • openshift-origin-cartridge-nodejs
  • openshift-origin-cartridge-perl
  • openshift-origin-cartridge-php
  • openshift-origin-cartridge-phpmyadmin
  • openshift-origin-cartridge-postgresql
  • openshift-origin-cartridge-python
  • openshift-origin-cartridge-ruby

[edit] Package Versions

Package Latest Rawhide F20 stable F20 test F19 stable F19 test
mcollective-qpid-plugin ++ 1.3.2 1.3.2 1.3.2 1.3.2 1.3.2 1.3.2
rubygem-rhc 1.19.1 1.19.1 1.19.1 1.19.1 1.19.1 1.19.1
* ++ These packages are not in OpenShift Origin v2
* +++ These packages are retired from Fedora

[edit] OpenShift Origin Package Dependencies

OpenShift Origin packages currently depend on the following packages not yet in Fedora

[edit] Installation and Configuration