OpenStack

From FedoraProject

Revision as of 17:52, 17 January 2012 by Mdomsch (Talk | contribs)

Jump to: navigation, search

Contents

OpenStack

OpenStack consists of a number services for running IaaS clouds. They are the Object Store (Swift), Compute (Nova) and Image (Glance) services.

The Diablo release of OpenStack was included Fedora 16. The Essex release will be included in Fedora 17.

This page tracks Fedora Cloud SIG's effort to maintain OpenStack in Fedora.

Getting Started

See Getting started with OpenStack Nova for details on how to try out the OpenStack packages on Fedora 16.

OpenStack in Fedora 17

The following features are proposed for Fedora 17:

Packages

Package Reviews

Packaging in progress:

Images

Rather than recommending users to download pre-built Ubuntu images in Getting_started_with_OpenStack Nova, we should have a set of official Fedora images like Cloud_SIG/EC2_Images. These should be built using similar process to the EC2 images.

For now, we can suggest users build Fedora images using Oz.

To Package

  1. noVNC - a HTML5 VNC client
  2. openstack-reddwarf - database as a service (will be part of openstack-nova?
  3. crowbar - OpenStack deployment service and chef wrapper

On the shelf for now:

  • openstack-burrow - message queue
    • Burrow development seems to have halted a while back when the main dev stopped working on it

Ubuntu

Some of Ubuntu's stuff may be useful to compare against:

OpenStack in EPEL

The Diablo version of openstack is in EPEL 6, supporting RHEL 6.2. Also included in these packages are backports of various fixes and libguestfs file injection support.

You can drill down to the latest "el6" version of each of the openstack packages to see, the latest versions available and associated changes.

The following ancillary EPEL packages were added/updated to support the openstack packages:

  • python-distutils-extra
  • bpython
  • python-migrate
  • python-novaclient
  • python-prettytable
  • python-greenlet
  • python-eventlet
  • python-passlib
  • python-sqlalchemy0.7
  • python-nose1.1
  • python-webob1.0