From Fedora Project Wiki

Revision as of 22:07, 13 April 2010 by Fcami (talk | contribs) (Created page with '{{QA/Test_Case |description=Checking that your card and software can render extremeTuxRacer. You must be using a card supported by the Radeon video driver. |actions= # Ensure the...')
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

Description

Checking that your card and software can render extremeTuxRacer. You must be using a card supported by the Radeon video driver.


How to test

  1. Ensure the 'nomodeset' kernel parameter is not enabled in your bootloader configuration (unless you need it for basic X operation to suceed)
  2. Ensure that
    glxinfo | grep 'OpenGL renderer'
    does not return:
    OpenGL renderer string: Software Rasterizer
  3. Install the extremetuxracer package: `yum -y install extremetuxracer`
  4. Launch etracer from a terminal.
  5. Edit the game settings (Configuration => {Video, Graphics}).
  6. Launch a practice session (Ski Jump is short, Path of Daggers entertaining). Look closely at the screen.
  7. Quit extremetuxracer.

Expected Results

  1. no crash.
  2. no obvious misrendering (flickering mostly)