Releases/FeatureLibataForPata

From FedoraProject

< Releases
Revision as of 16:28, 24 May 2008 by Admin (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Use libata for PATA support

  • Last modified: [[Date(2007-01-03T21:02:49Z)]
  • Owners: DaveJones, PeterJones, JeffGarzik, AlanCox
  • Targeted release: Fedora 7
  • Needs done by: Test1

Current status

Summary

Use libata for parallel ATA support, instead of the 'old-ide' stack.

Usage cases/rationale

This allows us to move the driver stack forward, and provides some features that I don't know off of the top of my head.

Scope

Requires changes to the kernel config, driver fixes, mkinitrd changes, and potential anaconda migration work.

Test Plan

Find machines that use the old IDE code. Test that they upgrade and boot properly without user intervention.

Dependencies

Details


[[Category:FedoraFeatures