SIGs/KDE/Meetings/2009-09-01

From FedoraProject

< SIGs | KDE | Meetings
Revision as of 16:50, 1 September 2009 by Kkofler (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Meeting Time

Participants

Agenda

  • topics to discuss:
    • PolicyKit - final decision
    • KDE 4.3.1
  • recent bugs:
    • #520611 koffice-filters requires koffice-kplato

Transcript

Summary

PolicyKit - final decision:

  • After KPackageKit stopped using polkit-qt nothing else uses it.
  • Remaining packages that relies on polkit-qt are PyKDE4 and PolicyKit-KDE.
  • The (apparently unused) polkit-qt bindings in PyKDE4 will be dropped from F12+.
  • PolicyKit-KDE in kdebase-workspace will be disabled, as PolicyKit 0.9 is being dropped.
  • polkit-qt will be blocked from dist-f12 in time for F12 Beta, as PolicyKit 0.9 is being dropped.
  • We will work on bringing in PolicyKit 1 versions and a PolicyKit 1 backend for kauth for F13 and F12 updates (in time for KDE 4.4).

KDE 4.3.1:

  • ThanNgo is working on adding support for OpenSSL 1.0 in kdelibs.
  • LukasTinkl started to work on updates for F11 and F10.
  • SebastianVahl will update the extragear packages when LukasTinkl imported them into CVS.

#520611 - koffice-filters requires koffice-kplato:

  • New koffice-filters introduced a dependency on koffice-kplato.
  • KevinKofler and RexDieter will try to sort these dependencies out.

Comments