Talk:Features/PackageKitBrowserPlugin

From FedoraProject

Revision as of 08:51, 22 August 2009 by Alexlan (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Doesn't work for me, I tried install the plugin on F-11:

$ rpm -q PackageKit-browser-plugin
PackageKit-browser-plugin-0.4.9-1.fc11.x86_64

and restarted epiphany and went to:

http://people.freedesktop.org/~hughsient/temp/test.html

but the page was blank, and get the following console output:

LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/nppdf.so [/usr/lib/mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/flash-plugin/libflashplayer.so [/usr/lib/flash-plugin/libflashplayer.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/gtk/.mozilla/plugins/nppdf.so [/home/gtk/.mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/nppdf.so [/usr/lib/mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/flash-plugin/libflashplayer.so [/usr/lib/flash-plugin/libflashplayer.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/nppdf.so [/usr/lib/mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/flash-plugin/libflashplayer.so [/usr/lib/flash-plugin/libflashplayer.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /home/gtk/.mozilla/plugins/nppdf.so [/home/gtk/.mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/mozilla/plugins/nppdf.so [/usr/lib/mozilla/plugins/nppdf.so: wrong ELF class: ELFCLASS32]
LoadPlugin: failed to initialize shared library /usr/lib/flash-plugin/libflashplayer.so [/usr/lib/flash-plugin/libflashplayer.so: wrong ELF class: ELFCLASS32

I thought this might be because I needed a i586 version as I have both i586 and x86_64 versions of nspluginwrapper on my machine, but there appears to be no i586 version.

$ sudo yum install PackageKit-browser-plugin.i586
[No package PackageKit-browser-plugin.i586 available.

Should I file a bug for this? -- Alexlan 08:51, 22 August 2009 (UTC)