FSA/F7/FEDORA-2007-0174

From FedoraProject

< FSA | F7
Jump to: navigation, search

[SECURITY] Fedora 7 Update: postgresql-8.2.4-1.fc7

--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2007-0174
2007-06-03 21:15:07
--------------------------------------------------------------------------------

Name        : postgresql
Product     : Fedora 7
Version     : 8.2.4
Release     : 1.fc7
Summary     : PostgreSQL client programs and libraries
Description :
PostgreSQL is an advanced Object-Relational database management system
(DBMS) that supports almost all SQL constructs (including
transactions, subselects and user-defined types and functions). The
postgresql package includes the client programs and libraries that
you'll need to access a PostgreSQL DBMS server.  These PostgreSQL
client programs are programs that directly manipulate the internal
structure of PostgreSQL databases on a PostgreSQL server. These client
programs can be located on the same machine with the PostgreSQL
server, or may be on a remote machine which accesses a PostgreSQL
server over a network connection. This package contains the docs
in HTML for the whole package, as well as command-line utilities for
managing PostgreSQL databases on a PostgreSQL server.

If you want to manipulate a PostgreSQL database on a remote PostgreSQL
server, you need this package. You also need to install this package
if you're installing the postgresql-server package.

--------------------------------------------------------------------------------
Update Information:

Update to PostgreSQL 8.2.4 for CVE-2007-2138, data loss bugs
--------------------------------------------------------------------------------
ChangeLog:

* Tue Apr 24 2007 Tom Lane <tgl redhat com> 8.2.4-1
- Update to PostgreSQL 8.2.4 for CVE-2007-2138, data loss bugs
Resolves: #237682
--------------------------------------------------------------------------------
References:

[ 1 ]  Bug #237682
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=237682
[ 2 ]  CVE-2007-2138
http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2138
--------------------------------------------------------------------------------
Updated packages:

cc956d3ee1d96780139b12bcdc3d5a3f4f6e1d03 postgresql-tcl-8.2.4-1.fc7.i386.rpm
594fcced1780b02bc2ba8fc653feb73d94d07e91 postgresql-devel-8.2.4-1.fc7.i386.rpm
b21986bec1c284c4eaa8de3f44389e027882c3e0 postgresql-plpython-8.2.4-1.fc7.i386.rpm
ba7e6698ec0b35e92907e9cab202b82d4dc4ad8a postgresql-test-8.2.4-1.fc7.i386.rpm
32746470bec89809451da27be1cbf4f00147f68f postgresql-contrib-8.2.4-1.fc7.i386.rpm
646643164d44fefff5deb6e27ce748b3af48c666 postgresql-docs-8.2.4-1.fc7.i386.rpm
8a84684665dc1205ecb28dd941e7ba007a4d2ba7 postgresql-plperl-8.2.4-1.fc7.i386.rpm
57b2b843cf40596439b89d850b0677f3b0869500 postgresql-debuginfo-8.2.4-1.fc7.i386.rpm
8041f94ea801d0ac6b190edd1d9e2ad267fd754e postgresql-pltcl-8.2.4-1.fc7.i386.rpm
f25aa5288ab52fe77f49bc6120cd379542e7695d postgresql-libs-8.2.4-1.fc7.i386.rpm
6afdcbd2fc224da0f20bff0d8beb4bd07376b027 postgresql-8.2.4-1.fc7.i386.rpm
a10461dc2ef5ab1b831d06f8d6fbb447bfa6f51b postgresql-server-8.2.4-1.fc7.i386.rpm
355e82240ce049c8c60b7fce51834b29a0e2ab9c postgresql-python-8.2.4-1.fc7.i386.rpm
7e57c2594a0fa040ebb050eab21f5e35c913e326 postgresql-plperl-8.2.4-1.fc7.ppc64.rpm
4cca3daacb65e1291fcf47e7948a701ed50defd5 postgresql-test-8.2.4-1.fc7.ppc64.rpm
20315a5b5aa127b90ef28bcb0f704d286ee9753b postgresql-pltcl-8.2.4-1.fc7.ppc64.rpm
2db6c11e160f0ed4fb196ac23ca02eb6b08de7b0 postgresql-contrib-8.2.4-1.fc7.ppc64.rpm
9ac9d2ba82ddc7e0f1bfc870c6bbaa1a59126684 postgresql-libs-8.2.4-1.fc7.ppc64.rpm
aab04eeda2ee5542221836d8084a4fd06e7b5552 postgresql-8.2.4-1.fc7.ppc64.rpm
56c4d4bed15bbc421f18fd53e284f876cf337bc9 postgresql-devel-8.2.4-1.fc7.ppc64.rpm
989a04986ba0e3ff89ede735a2d5b73a64d7e07c postgresql-plpython-8.2.4-1.fc7.ppc64.rpm
6b67af6cf601d0ecdeb06b4cab472d9677557b4b postgresql-debuginfo-8.2.4-1.fc7.ppc64.rpm
59516598facc50aa970ff7bbfd5574ce14cf7134 postgresql-python-8.2.4-1.fc7.ppc64.rpm
6755c283d04475a702a92650ac1e1d4fad619770 postgresql-tcl-8.2.4-1.fc7.ppc64.rpm
998dbf4f8e7a3a4752122fc316cecb6cd849126a postgresql-docs-8.2.4-1.fc7.ppc64.rpm
fb759d2e4dd2792a8298a7eb57c8927383987813 postgresql-server-8.2.4-1.fc7.ppc64.rpm
99d79d4d87b2323f3000f68f60dbd19c393c262e postgresql-libs-8.2.4-1.fc7.x86_64.rpm
f957cc8a8d72f75e15eb751514cc9d4c31587fb8 postgresql-tcl-8.2.4-1.fc7.x86_64.rpm
cac07ace8187a18d22ccb01496f6050579bb390e postgresql-test-8.2.4-1.fc7.x86_64.rpm
41ff16121bddbb2db508693be78877d68bf85a35 postgresql-python-8.2.4-1.fc7.x86_64.rpm
16a7e61f916db8cf6644520258e9d571d309e2ba postgresql-8.2.4-1.fc7.x86_64.rpm
3687d8f91785ca39f1227512ecdd37174a4e35ed postgresql-pltcl-8.2.4-1.fc7.x86_64.rpm
7eb876f62823ef07094d6503dcc23633957afe6e postgresql-plperl-8.2.4-1.fc7.x86_64.rpm
12d4717aeda64cd7390d27dedb5af8ac74419ac7 postgresql-devel-8.2.4-1.fc7.x86_64.rpm
90847aeb59d5aed8cf0e60b0eca3869638f88ca2 postgresql-docs-8.2.4-1.fc7.x86_64.rpm
623c0d762df8d51402f973e79745ea244b011944 postgresql-debuginfo-8.2.4-1.fc7.x86_64.rpm
496315385f6d5509ccb6320d94dca568fa220ad6 postgresql-plpython-8.2.4-1.fc7.x86_64.rpm
c1dae8b57f9470852f5d9486393cf4cd43b7e30d postgresql-contrib-8.2.4-1.fc7.x86_64.rpm
5eda9446c6ad25e882576edcb28daf9cedf157c4 postgresql-server-8.2.4-1.fc7.x86_64.rpm
1f8bb349dca9db3a6a477412c5659c4baabaf1cf postgresql-libs-8.2.4-1.fc7.ppc.rpm
85116c4b5fee7bb03615db4d952c2c4f5170c412 postgresql-tcl-8.2.4-1.fc7.ppc.rpm
f7ec309e89fdfd9ffd10d27c45e6c1dd38e53b66 postgresql-plpython-8.2.4-1.fc7.ppc.rpm
c5fa0f3c37c79801c78d500222b49a6f302a145f postgresql-test-8.2.4-1.fc7.ppc.rpm
12e37a1792cafcbdc18c5ddf7e5bb189651e2df0 postgresql-server-8.2.4-1.fc7.ppc.rpm
e9f611652c3cd2ff872f9e315733f1c9112aca15 postgresql-python-8.2.4-1.fc7.ppc.rpm
a23e7c4d40593136182042bce34b588bf3702fc0 postgresql-docs-8.2.4-1.fc7.ppc.rpm
630f3e25b29c6c978c3fb8f10d2e1642cf15d71c postgresql-debuginfo-8.2.4-1.fc7.ppc.rpm
df5125c9116fa2f12f8ce89c5a7e1bedff93843b postgresql-pltcl-8.2.4-1.fc7.ppc.rpm
72bd0b98cf53985f62cca6425f4d1176acbf8111 postgresql-contrib-8.2.4-1.fc7.ppc.rpm
73487b921e76ef54475d1faf54460bc0f7659e71 postgresql-8.2.4-1.fc7.ppc.rpm
81117a59517cdc94a7b436c3e7cf9644fd4ffca2 postgresql-plperl-8.2.4-1.fc7.ppc.rpm
8b5aada7b6b9e763c92446d2d62f08f925a9bcdb postgresql-devel-8.2.4-1.fc7.ppc.rpm
5a04ab609fc920b5f0cc9a299eeb3d7215f9b309 postgresql-8.2.4-1.fc7.src.rpm

This update can be installed with the 'yum' update program.  Use 'yum update
package-name' at the command line.  For more information, refer to 'Managing
Software with yum,' available at http://docs.fedoraproject.org/yum/.
--------------------------------------------------------------------------------