FSA/FC6/FEDORA-2007-489

From FedoraProject

< FSA | FC6
Jump to: navigation, search

[SECURITY] Fedora Core 6 Update: gimp-2.2.14-5.fc6

---------------------------------------------------------------------
Fedora Update Notification
FEDORA-2007-489
2007-05-07
---------------------------------------------------------------------

Product     : Fedora Core 6
Name        : gimp
Version     : 2.2.14
Release     : 5.fc6
Summary     : GNU Image Manipulation Program
Description :
GIMP (GNU Image Manipulation Program) is a powerful image composition and
editing program, which can be extremely useful for creating logos and other
graphics for webpages. GIMP has many of the tools and filters you would expect
to find in similar commercial offerings, and some interesting extras as well.
GIMP provides a large image manipulation toolbox, including channel operations
and layers, effects, sub-pixel imaging and anti-aliasing, and conversions, all
with multi-level undo.

---------------------------------------------------------------------
Update Information:

The GIMP package in Fedora includes a helper script
/usr/sbin/gimp-plugin-mgr for plugins contained in other
packages, for example, xsane-gimp. This script manages
symlinks from the GIMP plugin directory (which may change
between upgrades) to the actual location of the plugins.

A bug has been fixed in this erratum of GIMP that was in all
older GIMP packages. The bug concerns the execution order in
which the symlinks are installed and removed, causing the
symlinks to vanish when the GIMP package is updated.

Although this GIMP erratum has the execution order fixed,
due to the nature of the problem it will show up once more
when updating from an affected version to a fixed version.
To add these symlinks back in, run this command, providing
the root password when prompted:

su -c "/usr/sbin/gimp-plugin-mgr --install '*'"
---------------------------------------------------------------------
* Tue May  1 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-5
- don't let gimp-plugin-mgr --uninstall fail %pre/%preun scriptlets (#238337)
* Mon Apr 30 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-4
- fix plugin symlinks handling better (#238337)
* Mon Apr 30 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-3
- don't erroneously delete symlinks to external plugins when updating (#238337)
* Mon Apr 30 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-2
- avoid buffer overflow in sunras plugin (#238422)
* Tue Apr 24 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-1
- version 2.2.14

Bugs fixed in GIMP 2.2.14
=========================

- avoid crashing on newer versions of the winicon format (bug #352899)
- fixed crash in Postscript plug-in (bug #353381)
- fixed handling of TABs in the text tool (bug #353132)
- fixed bug in Depth Merge plug-in (bug #355219)
- fixed bug in GimpDrawablePreview widget (bug #353639)
- fixed bug in Line Nove script (bug #357433)
- fixed bug in Ripple plug-in (bug #357431)
- save locale independent files from Fractal Explorer plug-in (bug #360095)
- fixed bug in Super Nova plug-in (bug #340073)
- be more robust against broken XCF files (bug #357809)
- fixed drawing issues in Image Map plug-in (bug #311621)
- fixed smoothing option in Fractal Explorer plug-in (bug #372671)
- load channels in the proper order when opening an XCF file (bug #378003)
- deal with floating selections in the Burn-In Animation script (bug #384096)
- fixed clipping in the GimpPreviewArea widget (bug #392692)
- fixed a potential crash in gimp-remote (bug #392111)
- work around a file-chooser problem on Windows (bug #398726)
- fixed markup of the gimp(1) manual page (bug #401145)
- fixed the fix for the right-to-left layout in layers dialog (bug #348347)
- fixed PSD save plug-in on 64bit architectures (bug #335130)
- added missing dependency in gimpui-2.0.pc file (bug #356394)
- fixed a crash in the PSD save plug-in (bug #395385)
- improved robustness of transform tool preview code (bug #420595)
- improved forward compatibility of XCF loader (bug #316207)
- don't crash in the Compressor plug-in if files can't be opened (bug #422444)
- fixed sensitivity of input fields in the Lighting plug-in (bug #359833)

- don't BuildRequire gimp-print/gutenprint anymore
* Mon Mar 26 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.13-3
- use gutenprint per default for current development/future distribution
versions (Fedora >= 7, RHEL >= 6)
* Mon Mar 26 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.13-2
- own used directories in gimp-devel (#233794)
* Wed Feb 21 2007 Nils Philippsen <nphilipp redhat com>
- s/%redhat/%rhel/g
* Wed Feb  7 2007 Nils Philippsen <nphilipp redhat com>
- really change defaults for use of modular X and lcms (#224156)
* Thu Feb  1 2007 Nils Philippsen <nphilipp redhat com>
- change defaults for use of modular X and lcms (#224156)

---------------------------------------------------------------------
This update can be downloaded from:
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/6/

ba8e7ccb71e74904b304ce6925ceae2e8e336f7d  SRPMS/gimp-2.2.14-5.fc6.src.rpm
ba8e7ccb71e74904b304ce6925ceae2e8e336f7d  noarch/gimp-2.2.14-5.fc6.src.rpm
335e68dd610e71ccab2864bd82a7b1722cea9e4c  ppc/gimp-libs-2.2.14-5.fc6.ppc.rpm
1c1c3ba98ced2a5cadd2beb22352596531a952ba  ppc/gimp-devel-2.2.14-5.fc6.ppc.rpm
a312592041426da6f955243d74a29a45349bcda7  ppc/debug/gimp-debuginfo-2.2.14-5.fc6.ppc.rpm
602522f2ec567dc3320765c94d8bbe60e9c19763  ppc/gimp-2.2.14-5.fc6.ppc.rpm
b3c1975cbf82590d5c72d7e414fb9e8d39d95d9d  x86_64/debug/gimp-debuginfo-2.2.14-5.fc6.x86_64.rpm
524cf3f71081dbd5e44bb256b6894f8b3a4e587e  x86_64/gimp-libs-2.2.14-5.fc6.x86_64.rpm
4d3e6966a32618a6752b36c18c7dd70f4ee747ab  x86_64/gimp-devel-2.2.14-5.fc6.x86_64.rpm
226b073305b15ac9b242559a2a48f46ffecda5a1  x86_64/gimp-2.2.14-5.fc6.x86_64.rpm
4780aaccaa51d9bdda6b7e839f66df55e3a1bd16  i386/gimp-devel-2.2.14-5.fc6.i386.rpm
a861c10fa4feb6c87dfa058c2f24005933979694  i386/gimp-2.2.14-5.fc6.i386.rpm
f97c7df7801ee038fa789db3ccb8abae2908a168  i386/debug/gimp-debuginfo-2.2.14-5.fc6.i386.rpm
3a74780f66699c7705657c02e275dc7ff0396a33  i386/gimp-libs-2.2.14-5.fc6.i386.rpm

This update can be installed with the 'yum' update program.  Use 'yum update
package-name' at the command line.  For more information, refer to 'Managing
Software with yum,' available at http://fedora.redhat.com/docs/yum/.
---------------------------------------------------------------------