From Fedora Project Wiki
(Exclude list given by Dan on the 27th february of 1017)
 
(230 intermediate revisions by 7 users not shown)
Line 1: Line 1:
== Last build B43 ==
+
== PPC64LE EPEL 7 ==
 
+
This page is aboout epel7 packages built for ppc64le in a local development environment based on RHEL7.1
Metrics:
+
getting [https://ftp3.linux.ibm.com/files/ here]
    3 BUILD OK (current build succeed)
+
and epel7 source packages list getting [http://dl.fedoraproject.org/pub/epel/7/SRPMS/ here]
    0 NO SOURCE (current build failed due to no source found)
 
  2068 ALREADY AVAILABLE (package already available, not rebuilt)
 
  239 ALREADY ERROR (package already in error, not rebuilt)
 
    0 CURRENT DEPEND (current build failed due to dependencies)
 
    1 CURRENT ERROR (current build failed due to error)
 
  1651 NOARCH (noarch package (no need to build))
 
    1 BAD VERSION (current build failed due to bad version on dependencies)
 
    0 ARCH NOT FOUND (current build failed due to architecture not supported)
 
    83 EXCLUDE (package not buildable on ppc64le)
 
     
 
  4048 Packages processed by the build
 
  
 
== Tracker bugs ==
 
== Tracker bugs ==
 
Tracker for enabling ppc64le in EPEL 7 is [https://bugzilla.redhat.com/show_bug.cgi?id=1197165 1197165]
 
Tracker for enabling ppc64le in EPEL 7 is [https://bugzilla.redhat.com/show_bug.cgi?id=1197165 1197165]
  
== Tasks ==
 
  
 +
== Failures seen in the official initial EPEL-7 rebuild ==
 
{|
 
{|
 
! Package !! Problem !! Who !! Bugzilla !! Notes !! Dependant packages !! Resolved in build
 
! Package !! Problem !! Who !! Bugzilla !! Notes !! Dependant packages !! Resolved in build
 
|-
 
|-
| aespipe || aespipe FTBFS failed on arch ppc64le. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1142306 1142306] || || aespipe ||
+
| ceres-solver || http://koji.fedoraproject.org/koji/taskinfo?taskID=12108525 || rdossant || [https://bugzilla.redhat.com/show_bug.cgi?id=1289106 1289106] ||  || ||
 +
|-
 +
| odb || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082591 || rdossant ||  || gcc bug [https://bugzilla.redhat.com/show_bug.cgi?id=1256839 1256839] || ||
 +
|-
 +
| gearmand || ppc64le not supported with gearmand-1.1.12-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198706 1198706] || ||
 +
gearmand
 +
php-pecl-gearman
 +
||
 +
|-
 +
| libunwind || ppc64le not supported with libunwind-1.1-3 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198711 1198711] || Shipped in RHEL 7.2 but x86_64 only (pbr) ||
 +
<s>libunwind
 +
ceph
 +
fio
 +
gperftools
 +
nfs-ganesha</s>
 +
|| libunwind-1.1-10
 +
|-
 +
| xalan-c || ppc64le not supported with xalan-c-1.11.0-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198717 1198717] || still failing with last push || ||
 
|-
 
|-
| icewm || Configure error in icewm-1.3.8-5 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1197148 1197148] || || icewm ||
+
| linux_logo || ppc64le not supported with linux_logo-5.11-8.fc21 source. || || || Which component should be used in Bugzilla ? The EPEL linux_logo component! (pbr) || linux_logo ||
 
|-
 
|-
| redhat-rpm-config || ppc64le not supported with redhat-rpm-config-9.1.0 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1193178 1193178] || || ||
+
| thunderbird-lightning || thunderbird-lightning-3.3-5 build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1282848 1282848] || Need to be checked || thunderbird-lightning || Removed from epel7 ppc64
 
|-
 
|-
| alex || ppc64le not supported with alex-3.0.5-36 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198695 1198695] || || alex ||
+
| anjuta || not built for ppc64le || menantea ||  || anjuta ppc64le version is 3.22.0 and needs gcc 5  || ||
 
|-
 
|-
| wxGTK || wxGTK-2.8.12-11 source needed for ppc64le support. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198699 1198699] || Resolved || <s>wxGTK</s> || wxGTK-2.8.12-13
+
| couchdb || couchdb-1.6.1-1  build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1258779 1258779] || Need to check if it can not be re-introduced || couchdb || removed from epel7
 
|-
 
|-
| cfitsio || ppc64le not supported with cfitsio-3.360-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198703 1198703] || || cfitsio ||
+
| libetpan || not built for ppc64le || || || || ||
 
|-
 
|-
| cross-binutils || ppc64le not supported with cross-binutils-2.23.88.0.1-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198704 1198704] || ||
+
| dpm-dsi || not built for ppc64le || menantea || [https://bugzilla.redhat.com/show_bug.cgi?id=1418691 1418691] || Built on fc26, need to be checked on epel7 ||  || dpm-dsi-1.9.11-3
  cross-binutils
+
|-
  cross-gcc
+
| glite-lbjp-common-gsoap-plugin || not built for ppc64le || menantea || [https://bugzilla.redhat.com/show_bug.cgi?id=1418743 1418743] || Built on fc26, need to be checked on epel7 ||  || glite-lbjp-common-gsoap-plugin-3.2.12-11
 +
|-
 +
| ocaml || ocaml not found in RHEL-LE-7.1-GA/Server-optional/ppc64le. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201721 1201721] || still some sub packages missing in RHEL 7.2 (pbr) Need to be checked ||  
 +
  <s>sks</s>
 +
||
 +
|-
 +
| perl-gettext || mkvtoolnix is not buildable because perl-gettext is not found in epel7 || || [https://bugzilla.redhat.com/show_bug.cgi?id=1205736 1205736] [https://bugzilla.redhat.com/show_bug.cgi?id=1196539 1196539] || Shipped in RHEL 7.2 but x86_64 only, mkvtoolnix doesn't need it (pbr)  ||
 +
  <s>mkvtoolnix
 +
po4a</s>
 
  ||
 
  ||
 
|-
 
|-
| DivFix++ || ppc64le not supported with DivFix++-0.34-15 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198705 1198705] || || DivFix++ ||
+
| rust || not built for ppc64le || || || maintainer is working on it || ||
 
|-
 
|-
| gearmand || ppc64le not supported with gearmand-1.1.12-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198706 1198706] || ||
+
|}
gearmand
+
 
  php-pecl-gearman
+
== Resolved bugs ==
  ||
+
 
 +
{|
 +
! Package !! Problem !! Who !! Bugzilla !! Notes !! Dependant packages !! Resolved in build
 +
|-
 +
| aespipe || aespipe FTBFS failed on arch ppc64le. ||  || [https://bugzilla.redhat.com/show_bug.cgi?id=1142306 1142306] [https://bugzilla.redhat.com/show_bug.cgi?id=1287528 1287528]|| Resolved - fix pushed (pbr) || <s>aespipe</s> || aespipe-2.4d-2
 +
|-
 +
| icewm || Configure error in icewm-1.3.8-5 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1197148 1197148] || Resolved - Fix pushed (pbr) || <s>icewm</s> || icewm-1.3.8-9.el7
 +
|-
 +
| redhat-rpm-config || ppc64le not supported with redhat-rpm-config-9.1.0 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1193178 1193178] || Resolved - RHEL problem, not EPEL (pbr)  || ||
 +
|-
 +
| alex || ppc64le not supported with alex-3.0.5-36 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198695 1198695] || Resolved - see ghc (pbr) || <s>alex</s> ||
 +
|-
 +
| wxGTK || wxGTK-2.8.12-11 source needed for ppc64le support. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198699 1198699] || Resolved - fix pushed (pbr) || <s>wxGTK</s> || wxGTK-2.8.12-13
 
|-
 
|-
| hdf5 || ppc64le not supported with hdf5-1.8.12-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198709 1198709] || Resolved || <s>hdf5</s> || hdf5-1.8.12-6
+
| cfitsio || ppc64le not supported with cfitsio-3.360-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198703 1198703] || Resolved || <s>cfitsio</s> || cfitsio-3.360-1
 
|-
 
|-
| libunwind || ppc64le not supported with libunwind-1.1-3 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198711 1198711] || ||  
+
| cross-binutils || ppc64le not supported with cross-binutils-2.23.88.0.1-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198704 1198704] || Resolved - likely needs source from RHEL 7.2 if sticking with the same toolchain as EL7 (pbr) ||
  libunwind
+
  <s>cross-binutils</s>
  ceph
+
  cross-gcc <- not an epel7 package
gperftools
 
nfs-ganesha
 
 
  ||
 
  ||
 
|-
 
|-
| linux_logo || ppc64le not supported with linux_logo-5.11-8.fc21 source. || || || Which component should be used in Bugzilla ? || linux_logo ||
+
| DivFix++ || ppc64le not supported with DivFix++-0.34-15 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198705 1198705] || Resolved - not a bug (it's built) (pbr) || <s>DivFix++</s> ||
 +
|-
 +
| hdf5 || ppc64le not supported with hdf5-1.8.12-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198709 1198709] || Resolved || <s>hdf5</s> || hdf5-1.8.12-6
 
|-
 
|-
| openbabel || ppc64le not supported with openbabel-2.3.2-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198707 1198707] || || openbabel ||
+
| openbabel || ppc64le not supported with openbabel-2.3.2-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198707 1198707] || Resolved (Not a bug)|| <s>openbabel</s> ||
 
|-
 
|-
| udunits2 || ppc64le not supported with udunits2-2.1.24-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198710 1198710] || ||
+
| udunits2 || ppc64le not supported with udunits2-2.1.24-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198710 1198710] || Resolved - still fails [http://koji.fedoraproject.org/koji/taskinfo?taskID=12094708 koji build] (pbr) ||
  udunits2  
+
  <s>udunits2  
 
  gdl  
 
  gdl  
 
  grads  
 
  grads  
 
  ncl  
 
  ncl  
 
  nco  
 
  nco  
  ncview  
+
  ncview</s>
 
  ||
 
  ||
 
|-
 
|-
| userspace-rcu || ppc64le not supported with userspace-rcu-0.7.9-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198712 1198712] || ||  
+
| userspace-rcu || ppc64le not supported with userspace-rcu-0.7.9-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198712 1198712] || Resolved - updated to 0.7.16 (pbr) ||  
  userspace-rcu  
+
  <s>userspace-rcu  
  knot  
+
  knot</s>
  ||
+
  || userspace-rcu-0.7.16-1.el7
 
|-
 
|-
| webkitgtk || ppc64le not supported with webkitgtk-2.2.4-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198713 1198713] || || webkitgtk ||  
+
| webkitgtk || ppc64le not supported with webkitgtk-2.2.4-1 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198713 1198713] || Resolved ||  
 +
<s>webkitgtk
 +
atril</s>
 +
|| webkitgtk-2.4.9-1
 
|-
 
|-
 
| wxPython || ppc64le not supported with wxPython-2.8.12.0-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198715 1198715] || Resolved || <s>wxPython</s> || wxPython-2.8.12.0-8
 
| wxPython || ppc64le not supported with wxPython-2.8.12.0-4 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198715 1198715] || Resolved || <s>wxPython</s> || wxPython-2.8.12.0-8
 
|-
 
|-
| xalan-c || ppc64le not supported with xalan-c-1.11.0-2 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1198717 1198717] || || xalan-c ||
+
| ghc-* || ppc64le not supported with ghc-7.6.3-18.3 and associated ghc-* sources. |||| [https://bugzilla.redhat.com/show_bug.cgi?id=1200404 1200404] || How the hell is not noted this needs llvm 3.4!!!! (pbr)  ||  
|-
 
| ghc-* || ppc64le not supported with ghc-7.6.3-18.3 and associated ghc-* sources. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1200404 1200404] || ||  
 
 
  ghc  
 
  ghc  
 
  + 138 ghc-... packages
 
  + 138 ghc-... packages
  + alex
+
  <s>+ alex</s>
 
  cabal-dev  
 
  cabal-dev  
  cabal-install  
+
  <s>cabal-install  
 
  cabal-rpm  
 
  cabal-rpm  
 
  cpphs  
 
  cpphs  
  darcs  
+
  darcs</s>
 +
fts-rest
 +
<s>GeographicLib
 
  git-annex  
 
  git-annex  
 
  gtk2hs-buildtools  
 
  gtk2hs-buildtools  
Line 95: Line 124:
 
  hlint  
 
  hlint  
 
  hscolour  
 
  hscolour  
  idris  
+
  idris</s>
  pandoc
+
  iwyu
pandoc-citeproc
+
  <s>jwhois
shake
+
kde-plasma-networkmanagement-extras
xmonad
+
  lhapdf
  yumex
+
  llvm
zbackup
+
  ocaml-config-file
||
+
  ocaml-lablgl
|-
 
| qtwebkit || ppc64le not supported with qtwebkit-2.3.3-3 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201180 1201180] || Resolved || <s>qtwebkit</s> || qtwebkit-2.3.4-6
 
|-
 
| ocaml || ocaml not found in RHEL-LE-7.1-GA/Server-optional/ppc64le. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201721 1201721] || ||
 
clamav
 
dragonegg
 
  lhapdf  
 
  llvm  
 
  ocaml-camlp4
 
  octave-control
 
 
  octave  
 
  octave  
 +
octave-control
 
  octave-general  
 
  octave-general  
 
  octave-image  
 
  octave-image  
Line 119: Line 139:
 
  octave-signal
 
  octave-signal
 
  octave-netcdf
 
  octave-netcdf
  pythia8
+
pandoc
 +
pandoc-citeproc
 +
  pythia8</s>
 
  root
 
  root
 
  rootplot
 
  rootplot
  sks
+
  <s>shake
 +
xmonad
 +
yumex</s>
 +
zbackup
 
  ||
 
  ||
 +
|-
 +
| qtwebkit || ppc64le not supported with qtwebkit-2.3.3-3 source. || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201180 1201180] || Resolved || <s>qtwebkit</s> || qtwebkit-2.3.4-6
 
|-
 
|-
 
| cinnamon || cinnamon-xxx packages need source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201801 1201801] || Resolved. cinnamon build problems was due to circular dependencies needed bootstrapping. epel7 does not support gtk >= gtk-3.10, so epel7 is stuck with cinnamon-2.0.x ||
 
| cinnamon || cinnamon-xxx packages need source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1201801 1201801] || Resolved. cinnamon build problems was due to circular dependencies needed bootstrapping. epel7 does not support gtk >= gtk-3.10, so epel7 is stuck with cinnamon-2.0.x ||
Line 136: Line 163:
 
  mate-applet-lockkeys
 
  mate-applet-lockkeys
 
  mate-control-center
 
  mate-control-center
  mate-power-manager</s>
+
  mate-power-manager
 
  mail-notification
 
  mail-notification
  <s>mate-notification-daemon
+
  mate-notification-daemon
 
  mate-sensors-applet
 
  mate-sensors-applet
 
  mate-screensaver
 
  mate-screensaver
Line 155: Line 182:
 
  ||
 
  ||
 
|-
 
|-
| podofo || podofo package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1202796 1202796] || ||  
+
| podofo || podofo package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1202796 1202796] || Resolved - fix pushed (pbr) ||  
  podofo  
+
  <s>podofo  
  scribus  
+
  scribus</s>
  ||
+
  || podofo-0.9.1-17.el7
 
|-
 
|-
| testng || testng not found in epel7 || || [https://bugzilla.redhat.com/show_bug.cgi?id=1202835 1202835] || Resolved ||
+
| testng || testng not found in epel7 || || [https://bugzilla.redhat.com/show_bug.cgi?id=1202835 1202835] || Resolved - Shipped in el 7.2 (pbr) ||
  <s>protobuf</s>
+
  <s>protobuf
 
  java-dirq
 
  java-dirq
  <s>collectd</s>
+
  collectd
 
  dmlite-plugins-adapter
 
  dmlite-plugins-adapter
  <s>dmlite</s>
+
  dmlite
 
  dmlite-plugins-mysql
 
  dmlite-plugins-mysql
  <s>dpm-dsi
+
  dpm-dsi
 
  lcgdm-dav
 
  lcgdm-dav
 
  mosh
 
  mosh
Line 174: Line 201:
 
  || testng-6.8.7-3
 
  || testng-6.8.7-3
 
|-
 
|-
| perl-gettext || mkvtoolnix is not buildable because perl-gettext is not found in epel7 || || [https://bugzilla.redhat.com/show_bug.cgi?id=1205736 1205736] || || mkvtoolnix ||
+
| librx || librx package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1205816 1205816] || Resolved ||  
|-
 
| librx || librx package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1205816 1205816] || Resolved ||  
 
 
  <s>librx
 
  <s>librx
 
  gdal
 
  gdal
 
  GMT</s>
 
  GMT</s>
grass
 
 
  || librx-1.5-24
 
  || librx-1.5-24
 
|-
 
|-
| libva-vdpau-driver || libva-vdpau-driver package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1207780 1207780] || Resolved || <s>libva-vdpau-driver</s> || libva-vdpau-driver-0.7.4-10
+
| libva-vdpau-driver || libva-vdpau-driver package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1207780 1207780] || Resolved || <s>libva-vdpau-driver</s> || libva-vdpau-driver-0.7.4-10
 +
|-
 +
| scsi-target-utils || scsi-target-utils is dependent of glusterfs || || [https://bugzilla.redhat.com/show_bug.cgi?id=1209472 1209472] || Resolved || <s>scsi-target-utils</s> || scsi-target-utils-1.0.55-3
 +
|-
 +
| qt5-qtconfiguration || qt5-qtconfiguration package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1209509 1209509] || Resoleved - [http://koji.fedoraproject.org/koji/taskinfo?taskID=12098909 koji build] (pbr) || <s>qt5-qtconfiguration</s> || qt5-qtconfiguration-0.3.0-3
 +
|-
 +
| thunderbird-lightning || thunderbird-lightning package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1214779 1214779] || Resolved but new bug 1282848 || <s>thunderbird-lightning</s> ||
 +
|-
 +
| gdal || gdal package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1227642 1227642] || Resolved ||
 +
<s>grass
 +
liblas
 +
postgis</s>
 +
||  gdal-1.11.2-1
 +
|-
 +
| dmlite-plugins-adapter || dmlite-plugins-adapter and dmlite-plugins-mysql packages need source update || || [https://bugzilla.redhat.com/show_bug.cgi?id=1228305 1228305] || Resolved - dmlite-plugins... are deprecated ||
 +
<s>dmlite-plugins-adapter
 +
dmlite-plugins-mysql</s>
 +
||
 +
|-
 +
| perl-DBD-Firebird ||  perl-DBD-Firebird t/embed-80-event-ithreads.t fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1228642 1228642] || Resolved || <s>perl-DBD-Firebird</s> || perl-DBD-Firebird-1.20-1
 +
|-
 +
| libgda || libgda package needs source update || || [https://bugzilla.redhat.com/show_bug.cgi?id=1230218 1230218] || Resolved ||
 +
<s>libgda</s>
 +
anjuta
 +
|| libgda-5.2.2-7.el7
 +
|-
 +
| condor ||  condor-8.3.6-1 build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1291049 1291049] ||  Resolved - Note that boost of RHEL7.2 is an old version ||
 +
<s>condor
 +
+ glite-lb... packages</s>
 +
||
 +
|-
 +
| qbittorrent || qbittorrent-3.2.3-2  build fails || rdossant || [https://bugzilla.redhat.com/show_bug.cgi?id=1255788 1255788] || Resolved || <s>qbittorrent</s> ||
 +
|-
 +
| fts || fts-3.3.1-1  build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1260631 1260631] || Resolved || <s>fts-...</s> || fts-3.3.1-3
 +
|-
 +
| MUMPS || MUMPS-5.0.1-4 build fails with RHEL7.2 snapshot of 20151015 || || [https://bugzilla.redhat.com/show_bug.cgi?id=1282460 1282460] || Resolved || <s>MUMPS</s> || MUMPS-5.0.1-8
 +
|-
 +
| perl-File-RsyncP || perl-File-RsyncP-0.74-1 build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1282820 1282829] || Resolved || <s>perl-File-RsyncP</s> || perl-File-RsyncP-0.74-2
 +
|-
 +
| PackageKit-Qt || PackageKit-Qt-0.8.9-2 build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1285361 1285361] || Resolved - Fix pushed || <s>PackageKit-Qt</s> ||
 +
|-
 +
| uwsgi || uwsgi-2.0.11.2-5 build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1285395 1285395] || Resolved || <s>uwsgi</s> || uwsgi-2.0.11.2-7.el7
 +
|-
 +
| xfce4-vala || xfce-bluetooth-0-0.4.20150130git build fails || || [https://bugzilla.redhat.com/show_bug.cgi?id=1287776 1287776] || Resolved - Fix pushed (pbr) || <s>xfce-bluetooth</s> || xfce4-vala-4.10.3-10.el7
 +
|-
 +
| libtommath || gs pipe crashed when creating docs - http://koji.fedoraproject.org/koji/taskinfo?taskID=12081986 || jcapik || [https://bugzilla.redhat.com/show_bug.cgi?id=1243784 1243784] || Resolved - gs segfaulting somewhere in lcms2 library || || libtommath-0.42.0-4.el7
 +
|-
 +
| http-parser || flock tool not found - http://koji.fedoraproject.org/koji/taskinfo?taskID=12038002 || sharkcz || || Resolved- util-linux missing in the buildroot || || http-parser-2.0-5.20121128gitcd01361.el7
 +
|-
 +
| llvm || cherry-pick of ppc64le patches needed from Fedora llvm 3.4 || sharkcz || || Resolved || || llvm-3.4.2-8.el7
 +
|-
 +
| libkate || getopt tool missing - http://koji.fedoraproject.org/koji/taskinfo?taskID=12081953 || sharkcz || || Resolved - util-linux missing in the buildroot || || libkate-0.4.1-5.el7
 +
|-
 +
| sphinx || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082387 || sinnykumari || || Resolved - rebuild of epel7 branch works fine http://koji.fedoraproject.org/koji/taskinfo?taskID=12098117 || || sphinx-2.1.5-2.el7
 +
|-
 +
| libidn2 || http://koji.fedoraproject.org/koji/taskinfo?taskID=12081946 || than || || Resolved - https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d171415c28 || || libidn2-0.10-2.el7
 +
|-
 +
| qt5-qtconfiguration || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082314 || than || [https://bugzilla.redhat.com/show_bug.cgi?id=1289004 1289004] || Resolved - https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-354457e768 || || qt5-qtconfiguration-0.3.0-3.el7
 +
|-
 +
| libtomcrypt || http://koji.fedoraproject.org/koji/taskinfo?taskID=12107979 || jcapik || [https://bugzilla.redhat.com/show_bug.cgi?id=1243784 1243784] || Resolved - crashing gs, build without docs || stoken/dropbear/various vpns || libtomcrypt-1.17-23.el7
 +
|-
 +
| geos || http://koji.fedoraproject.org/koji/taskinfo?taskID=12081878 || rdossant || || Resolved - glibc devel files not found [https://bugzilla.redhat.com/show_bug.cgi?id=1287191 1287191] || <s>gdal/grass</s> libetpan glite-lbjp-common-gsoap-plugin || geos-3.4.2-2.el7
 +
|-
 +
| udunits2 || http://koji.fedoraproject.org/koji/taskinfo?taskID=12107969 ||  || || Resolved - makeinfo not found, because %configure modifies configure || <s>gdl</s> || udunits2-2.2.20-2.el7
 +
|-
 +
| liblxqt || http://koji.fedoraproject.org/koji/taskinfo?taskID=12107958 || than || [https://bugzilla.redhat.com/show_bug.cgi?id=1289613 1289613] || Resolved - liblxqt has build requirement on kf5 stuff which are not available in epel7. working with package maintainer on a fix. there're 2 options, 1. adding kf5 into epel7, 2. revert to 0.8.0 || ||
 +
|-
 +
| dragonegg || http://koji.fedoraproject.org/koji/taskinfo?taskID=12108074 || sharkcz || || Resolved - switch to Exclusive: x86, dead in Fedora || || dragonegg-3.4-5.el7
 +
|-
 +
| oath-toolkit || http://koji.fedoraproject.org/koji/taskinfo?taskID=12108657 || than || || Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-b4f55f2ebe || || oath-toolkit-2.4.1-9.el7
 +
|-
 +
| eigen3 || http://koji.fedoraproject.org/koji/taskinfo?taskID=12081762 || sinnykumari  || [https://bugzilla.redhat.com/show_bug.cgi?id=1289737 1289737] || Resolved - segfault in built tool || <s>tapkee</s> ||
 +
|-
 +
| eyesight || http://koji.fedoraproject.org/koji/taskinfo?taskID=12081812 || than || || Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-96834ab84a || || eyesight-0.1.4-1.el7
 
|-
 
|-
| scsi-target-utils || scsi-target-utils is dependent of glusterfs || || [https://bugzilla.redhat.com/show_bug.cgi?id=1209472 1209472] || || scsi-target-utils ||
+
| qt-creator || http://koji.fedoraproject.org/koji/taskinfo?taskID=12109215 || than || || Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d83c46c846 || || qt-creator-3.5.1-1.el7
 
|-
 
|-
| qt5-qtconfiguration || qt5-qtconfiguration package needs source update for ppc64le || || [https://bugzilla.redhat.com/show_bug.cgi?id=1209509 1209509] || Resolved || <s>qt5-qtconfiguration</s> || qt5-qtconfiguration-0.3.0-2
+
| kBuild || http://koji.fedoraproject.org/koji/taskinfo?taskID=12081872 || than || || Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c045fd9bbe || || kBuild-0.1.9998-5.r2784.el7
 +
|-
 +
| mail-notification || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082512 || sharkcz || || Resolved - same FTBFS also in Fedora || || mail-notification-5.4-66.git.eab5c13.el7
 +
|-
 +
| MUMPS || http://koji.fedoraproject.org/koji/taskinfo?taskID=12109593 || rdossant || || Resolved - newer successful build exists http://koji.fedoraproject.org/koji/buildinfo?buildID=701236 || || MUMPS-5.0.1-8.el7
 +
|-
 +
| vtk || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082428 || jcapik || [https://bugzilla.redhat.com/show_bug.cgi?id=1138466 1138466] || Resolved - The initial issue seems to be fixed, but now the tests fail on missing xorg.log || ||
 +
|-
 +
| trojita || || menantea || [https://bugzilla.redhat.com/show_bug.cgi?id=1290082 1290082] || Resolved - missing inclusion of QObject header || || trojita-0.5-8.el7
 +
|-
 +
| rubygem-ffi || http://koji.fedoraproject.org/koji/taskinfo?taskID=12058425 http://koji.fedoraproject.org/koji/taskinfo?taskID=12058425 ||  || || Resolved - failing test-suite in 1.9.3, 1.9.10 builds fine F-23+, but not in EPEL || ||
 +
|-
 +
| libgda || http://koji.fedoraproject.org/koji/taskinfo?taskID=12082441 ||  || || Resolved - failing to find JNI with openjdk || || libgda-5.2.2-7.el7
 
|-
 
|-
 
|}
 
|}
Line 193: Line 302:
 
== Detailed plans ==
 
== Detailed plans ==
 
* To be investigated:
 
* To be investigated:
 
couchdb
 
dmlite-plugins-adapter
 
dmlite-plugins-mysql
 
grass
 
java-dirq
 
mingw-qt
 
perl-DBD-Firebird
 
tapkee
 
thunderbird-lightning
 
  
 
== Various notes ==
 
== Various notes ==
* automake
+
Host test machine is a ppc64le VM based on RHEL-LE-7.3
Host test machine is a ppc64le VM based on RHEL-LE-7.1-20150219.1-Server-ppc64le-dvd1.iso
 
  
'''automake-1.13.4-3''' is part of the RHEL-LE-7.1-20150219.1-Server-ppc64le-dvd1.iso but some packages needs '''automake-1.14''' like:
+
* ruby
 +
'''ruby-2.0.0''' is part of RHEL-LE-7.3
  
'''libidn2-0.10-1, oath-toolkit-2.4.1-8'''
+
'''ruby-2.1.1''' should be used to better support ppc64le
  
and some packages are dependent of the two above;
+
* gcc
 +
'''gcc 4.8.5''' is part of RHEL-LE-7.3
  
'''jwhois, kde-plasma-networkmanagement-extras, NetworkManager-openconnect, openconnect'''
+
'''gcc 5.1.1''' is used in ppc64le f22
 
 
* mono
 
'''mono-2.10.8-8''' does not build on ppc64le epel7 neither on ppc64le epel7
 
 
 
It seems Fedora's version of mono is horrendously outdated. [https://bugzilla.redhat.com/show_bug.cgi?id=1089426 1089426]
 
  
 
* glusterfs  
 
* glusterfs  
 
''' glusterfs seeems supported in ppc64 and ppc64le fedora 22 but not in redhat and epel7'''
 
''' glusterfs seeems supported in ppc64 and ppc64le fedora 22 but not in redhat and epel7'''
  
* varnish
+
== Packages to be checked in epel7  ppc64le
''' varnish''' could have tests failed because of timeout on HTTP rx.
 
To pass all tests a patch can be done in bin/varnishtest/vtc_main.c to increase vtc_maxdur value.
 
  
== Exclude list ==
+
android-tools
 
+
barcode
Not built in epel7 ppc64
+
dieharder
  clamav
+
<s>glite-lbjp-common-gsoap-plugin</s>
 +
  gnu-smalltalk
 
  GtkAda
 
  GtkAda
 
  GtkAda3
 
  GtkAda3
 +
kicad (boost missing)
 
  lshw
 
  lshw
qemu
 
thunderbird
 
 
Not built in fc22 ppc64le
 
Agda
 
alglib
 
anet
 
banshee
 
cpuid
 
e3
 
edk2
 
elk
 
ga
 
galera
 
gnu-smalltalk
 
gpaw
 
gprolog
 
kBuild
 
libx86
 
libxc
 
mail-notification
 
 
  mine_detector
 
  mine_detector
 
  mongodb
 
  mongodb
  msr-tools
+
  nightview
nwchem
 
OCE
 
openblas
 
openni
 
paraview
 
perl-Parse-DMIDecode
 
php-pecl-xhprof
 
plplot
 
 
  PragmARC
 
  PragmARC
  pvm
+
  rear
  pypy
+
  rust built on fc26 ppc64le but not in epel7
RdRand
+
  sdcc
reptyr
 
  rubygem-ffi
 
  smesh
 
 
  sysprof
 
  sysprof
  trafficserver
+
  tapkee
  wine
+
  wiredtiger
 +
zbackup
 
  zlib-ada
 
  zlib-ada
  
golang: Not built in fc22 ppc64le
+
golang:
golang-bitbucket-kardianos-osext
 
golang-github-codegangsta-cli
 
golang-github-coreos-go-log
 
golang-github-coreos-go-systemd
 
golang-github-fsouza-go-dockerclient
 
golang-github-godbus-dbus
 
golang-github-goraft-raft
 
golang-github-kdar-factorlog
 
golang-github-kraman-libcontainer
 
golang-github-kr-fs
 
golang-github-openshift-go-json-rest
 
golang-github-openshift-go-systemd
 
golang-github-spf13-cobra
 
golang-github-spf13-pflag
 
golang-github-syndtr-gocapability
 
 
  golang-googlecode-gogoprotobuf
 
  golang-googlecode-gogoprotobuf
 
  golang-googlecode-goprotobuf
 
  golang-googlecode-goprotobuf
 
  golang-googlecode-tools
 
  golang-googlecode-tools
 +
 +
In error in ppc64le
 +
banshee
 +
 +
golang: Not built in epel7
 +
 +
golang-github-fsouza-go-dockerclient
 +
golang-github-syndtr-gocapability
 
  golang-github-fsouza-go-dockerclient
 
  golang-github-fsouza-go-dockerclient
  golang-launchpad-gocheck
+
  heketi
  
nodejs: Not built in fc22 ppc64le
+
nodejs: to be checked
 
  nodejs-caller-path
 
  nodejs-caller-path
 
  nodejs-got
 
  nodejs-got
Line 318: Line 375:
 
  nodejs-pg
 
  nodejs-pg
 
  nodejs-ws
 
  nodejs-ws
 +
php-gliph
 +
php-horde-Horde-Imap-Client
 +
php-phpunit-PHPUnit
 +
ptpd
 +
python-copr
 
  python-djblets
 
  python-djblets
 +
python-fmn-rules
 
  ReviewBoard
 
  ReviewBoard
 
  v8
 
  v8
  
mono: Not built in fc22 ppc64le
+
mono: to be checked
 
  dbus-sharp  
 
  dbus-sharp  
 
  dbus-sharp-glib  
 
  dbus-sharp-glib  
Line 330: Line 393:
 
  gnome-sharp  
 
  gnome-sharp  
 
  gtk-sharp2  
 
  gtk-sharp2  
 +
gtk-sharp3
 
  gtk-sharp-beans  
 
  gtk-sharp-beans  
 
  gudev-sharp  
 
  gudev-sharp  
libgpod
 
 
  libyui-bindings  
 
  libyui-bindings  
 
  mono  
 
  mono  
 
  mono-addins  
 
  mono-addins  
 
  mono-zeroconf  
 
  mono-zeroconf  
  notify-sharp  
+
  notify-sharp
  pinta  
+
taglib-sharp
 +
 
 +
== Exclude list (list of packages which not be built for epel7 ppc64le) ==
 +
 
 +
Not built in epel7 ppc64
 +
Agda
 +
anet
 +
bwa
 +
cpuid
 +
darktable
 +
e3
 +
edk2
 +
ga
 +
gprolog
 +
i7z
 +
iwyu
 +
libx86
 +
luajit
 +
memkind
 +
minetest
 +
msr-tools
 +
openni
 +
perl-Parse-DMIDecode
 +
php-pecl-xhprof
 +
qemu
 +
RdRand
 +
reptyr
 +
sbcl
 +
wine
 +
 
 +
== Exclude list given by Dan on the 27th february of 2017 ==
 +
 +
0ad
 +
0install
 +
Agda
 +
anet
 +
banshee
 +
bwa
 +
cabal-dev
 +
cargo
 +
chromium
 +
cjdns
 +
coffee-script
 +
cryptlib
 +
daq
 +
darktable
 +
dbus-sharp
 +
dbus-sharp-glib
 +
digikam
 +
docco
 +
dpm-dsi
 +
dragonegg
 +
e3
 +
edk2
 +
elasticdump
 +
expresso
 +
fedora-gnat-project-common
 +
fish
 +
fts-rest
 +
ga
 +
gdata-sharp
 +
ghc-derive
 +
ghc-geniplate
 +
ghc-gtk
 +
ghc-happstack-server
 +
ghc-hint
 +
ghc-reflection
 +
ghc-shakespeare
 +
ghc-shakespeare-js
 +
gio-sharp
 +
gkeyfile-sharp
 +
glide
 +
gnome-sharp
 +
gnu-smalltalk
 +
golang-bitbucket-ww-goautoneg
 +
golang-github-fsouza-go-dockerclient
 +
golang-github-knieriem-markdown
 +
golang-github-pkg-errors
 +
golang-github-spacemonkeygo-spacelog
 +
golang-github-syndtr-gocapability
 +
golang-googlecode-gogoprotobuf
 +
golang-googlecode-goprotobuf
 +
golang-googlecode-text
 +
golang-googlecode-tools
 +
golang-gopkg-check
 +
golang-gopkg-yaml
 +
gprolog
 +
GtkAda
 +
GtkAda3
 +
gtk-sharp2
 +
gtk-sharp3
 +
gtk-sharp-beans
 +
gudev-sharp
 +
heketi
 +
jasmine-node
 +
keepass
 +
kompose
 +
libcint
 +
libcxx
 +
libmfx
 +
libprelude
 +
libpreludedb
 +
libxsmm
 +
log4net
 +
lttng-tools
 +
lttng-ust
 +
luajit
 +
marked
 +
maxima
 +
memkind
 +
mine_detector
 +
minetest
 +
mocha
 +
mongodb
 +
mono-addins
 +
mono-cecil
 +
mono-zeroconf
 +
msr-tools
 +
nant
 +
node-gyp
 +
nodejs
 +
nodejs-*
 +
nodeunit
 +
notify-sharp
 +
notify-sharp3
 +
npm
 +
nunit
 +
nunit2
 +
nvidia-texture-tools
 +
nvml
 +
openni
 +
orocos-bfl
 +
perl-Parse-DMIDecode
 +
php-pecl-xhprof
 +
  pinta
 +
PragmARC
 +
prelude-lml
 +
prelude-manager
 +
python-openoffice
 +
qcint
 +
RdRand
 +
reptyr
 +
root
 +
rubygem-therubyracer
 +
rust
 +
sbcl
 +
seamonkey
 +
skanlite
 +
statsd
 +
SuperLUMT
 +
sysprof
 
  taglib-sharp
 
  taglib-sharp
 +
tarantool
 +
tmux-top
 +
tpm2-tools
 +
tpm2-tss
 +
uglify-js
 +
uglify-js1
 +
usbguard
 +
v8
 +
vim-go
 +
warsow
 +
warsow-data
 +
wine
 +
wiredtiger
 +
xsp
 +
ycssmin
 +
zlib-ada
 +
 +
Some groups can be seen
 +
- nodejs
 +
- GNAT/Ada based packages
 +
- some Mono/C# packages (mono-*, *-sharp)
 +
 +
There can be few exceptions on top of this list which weren't included
 +
in the bootstrap builds for ppc64le in RHEL 7.2.

Latest revision as of 14:11, 7 March 2017

PPC64LE EPEL 7

This page is aboout epel7 packages built for ppc64le in a local development environment based on RHEL7.1 getting here and epel7 source packages list getting here

Tracker bugs

Tracker for enabling ppc64le in EPEL 7 is 1197165


Failures seen in the official initial EPEL-7 rebuild

Package Problem Who Bugzilla Notes Dependant packages Resolved in build
ceres-solver http://koji.fedoraproject.org/koji/taskinfo?taskID=12108525 rdossant 1289106
odb http://koji.fedoraproject.org/koji/taskinfo?taskID=12082591 rdossant gcc bug 1256839
gearmand ppc64le not supported with gearmand-1.1.12-2 source. 1198706
gearmand 
php-pecl-gearman 
libunwind ppc64le not supported with libunwind-1.1-3 source. 1198711 Shipped in RHEL 7.2 but x86_64 only (pbr)
libunwind 
ceph 
fio
gperftools 
nfs-ganesha 
libunwind-1.1-10
xalan-c ppc64le not supported with xalan-c-1.11.0-2 source. 1198717 still failing with last push
linux_logo ppc64le not supported with linux_logo-5.11-8.fc21 source. Which component should be used in Bugzilla ? The EPEL linux_logo component! (pbr) linux_logo
thunderbird-lightning thunderbird-lightning-3.3-5 build fails 1282848 Need to be checked thunderbird-lightning Removed from epel7 ppc64
anjuta not built for ppc64le menantea anjuta ppc64le version is 3.22.0 and needs gcc 5
couchdb couchdb-1.6.1-1 build fails 1258779 Need to check if it can not be re-introduced couchdb removed from epel7
libetpan not built for ppc64le
dpm-dsi not built for ppc64le menantea 1418691 Built on fc26, need to be checked on epel7 dpm-dsi-1.9.11-3
glite-lbjp-common-gsoap-plugin not built for ppc64le menantea 1418743 Built on fc26, need to be checked on epel7 glite-lbjp-common-gsoap-plugin-3.2.12-11
ocaml ocaml not found in RHEL-LE-7.1-GA/Server-optional/ppc64le. 1201721 still some sub packages missing in RHEL 7.2 (pbr) Need to be checked
sks
perl-gettext mkvtoolnix is not buildable because perl-gettext is not found in epel7 1205736 1196539 Shipped in RHEL 7.2 but x86_64 only, mkvtoolnix doesn't need it (pbr)
mkvtoolnix 
po4a
rust not built for ppc64le maintainer is working on it

Resolved bugs

Package Problem Who Bugzilla Notes Dependant packages Resolved in build
aespipe aespipe FTBFS failed on arch ppc64le. 1142306 1287528 Resolved - fix pushed (pbr) aespipe aespipe-2.4d-2
icewm Configure error in icewm-1.3.8-5 source. 1197148 Resolved - Fix pushed (pbr) icewm icewm-1.3.8-9.el7
redhat-rpm-config ppc64le not supported with redhat-rpm-config-9.1.0 source. 1193178 Resolved - RHEL problem, not EPEL (pbr)
alex ppc64le not supported with alex-3.0.5-36 source. 1198695 Resolved - see ghc (pbr) alex
wxGTK wxGTK-2.8.12-11 source needed for ppc64le support. 1198699 Resolved - fix pushed (pbr) wxGTK wxGTK-2.8.12-13
cfitsio ppc64le not supported with cfitsio-3.360-1 source. 1198703 Resolved cfitsio cfitsio-3.360-1
cross-binutils ppc64le not supported with cross-binutils-2.23.88.0.1-2 source. 1198704 Resolved - likely needs source from RHEL 7.2 if sticking with the same toolchain as EL7 (pbr)
cross-binutils 
cross-gcc <- not an epel7 package
DivFix++ ppc64le not supported with DivFix++-0.34-15 source. 1198705 Resolved - not a bug (it's built) (pbr) DivFix++
hdf5 ppc64le not supported with hdf5-1.8.12-4 source. 1198709 Resolved hdf5 hdf5-1.8.12-6
openbabel ppc64le not supported with openbabel-2.3.2-2 source. 1198707 Resolved (Not a bug) openbabel
udunits2 ppc64le not supported with udunits2-2.1.24-4 source. 1198710 Resolved - still fails koji build (pbr)
udunits2 
gdl 
grads 
ncl 
nco 
ncview 
userspace-rcu ppc64le not supported with userspace-rcu-0.7.9-1 source. 1198712 Resolved - updated to 0.7.16 (pbr)
userspace-rcu 
knot 
userspace-rcu-0.7.16-1.el7
webkitgtk ppc64le not supported with webkitgtk-2.2.4-1 source. 1198713 Resolved
webkitgtk
atril
webkitgtk-2.4.9-1
wxPython ppc64le not supported with wxPython-2.8.12.0-4 source. 1198715 Resolved wxPython wxPython-2.8.12.0-8
ghc-* ppc64le not supported with ghc-7.6.3-18.3 and associated ghc-* sources. 1200404 How the hell is not noted this needs llvm 3.4!!!! (pbr)
ghc 
+ 138 ghc-... packages
+ alex
cabal-dev 
cabal-install 
cabal-rpm 
cpphs 
darcs 
fts-rest
GeographicLib
git-annex 
gtk2hs-buildtools 
happy 
haskell-platform 
hlint 
hscolour 
idris
iwyu 
jwhois
kde-plasma-networkmanagement-extras
lhapdf
llvm
ocaml-config-file
ocaml-lablgl
octave 
octave-control
octave-general 
octave-image 
octave-io 
octave-signal
octave-netcdf
pandoc 
pandoc-citeproc 
pythia8
root
rootplot
shake 
xmonad 
yumex
zbackup
qtwebkit ppc64le not supported with qtwebkit-2.3.3-3 source. 1201180 Resolved qtwebkit qtwebkit-2.3.4-6
cinnamon cinnamon-xxx packages need source update for ppc64le 1201801 Resolved. cinnamon build problems was due to circular dependencies needed bootstrapping. epel7 does not support gtk >= gtk-3.10, so epel7 is stuck with cinnamon-2.0.x
cinnamon
cinnamon-control-center
cinnamon-session
exo
gtkwave
ibus-handwrite
marco
mate-applets
mate-applet-lockkeys
mate-control-center
mate-power-manager
mail-notification
mate-notification-daemon
mate-sensors-applet
mate-screensaver
mate-settings-daemon
mate-utils
orage
Thunar
xfce4-netload-plugin
xfce4-panel
xfce4-session
xfce4-power-manager
xfce4-settings
xfce4-systemload-plugin
xfce4-weather-plugin
xfdesktop
podofo podofo package needs source update for ppc64le 1202796 Resolved - fix pushed (pbr)
podofo 
scribus 
podofo-0.9.1-17.el7
testng testng not found in epel7 1202835 Resolved - Shipped in el 7.2 (pbr)
protobuf
java-dirq
collectd
dmlite-plugins-adapter
dmlite
dmlite-plugins-mysql
dpm-dsi
lcgdm-dav
mosh
ocserv
protobuf-c
testng-6.8.7-3
librx librx package needs source update for ppc64le 1205816 Resolved
librx
gdal
GMT
librx-1.5-24
libva-vdpau-driver libva-vdpau-driver package needs source update for ppc64le 1207780 Resolved libva-vdpau-driver libva-vdpau-driver-0.7.4-10
scsi-target-utils scsi-target-utils is dependent of glusterfs 1209472 Resolved scsi-target-utils scsi-target-utils-1.0.55-3
qt5-qtconfiguration qt5-qtconfiguration package needs source update for ppc64le 1209509 Resoleved - koji build (pbr) qt5-qtconfiguration qt5-qtconfiguration-0.3.0-3
thunderbird-lightning thunderbird-lightning package needs source update for ppc64le 1214779 Resolved but new bug 1282848 thunderbird-lightning
gdal gdal package needs source update for ppc64le 1227642 Resolved
grass
liblas 
postgis
gdal-1.11.2-1
dmlite-plugins-adapter dmlite-plugins-adapter and dmlite-plugins-mysql packages need source update 1228305 Resolved - dmlite-plugins... are deprecated
dmlite-plugins-adapter
dmlite-plugins-mysql
perl-DBD-Firebird perl-DBD-Firebird t/embed-80-event-ithreads.t fails 1228642 Resolved perl-DBD-Firebird perl-DBD-Firebird-1.20-1
libgda libgda package needs source update 1230218 Resolved
libgda
anjuta
libgda-5.2.2-7.el7
condor condor-8.3.6-1 build fails 1291049 Resolved - Note that boost of RHEL7.2 is an old version
condor 
+ glite-lb... packages
qbittorrent qbittorrent-3.2.3-2 build fails rdossant 1255788 Resolved qbittorrent
fts fts-3.3.1-1 build fails 1260631 Resolved fts-... fts-3.3.1-3
MUMPS MUMPS-5.0.1-4 build fails with RHEL7.2 snapshot of 20151015 1282460 Resolved MUMPS MUMPS-5.0.1-8
perl-File-RsyncP perl-File-RsyncP-0.74-1 build fails 1282829 Resolved perl-File-RsyncP perl-File-RsyncP-0.74-2
PackageKit-Qt PackageKit-Qt-0.8.9-2 build fails 1285361 Resolved - Fix pushed PackageKit-Qt
uwsgi uwsgi-2.0.11.2-5 build fails 1285395 Resolved uwsgi uwsgi-2.0.11.2-7.el7
xfce4-vala xfce-bluetooth-0-0.4.20150130git build fails 1287776 Resolved - Fix pushed (pbr) xfce-bluetooth xfce4-vala-4.10.3-10.el7
libtommath gs pipe crashed when creating docs - http://koji.fedoraproject.org/koji/taskinfo?taskID=12081986 jcapik 1243784 Resolved - gs segfaulting somewhere in lcms2 library libtommath-0.42.0-4.el7
http-parser flock tool not found - http://koji.fedoraproject.org/koji/taskinfo?taskID=12038002 sharkcz Resolved- util-linux missing in the buildroot http-parser-2.0-5.20121128gitcd01361.el7
llvm cherry-pick of ppc64le patches needed from Fedora llvm 3.4 sharkcz Resolved llvm-3.4.2-8.el7
libkate getopt tool missing - http://koji.fedoraproject.org/koji/taskinfo?taskID=12081953 sharkcz Resolved - util-linux missing in the buildroot libkate-0.4.1-5.el7
sphinx http://koji.fedoraproject.org/koji/taskinfo?taskID=12082387 sinnykumari Resolved - rebuild of epel7 branch works fine http://koji.fedoraproject.org/koji/taskinfo?taskID=12098117 sphinx-2.1.5-2.el7
libidn2 http://koji.fedoraproject.org/koji/taskinfo?taskID=12081946 than Resolved - https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d171415c28 libidn2-0.10-2.el7
qt5-qtconfiguration http://koji.fedoraproject.org/koji/taskinfo?taskID=12082314 than 1289004 Resolved - https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-354457e768 qt5-qtconfiguration-0.3.0-3.el7
libtomcrypt http://koji.fedoraproject.org/koji/taskinfo?taskID=12107979 jcapik 1243784 Resolved - crashing gs, build without docs stoken/dropbear/various vpns libtomcrypt-1.17-23.el7
geos http://koji.fedoraproject.org/koji/taskinfo?taskID=12081878 rdossant Resolved - glibc devel files not found 1287191 gdal/grass libetpan glite-lbjp-common-gsoap-plugin geos-3.4.2-2.el7
udunits2 http://koji.fedoraproject.org/koji/taskinfo?taskID=12107969 Resolved - makeinfo not found, because %configure modifies configure gdl udunits2-2.2.20-2.el7
liblxqt http://koji.fedoraproject.org/koji/taskinfo?taskID=12107958 than 1289613 Resolved - liblxqt has build requirement on kf5 stuff which are not available in epel7. working with package maintainer on a fix. there're 2 options, 1. adding kf5 into epel7, 2. revert to 0.8.0
dragonegg http://koji.fedoraproject.org/koji/taskinfo?taskID=12108074 sharkcz Resolved - switch to Exclusive: x86, dead in Fedora dragonegg-3.4-5.el7
oath-toolkit http://koji.fedoraproject.org/koji/taskinfo?taskID=12108657 than Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-b4f55f2ebe oath-toolkit-2.4.1-9.el7
eigen3 http://koji.fedoraproject.org/koji/taskinfo?taskID=12081762 sinnykumari 1289737 Resolved - segfault in built tool tapkee
eyesight http://koji.fedoraproject.org/koji/taskinfo?taskID=12081812 than Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-96834ab84a eyesight-0.1.4-1.el7
qt-creator http://koji.fedoraproject.org/koji/taskinfo?taskID=12109215 than Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-d83c46c846 qt-creator-3.5.1-1.el7
kBuild http://koji.fedoraproject.org/koji/taskinfo?taskID=12081872 than Resolved - push it in update, https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-c045fd9bbe kBuild-0.1.9998-5.r2784.el7
mail-notification http://koji.fedoraproject.org/koji/taskinfo?taskID=12082512 sharkcz Resolved - same FTBFS also in Fedora mail-notification-5.4-66.git.eab5c13.el7
MUMPS http://koji.fedoraproject.org/koji/taskinfo?taskID=12109593 rdossant Resolved - newer successful build exists http://koji.fedoraproject.org/koji/buildinfo?buildID=701236 MUMPS-5.0.1-8.el7
vtk http://koji.fedoraproject.org/koji/taskinfo?taskID=12082428 jcapik 1138466 Resolved - The initial issue seems to be fixed, but now the tests fail on missing xorg.log
trojita menantea 1290082 Resolved - missing inclusion of QObject header trojita-0.5-8.el7
rubygem-ffi http://koji.fedoraproject.org/koji/taskinfo?taskID=12058425 http://koji.fedoraproject.org/koji/taskinfo?taskID=12058425 Resolved - failing test-suite in 1.9.3, 1.9.10 builds fine F-23+, but not in EPEL
libgda http://koji.fedoraproject.org/koji/taskinfo?taskID=12082441 Resolved - failing to find JNI with openjdk libgda-5.2.2-7.el7

Detailed plans

  • To be investigated:

Various notes

Host test machine is a ppc64le VM based on RHEL-LE-7.3

  • ruby

ruby-2.0.0 is part of RHEL-LE-7.3

ruby-2.1.1 should be used to better support ppc64le

  • gcc

gcc 4.8.5 is part of RHEL-LE-7.3

gcc 5.1.1 is used in ppc64le f22

  • glusterfs

glusterfs seeems supported in ppc64 and ppc64le fedora 22 but not in redhat and epel7

== Packages to be checked in epel7 ppc64le

android-tools
barcode
dieharder
glite-lbjp-common-gsoap-plugin
gnu-smalltalk
GtkAda
GtkAda3
kicad (boost missing)
lshw
mine_detector
mongodb
nightview
PragmARC
rear
rust  built on fc26 ppc64le but not in epel7
sdcc
sysprof
tapkee
wiredtiger
zbackup
zlib-ada

golang:

golang-googlecode-gogoprotobuf
golang-googlecode-goprotobuf
golang-googlecode-tools

In error in ppc64le

banshee

golang: Not built in epel7

golang-github-fsouza-go-dockerclient
golang-github-syndtr-gocapability
golang-github-fsouza-go-dockerclient
heketi

nodejs: to be checked

nodejs-caller-path
nodejs-got
nodejs-node-expat
nodejs-libxmljs
nodejs-node-stringprep
nodejs-read-all-stream
nodejs-nsp-audit-shrinkwrap
nodejs-require-uncached
nodejs-sprintf
nodejs-split
nodejs
nodejs-bson
nodejs-fs-ext
nodejs-i2c
nodejs-pg
nodejs-ws
php-gliph
php-horde-Horde-Imap-Client
php-phpunit-PHPUnit
ptpd
python-copr
python-djblets
python-fmn-rules
ReviewBoard
v8

mono: to be checked

dbus-sharp 
dbus-sharp-glib 
gdata-sharp 
gio-sharp 
gkeyfile-sharp 
gnome-sharp 
gtk-sharp2 
gtk-sharp3 
gtk-sharp-beans 
gudev-sharp 
libyui-bindings 
mono 
mono-addins 
mono-zeroconf 
notify-sharp
taglib-sharp

Exclude list (list of packages which not be built for epel7 ppc64le)

Not built in epel7 ppc64

Agda
anet
bwa
cpuid
darktable
e3
edk2
ga
gprolog
i7z
iwyu
libx86
luajit
memkind
minetest
msr-tools
openni
perl-Parse-DMIDecode
php-pecl-xhprof
qemu
RdRand
reptyr
sbcl
wine

Exclude list given by Dan on the 27th february of 2017

0ad
0install
Agda
anet
banshee
bwa
cabal-dev
cargo
chromium
cjdns
coffee-script
cryptlib
daq
darktable
dbus-sharp
dbus-sharp-glib
digikam
docco
dpm-dsi
dragonegg
e3
edk2
elasticdump
expresso
fedora-gnat-project-common
fish
fts-rest
ga
gdata-sharp
ghc-derive
ghc-geniplate
ghc-gtk
ghc-happstack-server
ghc-hint
ghc-reflection
ghc-shakespeare
ghc-shakespeare-js
gio-sharp
gkeyfile-sharp
glide
gnome-sharp
gnu-smalltalk
golang-bitbucket-ww-goautoneg
golang-github-fsouza-go-dockerclient
golang-github-knieriem-markdown
golang-github-pkg-errors
golang-github-spacemonkeygo-spacelog
golang-github-syndtr-gocapability
golang-googlecode-gogoprotobuf
golang-googlecode-goprotobuf
golang-googlecode-text
golang-googlecode-tools
golang-gopkg-check
golang-gopkg-yaml
gprolog
GtkAda
GtkAda3
gtk-sharp2
gtk-sharp3
gtk-sharp-beans
gudev-sharp
heketi
jasmine-node
keepass
kompose
libcint
libcxx
libmfx
libprelude
libpreludedb
libxsmm
log4net
lttng-tools
lttng-ust
luajit
marked
maxima
memkind
mine_detector
minetest
mocha
mongodb
mono-addins
mono-cecil
mono-zeroconf
msr-tools
nant
node-gyp
nodejs
nodejs-*
nodeunit
notify-sharp
notify-sharp3
npm
nunit
nunit2
nvidia-texture-tools
nvml
openni
orocos-bfl
perl-Parse-DMIDecode
php-pecl-xhprof
pinta
PragmARC
prelude-lml
prelude-manager
python-openoffice
qcint
RdRand
reptyr
root
rubygem-therubyracer
rust
sbcl
seamonkey
skanlite
statsd
SuperLUMT
sysprof
taglib-sharp
tarantool
tmux-top
tpm2-tools
tpm2-tss
uglify-js
uglify-js1
usbguard
v8
vim-go
warsow
warsow-data
wine
wiredtiger
xsp
ycssmin
zlib-ada 
Some groups can be seen
- nodejs
- GNAT/Ada based packages
- some Mono/C# packages (mono-*, *-sharp)
There can be few exceptions on top of this list which weren't included
in the bootstrap builds for ppc64le in RHEL 7.2.