From Fedora Project Wiki

< Architectures‎ | PowerPC

Revision as of 12:49, 25 March 2015 by Menantea (talk | contribs) (Tasks)

Last build B28

Metrics:

    2 BUILD OK (current build succeed)
    0 NO SOURCE (current build failed due to no source found)
 1993 ALREADY AVAILABLE (package already available, not rebuilt)
  224 ALREADY ERROR (package already in error, not rebuilt)
   49 CURRENT DEPEND (current build failed due to dependencies)
    2 CURRENT ERROR (current build failed due to error)
 1675 NOARCH (noarch package (no need to build))
   15 BAD VERSION (current build failed due to bad version on dependencies)
    0 ARCH NOT FOUND (current build failed due to architecture not supported)
   73 EXCLUDE (package not buildable on ppc64le)
     
 4042 Packages processed by the build

Tracker bugs

Tracker for enabling ppc64le in EPEL 7 is 1197165

Tasks

Package Problem Who Bugzilla Notes Dependant packages Resolved in build
aespipe aespipe FTBFS failed on arch ppc64le. 1142306 aespipe
icewm Configure error in icewm-1.3.8-5 source. 1197148 icewm
redhat-rpm-config ppc64le not supported with redhat-rpm-config-9.1.0 source. 1193178
alex ppc64le not supported with alex-3.0.5-36 source. 1198695 alex
wxGTK wxGTK-2.8.12-11 source needed for ppc64le support. 1198699 wxGTK
cfitsio ppc64le not supported with cfitsio-3.360-1 source. 1198703 cfitsio
cross-binutils ppc64le not supported with cross-binutils-2.23.88.0.1-2 source. 1198704 cross-binutils cross-gcc
DivFix++ ppc64le not supported with DivFix++-0.34-15 source. 1198705 DivFix++
gearmand ppc64le not supported with gearmand-1.1.12-2 source. 1198706 gearmand php-pecl-gearman
hdf5 ppc64le not supported with hdf5-1.8.12-4 source. 1198709 hdf5
libunwind ppc64le not supported with libunwind-1.1-3 source. 1198711 libunwind ceph gperftools nfs-ganesha
linux_logo ppc64le not supported with linux_logo-5.11-8.fc21 source. Which component should be used in Bugzilla ? linux_logo
openbabel ppc64le not supported with openbabel-2.3.2-2 source. 1198707 openbabel
udunits2 ppc64le not supported with udunits2-2.1.24-4 source. 1198710 udunits2 gdl grads ncl nco ncview
userspace-rcu ppc64le not supported with userspace-rcu-0.7.9-1 source. 1198712 userspace-rcu knot
webkitgtk ppc64le not supported with webkitgtk-2.2.4-1 source. 1198713 webkitgtk
wxPython ppc64le not supported with wxPython-2.8.12.0-4 source. 1198715 wxPython
xalan-c ppc64le not supported with xalan-c-1.11.0-2 source. 1198717 xalan-c
ghc-* ppc64le not supported with ghc-7.6.3-18.3 and associated ghc-* sources. 1200404 ghc + 138 ghc-... packages + alex cabal-dev cabal-install cabal-rpm cpphs darcs git-annex gtk2hs-buildtools happy haskell-platform hlint hscolour idris pandoc pandoc-citeproc shake xmonad
qtwebkit ppc64le not supported with qtwebkit-2.3.3-3 source. 1201180 qtwebkit
ocaml ocaml not found in RHEL-LE-7.1-GA/Server-optional/ppc64le. 1201721 clamav dragonegg lhapdf llvm ocaml octave-control octave octave-general octave-image octave-io octave-signal octave-netcdf pythia8 root rootplot sks
cinnamon cinnamon-xxx packages need source update for ppc64le 1201801 cinnamon cinnamon-control-center cinnamon-session exo gtkwave ibus-handwrite marco mate-applets mate-applet-lockkeys mate-control-center mate-power-manager mail-notification mate-notification-daemon mate-sensors-applet mate-screensaver mate-settings-daemon mate-utils orage Thunar xfce4-netload-plugin xfce4-panel xfce4-session xfce4-power-manager xfce4-settings xfce4-systemload-plugin xfce4-weather-plugin xfdesktop
podofo podofo package needs source update for ppc64le 1202796 podofo scribus
testng testng not found in epel7 1202835 dependency of protobuf protobuf java-dirq collectd dmlite-plugins-adapter dmlite dmlite-plugins-mysql dpm-dsi lcgdm-dav mosh ocserv protobuf-c zbackup

Detailed plans

  • To do...

Various notes

  • automake

Host test machine is a ppc64le VM based on RHEL-LE-7.1-20150219.1-Server-ppc64le-dvd1.iso

automake-1.13.4-3 is part of the RHEL-LE-7.1-20150219.1-Server-ppc64le-dvd1.iso but some packages needs automake-1.14 like:

libidn2-0.10-1, oath-toolkit-2.4.1-8

and some packages are dependent of the two above;

jwhois, kde-plasma-networkmanagement-extras, NetworkManager-openconnect, openconnect

  • mono

mono-2.10.8-8 does not build on ppc64le epel7 neither on ppc64le epel7

It seems Fedora's version of mono is horrendously outdated. 1089426