From Fedora Project Wiki

(Whoops! You need control-center from rawhide, too. (Which makes it virtually impossible without a full rawhide install, but oh well.))
(delete contents; wildly out of date now and just confusing)
 
Line 1: Line 1:
# <code>yum -y install git glib2-devel dbus-devel dbus-glib-devel pam-devel libX11-devel libsexy-devel xmlto sqlite-devel NetworkManager-glib-devel PolicyKit-devel libtool docbook-utils gnome-doc-utils python-devel perl(XML::Parser) intltool gettext xulrunner-devel libarchive-devel gstreamer-devel gstreamer-plugins-base-devel qt4-devel cppunit-devel pango-devel fontconfig-devel</code>
 
# <code>git clone git://anongit.freedesktop.org/git/packagekit/PackageKit</code>
 
# <code>cd PackageKit</code>
 
# <code>git pull</code>
 
# <code>mkdir ~/.root</code>
 
# <code>./autogen.sh --enable-maintainer-mode --enable-gtk-doc --prefix=~/.root --enable-yum --enable-yum2 --enable-dummy --enable-docbook-docs --enable-tests --enable-developer --enable-local --with-default-backend=yum</code>
 
# <code>make && make install</code>
 
# <code>cd src</code>
 
# <code>sudo ./run-pk.sh yum</code>
 
In another tab:
 
# <code>cd PackageKit</code>
 
# <code>cd client</code>
 
# <code>./pkcon search name git</code>
 
  
== For gnome-packagekit: ==
 
{{admon/important|Rawhide Required|Note that building the current gnome-packagekit source requires gtk3 libraries newer than the ones available in Fedora 14. If you wish to build gnome-packagekit, it will be necessary to install rawhide packages for gtk3 and any dependencies.}}
 
# <code>git clone git://people.freedesktop.org/~hughsient/gnome-packagekit</code>
 
# <code>cd gnome-packagekit</code>
 
# <code>mkdir ~/.root</code>
 
# <code>yum -y install libgnomeui-devel libglade2-devel libwnck-devel dbus-devel libnotify-devel gnome-panel-devel scrollkeeper gnome-doc-utils desktop-file-utils gettext libtool cairo-devel startup-notification-devel perl(XML::Parser) gnome-doc-utils gnome-menus-devel libsexy-devel PackageKit-devel PolicyKit-gnome-devel unique-devel intltool xorg-x11-proto-devel fontconfig-devel upower-devel</code>
 
# <code> yum --enablerepo=rawhide install gtk3 gtk3-devel libcanberra-gtk3 control-center-devel</code>
 
# <code>./autogen.sh --prefix=/home/hughsie/.root --enable-tests --enable-gtk-doc</code>
 
# <code>make && make install</code>
 
# <code>cd src</code>
 
# <code>killall gpk-update-icon</code>
 
# <code>./gpk-update-icon -v</code>
 
In another tab:
 
# <code>cd src</code>
 
# <code>./gpk-application -v</code>
 
 
== For KPackageKit: ==
 
# <code>yum -y install svn cmake desktop-file-utils kde-filesystem kdelibs4-devel PackageKit-qt-devel</code>
 
# <code>svn co svn://anonsvn.kde.org/home/kde/trunk/playground/sysadmin/kpackagekit</code>
 
# <code>mkdir ~/.root</code>
 
# <code>cd kpackagekit</code>
 
# <code>cmake -DCMAKE_INSTALL_PREFIX=~/.root .</code>
 
# <code>make</code>
 
# <code>make install</code>
 
# <code>cd KPackageKit</code>
 
# <code>./kpackagekit</code>
 
 
Any problems, please send a message to the mailing list: http://lists.freedesktop.org/mailman/listinfo/packagekit
 

Latest revision as of 09:27, 29 November 2013