From Fedora Project Wiki
m (Add trackers)
 
(10 intermediate revisions by 2 users not shown)
Line 1: Line 1:
{{admon/important | Comments and Explanations | The page source contains comments providing guidance to fill out each section. They are invisible when viewing this page. To read it, choose the "view source" link.<br/> }}
 
 
= Bash 5.0
 
 
 
== Summary ==
 
== Summary ==
  
Line 34: Line 30:
 
CLOSED as NEXTRELEASE -> change is completed and verified and will be delivered in next release under development
 
CLOSED as NEXTRELEASE -> change is completed and verified and will be delivered in next release under development
 
-->
 
-->
* Tracker bug: <will be assigned by the Wrangler>
+
* Tracker bug: [https://bugzilla.redhat.com/show_bug.cgi?id=1675080 #1675080]
 +
* Release notes tracker: [https://pagure.io/fedora-docs/release-notes/issue/295 #295]
  
 
== Detailed Description ==
 
== Detailed Description ==
Line 113: Line 110:
  
 
== Upgrade/compatibility impact ==
 
== Upgrade/compatibility impact ==
It should be minimum as this release is largely backward compatible.
+
Code related to resolving namerefs was changed, so some scripts may break. But impact should be minimum as this release is largely backward compatible.
  
 
<!-- What happens to systems that have had a previous versions of Fedora installed and are updated to the version containing this change? Will anything require manual configuration or data migration? Will any existing functionality be no longer supported? -->
 
<!-- What happens to systems that have had a previous versions of Fedora installed and are updated to the version containing this change? Will anything require manual configuration or data migration? Will any existing functionality be no longer supported? -->
Line 179: Line 176:
 
-->
 
-->
  
[[Category:ChangePageIncomplete]]
 
 
<!-- When your change proposal page is completed and ready for review and announcement -->
 
<!-- When your change proposal page is completed and ready for review and announcement -->
 
<!-- remove Category:ChangePageIncomplete and change it to Category:ChangeReadyForWrangler -->
 
<!-- remove Category:ChangePageIncomplete and change it to Category:ChangeReadyForWrangler -->
Line 186: Line 182:
  
 
<!-- Select proper category, default is Self Contained Change -->
 
<!-- Select proper category, default is Self Contained Change -->
[[Category:SelfContainedChange]]
+
[[Category:SystemWideChange]]
 +
[[Category:ChangeAcceptedF30]]
 
<!-- [[Category:SystemWideChange]] -->
 
<!-- [[Category:SystemWideChange]] -->

Latest revision as of 19:29, 11 February 2019

Summary

Upgrade bash to 5.0 release. This release fixes several outstanding bugs in bash-4.4 and introduces several new features. The most significant bug fixes are an overhaul of how nameref variables resolve and a number of potential out-of-bounds memory errors discovered via fuzzing.

Owner

  • Email: svashisht@redhat.com
  • Release notes owner:

Current status

Detailed Description

There are a number of changes to the expansion of $@ and $* in various contexts where word splitting is not performed to conform to a Posix standard interpretation, and additional changes to resolve corner cases for Posix conformance.

The most notable new features are several new shell variables: BASH_ARGV0, EPOCHSECONDS, and EPOCHREALTIME. The history builtin can remove ranges of history entries and understands negative arguments as offsets from the end of the history list. There is an option to allow local variables to inherit the value of a variable with the same name at a preceding scope. There is a new shell option that, when enabled, causes the shell to attempt to expand associative array subscripts only once (this is an issue when they are used in arithmetic expressions). The `globasciiranges' shell option is now enabled by default; it can be set to off by default at configuration time.

There are a few incompatible changes between bash-4.4 and bash-5.0. The changes to how nameref variables are resolved means that some uses of namerefs will behave differently, though upstream has tried to minimize the compatibility issues.


Benefit to Fedora

Bash is the default shell in Fedora and it will benefit from new features and performance improvements of the latest release.


Scope

  • Proposal owners: Upgrade bash to 5.0
  • Other developers: N/A (not a System Wide Change)
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

Code related to resolving namerefs was changed, so some scripts may break. But impact should be minimum as this release is largely backward compatible.


How To Test

N/A (not a System Wide Change)

User Experience

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: (What to do? Who will do it?) N/A (not a System Wide Change)
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? N/A (not a System Wide Change), Yes/No
  • Blocks product? product

Documentation

N/A (not a System Wide Change)

Release Notes

https://lists.gnu.org/archive/html/bug-bash/2019-01/msg00063.html