From Fedora Project Wiki
m (Add releng ticket number)
m (Fix typos)
Line 25: Line 25:
 
these packages, they are marked as deprecated.
 
these packages, they are marked as deprecated.
  
As of time of submision of this change proposal, 10 Fedora components
+
As of time of submission of this change proposal, 10 Fedora components
stil Require or BuildRequire Apache Avalon packages, therefore
+
still Require or BuildRequire Apache Avalon packages, therefore
 
immediate retirement of these packages is not feasible at this point.
 
immediate retirement of these packages is not feasible at this point.
  

Revision as of 15:23, 12 December 2018

Deprecate Apache Avalon

Summary

Mark Apache Avalon software packages as deprecated.

Owner

Current status

  • Targeted release: Fedora 30
  • Last updated: 2018-12-12
  • Tracker bug: <will be assigned by the Wrangler>

Detailed Description

Apache Avalon project was closed by upstream [1] in October 2004 (more than 14 years ago), approximately one month after it was added to Fedora Core 4 in September 2004.

Apache Avalon software packages are intended to be eventually removed from Fedora, but are kept in Fedora for some additional, indeterminate time for various reasons including maintaining backwards compatibility. In order to prevent new packages from depending on these packages, they are marked as deprecated.

As of time of submission of this change proposal, 10 Fedora components still Require or BuildRequire Apache Avalon packages, therefore immediate retirement of these packages is not feasible at this point.

Benefit to Fedora

Packages of obsolete Apache Avalon software will be clearly and explicitly marked as deprecated. Other packages in Fedora will not be able to add dependencies on deprecated packages (that includes Requires, BuildRequires, Recommends, Suggests, etc.). This applies both for updates of existing packages and new packages added to Fedora. This in turn will make it easier to gradually remove dependencies on deprecated packages and finally remove deprecated Apache Avalon software from Fedora.

Scope

  • Proposal owners: add special virtual provides deprecated() to all packages built from avalon-framework and avalon-logkit source components.
  • Other developers: N/A (not a System Wide Change)
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

N/A (not a System Wide Change)

How To Test

N/A (not a System Wide Change)

User Experience

No change in user experience. Technically, nothing changes; deprecated packages work and behave as before.

Dependencies

N/A (not a System Wide Change)

Contingency Plan

  • Contingency mechanism: N/A (not a System Wide Change)
  • Contingency deadline: N/A (not a System Wide Change)
  • Blocks release? N/A (not a System Wide Change)

Documentation

N/A (not a System Wide Change)

Release Notes