From Fedora Project Wiki

< Changes

Revision as of 00:35, 6 January 2019 by Kkofler (talk | contribs) (Mention that a libmysqld is provided by MariaDB.)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)

MySQL 8

Summary

Update of MySQL ( community-mysql package) in Fedora from 5.7 to 8.0 version.

Owner

Current status

Detailed Description

Update of MySQL package in Fedora from 5.7 version to 8.0 version.

Benefit to Fedora

I'm cooperating with the upstream to bring the latest stable software to Fedora users.

Scope

  • Proposal owners:
    • Release MySQL 8.0.11 to Rawhide (done)
    • Check software that requires community-mysql package (done, only mysql-connector-odbc)
    • Gather user input on the changes between mysql 5.7 and 8.0
  • Other developers: N/A (not a System Wide Change)
  • Policies and guidelines: N/A (not a System Wide Change)
  • Trademark approval: N/A (not needed for this Change)

Upgrade/compatibility impact

The 'libmysqld' embedded server library has been removed by upstream. (Though, applications requiring 'libmysqld' can be (re)built against mariadb-embedded-devel, which Provides mysql-embedded-devel and ships a libmysqld.so symlink to libmariadbd.so.*.)

Downgrade from MySQL 8 to MySQL 5.7 is not supported.

How To Test

Usual testing as when upgrading between major MySQL versions.

Test that all other software runs well with MySQL 8. Report any issues, so I can reach the different upstreams and check if they plan update their software to support MySQL 8 and when.

User Experience

The users will have to migrate their applications and databases, if the y want to use MySQL 8.

If the users want to stick with MySQL 5.7 for a little longer, I'm providing COPR repo with MySQL 5.7 built from f28 branch for Rawhide.

Also, module with MySQL 5.7 is planned.

Dependencies

mysql-connector-odbc

  • also maintained by me
  • currently FTBFS against the MySQL 8.0.11, working on the fix. However for MariaDB there is mariadb-connector-odbc, so users don't depend on this piece of software.

There may be more software, which does not support MySQL 8 yet. For such occurences, COPR repo with MySQL 5.7 was created.

Contingency Plan

The COPR repository until F29 freeze seems enough to me. For F29, there should be a module available with MySQL 5.7 to cover users that can't / don't want to upgrade.

  • Contingency mechanism: COPR and Module with MySQL 5.7 available
  • Contingency deadline: beta freeze
  • Blocks release? N/A (not a System Wide Change)
  • Blocks product? N/A (not a System Wide Change)

Documentation

Upgrading and incompatibilities: https://dev.mysql.com/doc/refman/8.0/en/upgrading-from-previous-series.html

Upgrade startegy: https://dev.mysql.com/doc/refman/8.0/en/upgrading-strategies.html

Release Notes

Release notes for each release: https://dev.mysql.com/doc/relnotes/mysql/8.0/en/

Overall overview of the changes in 8.0: https://dev.mysql.com/doc/refman/8.0/en/mysql-nutshell.html