Common F11 bugs

From FedoraProject

(Difference between revisions)
Jump to: navigation, search
(add a note on suspend fail with kernel oops (499651))
(move updates-pending-star to resolved issues)
Line 67: Line 67:
  
 
An [http://dcantrel.fedorapeople.org/491754.img updates.img] file is available to work around the defect. This image is provided through the Fedora project space of David Cantrell, one of the Anaconda maintainers. For additional information on using an {{file|updates.img}} with the installer, see [[Anaconda/Updates]].
 
An [http://dcantrel.fedorapeople.org/491754.img updates.img] file is available to work around the defect. This image is provided through the Fedora project space of David Cantrell, one of the Anaconda maintainers. For additional information on using an {{file|updates.img}} with the installer, see [[Anaconda/Updates]].
 +
 +
{{Anchor|updates-pending-star}}
 +
=== Update notification doesn't disappear ===
 +
<small>[[Common F11 bugs#updates-pending-star|link to this item]] - [[rhbug:492005|Bugzilla: #492005]]</small>
 +
 +
After updating using PackageKit, the updates notice may reappear even when there are no package updates left to receive.
 +
 +
An updated [https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5748 gnome-packagekit] package has been released to address this issue. Update your system as usual to receive this update, if you do not yet already have it.
  
 
== Issues when upgrading from previous releases ==
 
== Issues when upgrading from previous releases ==
Line 439: Line 447:
  
 
Please also see the [https://fedoraproject.org/wiki/Documentation_Networking_Beat#Ethernet_connections_are_not_started_at_first_boot future release note] describing this, and a [http://fedorasolved.org/Members/khaytsus/go-online-automatically-at-boot graphical description of the steps to take to make this setting].
 
Please also see the [https://fedoraproject.org/wiki/Documentation_Networking_Beat#Ethernet_connections_are_not_started_at_first_boot future release note] describing this, and a [http://fedorasolved.org/Members/khaytsus/go-online-automatically-at-boot graphical description of the steps to take to make this setting].
 
{{Anchor|updates-pending-star}}
 
=== Update notification doesn't disappear ===
 
<small>[[Common F11 bugs#updates-pending-star|link to this item]] - [[rhbug:492005|Bugzilla: #492005]]</small>
 
 
After updating using PackageKit, the updates notice may reappear even when there are no package updates left to receive.
 
 
An updated [https://admin.fedoraproject.org/updates/F11/FEDORA-2009-5748 gnome-packagekit] package has been submitted to the updates repository. Users experiencing this problem are encouraged to update to this package which is reported to fix the problem. To test the update, run this command: <tt>su -c 'yum update gnome-packagekit'</tt>.
 
  
 
{{Anchor|random-display-blank}}
 
{{Anchor|random-display-blank}}

Revision as of 19:04, 21 July 2009

This page documents common bugs in Fedora 11 and, if available, fixes or workarounds for these problems. If you find your problem in this page, do not file a bug for it, unless otherwise instructed. Where appropriate, a reference to the current bug(s) in Bugzilla is included.

Contents

Release Summary, Announcement and Notes

Read the Fedora 11 Preview release notes for specific information about changes in Fedora 11 Preview, known issues, and other general information.

My bug is not listed

Not every bug is listed in this page, but Bugzilla should be a comprehensive database of known bugs. This page is a sampling of the bugs most commonly discussed on our mailing lists and forums.

To see if your bug has already been reported, you can search Bugzilla. If it has not yet been reported, we encourage you to do so to help improve Fedora for yourself and others. A guide to Bugs and feature requests has been prepared to assist you.

If you believe an already-reported bug report should be added to this page because it is commonly encountered, you can:

  • Add it yourself, if you have wiki access. Remember to try and follow the style and guidelines explained in the comments in the page source.
  • Add the CommonBugs keyword to the bug report, and contact the Fedora QA team with the Bugzilla report number explaining why you believe that particular report qualifies as a common issue. You can contact Fedora QA through any of the methods listed here.


Resolved issues

Some fingerprint readers do not work with non-zero bytes in cmd response error

link to this item - Bugzilla: #500460

Some fingerprint reader models (including at least the ones in some Thinkpad T43 laptop models) failed to work at all in Fedora 11. If you ran an application which attempts to use the fingerprint reader from a console, the following error messages were observed:

upekts:warning [__handle_incoming_msg] non-zero bytes in cmd response: fb ff

An updated libfprint package has been released to address this issue. Update your system as usual to receive this update, if you do not yet already have it.

Installation fails with DeviceError: cannot commit to disk sda after 5 attempts

link to this item - Bugzilla: #491754

Several users reported a failure during installation of Fedora 11. While partitioning your disk(s), the anaconda installer might fail and present an error message indicating DeviceError: cannot commit to disk sda after 5 attempts. Subsequent attempts to install the system using the same steps appear to be successful in some, but not all, cases. In other cases, changing the chosen partition layout seemed to avoid the problem.

An updates.img file is available to work around the defect. This image is provided through the Fedora project space of David Cantrell, one of the Anaconda maintainers. For additional information on using an Template:File with the installer, see Anaconda/Updates.

Update notification doesn't disappear

link to this item - Bugzilla: #492005

After updating using PackageKit, the updates notice may reappear even when there are no package updates left to receive.

An updated gnome-packagekit package has been released to address this issue. Update your system as usual to receive this update, if you do not yet already have it.

Issues when upgrading from previous releases

As usual, the supported methods for upgrading from previous Fedora releases are to do an 'upgrade install' from the regular installation media, or to use preupgrade (see How_to_use_PreUpgrade). Upgrading by using yum directly is not supported, but may in practice work. For known issues when upgrading via yum, see the page on this upgrade method.

Upgrade fails while editing existing bootloader entry

link to this item - Bugzilla: #501057

While upgrading your system using anaconda, the Fedora installer, you are given the option to update your bootloader configuration, create a new bootloader configuration or skip any bootloader configuration changes. When choosing to create a new bootloader configuration, the installer may fail while attempting to edit the default bootloader target created by the installer. To work around this issue, edit the default bootloader configuration after the upgrade completes and your system reboots. If changes are needed prior to a system reboot, you may manually edit the configuration by pressing <ctrl><alt>F2 and edit the bootloader configuration file by typing:
 vi /mnt/sysimage/etc/grub.conf

Can't find .i686 kernel

The kernel.i686 RPM is no longer produced. All .i386 and .i486 packages have been rebuilt as .i586 (Pentium class). These designations represent the minimum supported architecture version; Fedora 11 is optimized for Pentium 4-compatible and later processors. Fedora has never officially supported pre-Pentium architectures, and dropping any remaining backwards compatibility with these chips further improves performance and allows for code simplification.

The following kernels are available instead:

  • kernel.i586, for those requiring compatibility with a Pentium-class architecture or who do not have a PAE and NX capable processor.
  • kernel-PAE.i686, which requires a PAE and NX capable processor with Pentium PRO-class or later architecture.

After analyzing the differences between the i585 and i686 architectures, dropping the non-PAE i686 kernel is not expected to have a negative performance impact for those required to use the kernel.i586 package. The kernel-PAE.i686 RPM has additional capabilities, such as support for ExecShield security and the ability to address up to 64GB of RAM (the standard kernel can address only 4GB). Note that the architecture designations in RPM names represent the minimum supported architecture version; Fedora 11 is optimized for Pentium 4-compatible and later processors.

Anaconda (the recommended install method) will automatically choose the best kernel for your hardware.

If you are using the "yum upgrade" method (not recommended), you may receive the kernel.i586 package even if your processor would support the kernel-PAE.i686 package. To determine this, run the command:

grep 'flags.* pae' /proc/cpuinfo | grep -wq nx && echo 'kernel-PAE'

If you see "kernel-PAE" in the output, then your CPU is capable of using this package, and you can manually "yum install kernel-PAE".

The installer does not honor skip bootloader choice

link to this item - Bugzilla: #501063

While upgrading your system using anaconda, the Fedora installer, you are given the option to update your bootloader configuration, create a new bootloader configuration or skip any bootloader configuration changes. When choosing to 'skip any bootloader configuration changes, the installer will ignore this select and update any existing bootloader configuration. To work around this issue, save the existing bootloader configuration prior to upgrade, and restore that configuration after the upgrade completes and your system reboots. If changes are needed prior to a system reboot, you may manually edit the configuration by pressing <ctrl><alt>F2 and edit the bootloader configuration file by typing:
 vi /mnt/sysimage/etc/grub.conf

Yum doesn't work after upgrading from F10

link to this item - Bugzilla: #506685

When upgrading from an updated F10 install, yum ends up not working - outputting an error about no yum module found.

The version of yum in f10-updates was newer than the one in F11-GA - it caused yum to not be updated during the anaconda upgrade process. There is a simple one-time work around as root:

export PYTHONPATH=/usr/lib/python2.5/site-packages

yum clean all

yum update yum

That should update you to the current yum from F11-updates and you'll be all set.

Installation issues

Documentation for ISO images is faulty

link to this item - Bugzilla: #504228

The README-BURNING-ISOS file distributed on mirrors along with the CD and DVD images contains an incorrect filename for the checksum file, which is now Fedora-11-<arch>-CHECKSUM. Additionally, it refers to SHA-1 checksums instead of SHA-256 checksums. To check the contents of a downloaded ISO image using an existing Linux operating system, use the sha256sum command instead of sha1sum. As stated correctly in the document, the BitTorrent download method automatically performs checksums during download, so no additional procedure is required in that case.

The Documentation team is aware of this bug. Although the file cannot be easily changed after mirror distribution, this issue will be fixed for the next release.

Live image installations fail with FSError: filesystem has not been created

link to this item - Bugzilla: #498553

Several users have reported a failure occurring during installation from a Fedora 11 live media environment. During the disk partitioning phase of the installer, a window focus interaction issue between the metacity, the GNOME window manager, and the Fedora installer may allow the user to click the Next button of the installer before partitioning has completed. Doing so will result in a failure message, FSError: filesystem has not been created. To workaround this issue, it is recommended that users verify that no installer partitioning progress dialogs are present before clicking the Next button until all partitioning operations have completed. Due to the windowing environment that the live image installer runs from, it is possible that a partitioning progress dialog does not have focus and is behind the main installer window. Before proceeding to the Next phase of the installation, verify that no installer partitioning progress dialogs are present.

Booting Fedora 11 live media created with livecd-iso-to-disk from a Fedora 9 system fails to boot

link to this item - Bugzilla: #498155

Fedora 11 live media created from a Fedora 9 system using livecd-iso-to-disk may fail during boot with a message, Unable to find root filesystem or a grey screen.

An updated livecd-tools package has been submitted to the Fedora 9 updates-testing repository for testing. Fedora 9 users experiencing this problem while creating Fedora 11 live media are encouraged to test this update and report to Bodhi whether it solves the problem.

Booting Fedora 11 live media created with liveusb-creator from a Fedora 9 or Fedora 10 system fails to boot

link to this item - Bugzilla: #494000

Fedora 11 live media created from a Fedora 9 system using liveusb-creator may fail during boot with a message, Unable to find root filesystem or a grey screen. The recommended workaround for this issue is to use livecd-iso-to-disk - the command line tool - instead, with reference to issue 498155 above for Fedora 9 users, and to the instructions for using this tool. Fedora 10 may be able to work around the issue by installing the Fedora 11 version of the syslinux package, but that may have unpredictable results for other operations and is hence not recommended.

QEMU/KVM DVD installs under a Fedora 11 host hang when attempting to eject DVD

link to this item - Bugzilla: #501412

KVM users may experience that Fedora 11 DVD installs hang prior to ejecting the virtual optical DVD media. This issue is the result of interactions in QEMU's IDE CDROM emulation for eject and tray locking. Users may work around this issue by restarting the hung guest.

An updated qemu package has been submitted to the updates-testing repository for testing. Users experiencing this problem are encouraged to test this update and report to Bodhi whether it solves the problem. To test the update, run this command:

su -c 'yum --enablerepo=updates-testing  install qemu'

Installation fails with PartitionException: Can't have overlapping partitions

link to this item - Bugzilla: #499544

Several users have reported installation failures while attempting to re-use or resize existing disk partitions during an install. The most common reproducer occurs while resizing existing partitions under the Create custom layout partitioning option. If you encounter this failure and the use of existing partitions is required, it is recommended that you resize your partitions prior to performing the installation. This page will be updated when more information is available.

Installation fails while editing previously encrypted partition - IndexError: list index out of range

link to this item - Bugzilla: #502310

Several users have reported installation failures while attempting to edit previously encrypted disk partitions during an install. When the installer discovers encrypted volumes, it will prompt the user for a passphrase needed to unlock the encrypted partitions. If the user does not enter a passphrase, and later attempts to edit a previously encrypted partition under the Create custom layout partitioning option, the installer will fail with a message, IndexError: list index out of range. To work around this issue, users are advised to enter a passphrase when prompted for any previously encrypted disk partitions. If the passphrase is not known, you are advised to let the installer partition your disks using the Use entire drive option, or edit any previously encrypted disk partitions by hand prior to installation.

Kickstart installations cannot reuse existing RAID arrays

link to this item - Bugzilla: #503310

Kickstart installations which attempt to reuse existing RAID arrays (raid --useexisting) will fail with an error that the array name is not recognized. Anaconda does recognize (and can use) the RAID autostart partitions, but cannot reuse their assembly in any existing arrays. Semi-automatic kickstart installations with manual layout also exhibit the issue.

To work around the issue, you must either rebuild the array, losing all existing data in the array, or perform the installation without kickstart. Fully manual installations do not exhibit the issue. The inability to reuse existing arrays is limited to kickstart installations only.

Kickstart installations cannot reuse existing LVM volume groups

link to this item - Bugzilla: #503681

Kickstart installations which attempt to reuse existing LVM volume groups (volgroup --useexisting) will fail with an error that the volume group name is not recognized. Anaconda does recognize (and can use) LVM physical volume partitions, but cannot reuse their membership in any existing volume groups. Semi-automatic kickstart installations with manual layout also exhibit the issue.

To work around the issue, you must either recreate the group, losing all its existing logical volumes and the data they contain, or perform the installation without kickstart. Fully manual installations do not exhibit the issue. The inability to reuse existing volume groups is limited to kickstart installations only.

Kickstart installations fail when using partition options --ondisk or --biosdisk

link to this item - Bugzilla: #504687

Kickstart installations which use either the --ondisk or --biosdisk options to the part kickstart command will not work. A workaround for Fedora 11 is to avoid using either kickstart options. If use of the options --ondisk or --biosdisk is required, an updates.img is available to work around the defect. For additional information on using an updates.img with the installer, see Anaconda/Updates.

Installer sees no hard drives on ppc970 systems

link to this item - Bugzilla: #504040

There is a problem with yaboot on ppc970-based systems which causes the installer to be unable to find the system's hard drives. This prevents installation or upgrade from working.

There is a fix for yaboot, but the fixed package is not present on the Fedora 11 media. Once a fixed package is available for Fedora 10 you should be able to preupgrade from Fedora 10 to Fedora 11.

Installation fails with LVMError: lvcreate failed for vg_gx2701/lv_root

link to this item - Bugzilla: #496760

There is a problem while creating logical volumes during installation. The steps to reproduce this failure were originally verified prior to release of Fedora 11. Since the release, it appears there may be new failure vectors for this same issue. If you are experiencing this failure, you will need to reboot your system and retry the installation. Root cause for this issue is being investigated.

Hardware-related issues

General note about updating system BIOS and device firmware

link to this item

Some bugs can be resolved by updating the system BIOS and the firmware on some devices. Always make sure you have the latest versions applied before reporting a bug. Examples of devices which may have firmware updates available include CD/DVD drives and external storage devices such as firewire drive enclosures.

Miscellaneous problems with Intel graphics adapters

link to this item

Many users are already aware from coverage in the press that significant changes have recently been made to the driver for Intel graphics adapters (and the supporting code in Mesa/DRI and the kernel), and that these have caused some functionality regressions. If you are suffering from problems with an Intel graphics adapter such as failure of X to start at all, hangs or freezes or crashes in the graphical environment, display corruption, failure of 3D accelerated applications to work properly or similar problems, and your issue is not specifically covered elsewhere on this page, the following general advice may be of use.

Several such issues may be worked around by disabling kernel mode setting. To do this, add

nomodeset

as a kernel parameter. If this solves your problem, please check whether a bug has already been reported for it, and if not, file a new bug report on the xorg-x11-drv-intel component, explaining your symptoms, and providing all the usual information required for X.org bug reports. In future kernel mode setting will be the only available method, and so we wish to ensure all problems caused by kernel mode setting are fixed.

If this does not resolve your issue, one other potential workaround is to change to a different acceleration method. To do this, add a line:

Option "AccelMethod" "EXA"

or:

Option "AccelMethod" "XAA"

to the Device section of /etc/X11/xorg.conf. If that file does not exist, see How_to_create_xorg.conf for instructions on how to create it. Again, if doing this works around the problem you are experiencing, please check whether a bug report on the problem has already been filed, and if not, please file a new bug report on the xorg-x11-drv-intel component, explaining your symptoms, and providing all the usual information required for X.org bug reports. These legacy acceleration methods will be removed in future, so any bugs in the new acceleration method (UXA) need to be fixed.

Miscellaneous problems with ATI / AMD graphics adapters

link to this item - Bugzilla: #498457

As with the Intel driver, the Radeon driver for ATI / AMD graphics adapters is going through substantial changes, and it is worth noting some configuration options that may help address various problems with such adapters. If you are experiencing failure to start the graphical desktop, hanging or freezing, corruption, or slow performance with an ATI / AMD graphics adapter, you may try the following.

Some issues may be worked around by disabling kernel mode setting. To do this, add

nomodeset

as a kernel parameter. If this solves your problem, please check whether a bug has already been reported for it, and if not, file a new bug report on the xorg-x11-drv-ati component, explaining your symptoms, and providing all the usual information required for X.org bug reports. In future kernel mode setting will be the only available method, and so we wish to ensure all problems caused by kernel mode setting are fixed.

If this does not resolve your issue, one other potential workaround is to change to a different acceleration method. To do this, add a line:

Option "AccelMethod" "XAA"

to the Device section of /etc/X11/xorg.conf. If that file does not exist, see How_to_create_xorg.conf for instructions on how to create it. Again, if doing this works around the problem you are experiencing, please check whether a bug report on the problem has already been filed, and if not, please file a new bug report on the xorg-x11-drv-ati component, explaining your symptoms, and providing all the usual information required for X.org bug reports. These legacy acceleration methods will be removed in future, so any bugs in the new acceleration method (EXA) need to be fixed.

Finally, if this does not resolve your issue, there is one other configuration option to try. Add a line:

Option "AccelDFS" "off"

to the Device section of /etc/X11/xorg.conf. If that file does not exist, see How_to_create_xorg.conf for instructions on how to create it. Again, if doing this works around the problem you are experiencing, please check whether a bug report on the problem has already been filed, and if not, please file a new bug report on the xorg-x11-drv-ati component, explaining your symptoms, and providing all the usual information required for X.org bug reports.

If still nothing works (e.g., Radeon Xpress 200 seems to be really stubborn, see this bug for illustration), try adding to /etc/X11/xorg.conf this line:

 
Option "DRI" "off"

and of course all previous comments about filing a bug (or more likely, joining one already existing) would be helpful.

Resume from suspend fails with NVIDIA graphics adapters

link to this item - Bugzilla: #459323

Resuming from suspend fails to restore the graphical display when using the nouveau video driver, which is now the default for all NVIDIA video adapters in Fedora 11. Unfortunately, there is no workaround for this problem, and it is not likely to be fixed within the Fedora 11 timeframe. If you have a system with an NVIDIA video adapter on which you need suspend/resume functionality, you must use an alternative driver. The old nv free driver will work for some cards, but for others, only the proprietary nvidia driver will work. To switch to the nv driver, you can use the system-config-display utility - on the Hardware tab, click the Configure... button next to Video Card and select the nv driver from the list.

Graphical desktop failing to start or crashing with AGP NVIDIA graphics cards

link to this item - Bugzilla: #490358, Bugzilla: #487456, Bugzilla: #498579, Bugzilla: #499730

Problems have been reported with several NVIDIA AGP graphics cards, with the new nouveau graphics driver used in Fedora 11. AGP is a tricky case that the driver does not yet handle well for several cards. If you experience failure to start the graphical desktop (X server), or hanging or crashing of the graphical desktop, and you have an NVIDIA-based AGP graphics card, you may want to try the following workaround. Add the kernel parameter nouveau.noagp=1. For many reporters, this resolves the problem.

Some NVIDIA onboard graphics chipsets use AGP, as well as expansion cards that fit in an AGP slot. To check whether your onboard chipset is an AGP one, run this command:

grep -i agp /var/log/Xorg.0.log

if it returns anything, your chip is an AGP one. If not, it isn't.

If you experience a problem of this kind, and your graphics card is not the same model as in any of the existing reports listed above, please file a new bug report on the xorg-x11-drv-nouveau component, explaining your symptoms, and providing all the usual information required for X.org bug reports.

Grey lines appear in Firefox location bar and terminal windows with Intel i845 graphics adapters

link to this item - Bugzilla: #502096

In a default configuration, on systems with Intel i845 graphics adapters, you may notice graphical corruption of the Firefox location bar, GNOME terminal windows, and possibly other applications. The corruption manifests as one pixel tall, dotted light grey lines of varying widths in random locations, appearing and disappearing. Disabling kernel modesetting, using the nomodeset parameter, works around this issue.

Enabling desktop effects causes system hang with Intel i845 graphics adapters

link to this item - Bugzilla: #490005

On systems with Intel i845 graphics chipsets, attempting to enable accelerated desktop effects (Compiz) via the System / Preferences / Desktop Effects menu entry causes the system to hang (in fact, X is stuck, but if you have the appropriate network setup, you should be able to ssh into the affected machine to shut it down in an orderly fashion). There is no known workaround for this issue, therefore we advise not trying to enable desktop effects on this graphics chipset for now.

Corrupted display in Google Earth on Intel i855 graphics adapters

link to this item - Bugzilla: #XXXXXX

In a default configuration, on systems with Intel i855 graphics adapters, Google Earth does not display properly, rendering only a small, empty black rectangle (and hence obviously being useless). Disabling kernel modesetting with the nomodeset kernel parameter may work around this issue.

Screen stays black when returning from idle mode on Thinkpad X41T

link to this item - Bugzilla: #489907

On the Lenovo / IBM Thinkpad X41T model laptop, with default settings, the screen will fail to turn back on once it has gone into power-saving idle mode (either on a timeout, or on closing and re-opening the lid). Disabling kernel modesetting via the nomodeset kernel parameter works around this problem, but may cause other problems to occur instead. Another workaround is to create a file with the following contents:

#!/bin/bash
xrandr --output LVDS1 --off
xrandr --output LVDS1 --auto

Make it executable, and set a shortcut key combination to launch it. Running the script via the shortcut should restore the display. Fedora developers are currently working on a fix for this problem.

Graphical installation / desktop fails to start on Asus Eee Top

link to this item - Bugzilla: #491627

It has been reported that with a default configuration, Fedora 11 fails to initialize the graphical desktop (X server) properly on the Asus Eee Top system. You can work around this issue by downloading this file and installing it as /etc/X11/xorg.conf. With this file in place, the X server should start correctly at the native resolution of the system.

Graphical installation / desktop fails to start on Mac systems with Intel 945 graphics adapter 8086:27A2

link to this item - Bugzilla: #494390

Several users of various Apple Mac systems, including some generations of the Mac Mini and Macbook, which all use an Intel 945 graphics adapter with the PCI ID 8086:27A2, have reported that the graphical installation / desktop (X server) fail to start correctly. Some users report that disabling kernel modesetting, with the kernel parameter nomodeset, works around this issue.

This issue has also been reported as freedesktop.org bug #21710, and was subsequently resolved in kernel 2.6.31 (as the problem is in part of the driver that comes within the kernel). We are investigating the possibility of backporting this patch for a future Fedora 11 kernel update.

Graphical installation / desktop fails to start on Toshiba Portége M100

link to this item - Bugzilla: #500544

It has been reported that starting the graphical environment (either during installation or on boot of an installed system) fails entirely with default configuration on the Toshiba Portége M100 system. To work around this issue, add the nomodeset kernel parameter, which disables kernel modesetting. With this parameter set, things should work fine.

Graphical installation fails to start on ATI / AMD graphics adapters (especially onboard graphics)

link to this item

On some ATI / AMD graphics adapters - especially onboard adapters (IGPs) - graphical installation may fail to work even if you disable kernel modesetting according to the general ATI / AMD instructions above. In this case, try switching to the fallback vesa driver, by adding xdriver=vesa as a kernel parameter for the installer. If this issue affects you, you will likely need to both disable kernel modesetting and switch to the XAA acceleration method, according to the general ATI / AMD instructions above, if you wish to use the native driver on the installed system (you can switch from vesa to the native driver once the installation has completed using the system-config-display tool).

Slow 3D performance on ATI / AMD graphics adapters

link to this item

The use of kernel modesetting is known to have an adverse impact on 3D performance for ATI / AMD graphics adapters. If you notice poor 3D performance (and better 3D performance is more important to you than smooth graphical boot), disabling kernel modesetting should improve this somewhat. To disable kernel modesetting, add nomodeset as a kernel parameter.

Garbage displayed in some 3D games and applications on ATI / AMD graphics adapters

link to this item - external reference

The GL_EXT_framebuffer_object OpenGL extension is not currently implemented by the 3D driver for ATI / AMD adapters in Fedora 11. This will result in garbage rendering in any game or application which uses this extension. This is a known limitation of the current implementation of the driver: it is being worked on by the driver developers and future updates may make this extension available again.

Installer crashes when Xorg is launched due to ACPI

link to this item - Bugzilla: #507715

ACPI problems are known to cause a crash when Xorg is launched by the installer. Using the kernel parameter acpi=off disables ACPI.

PulseAudio-based volume control cannot adjust volume satisfactorily

link to this item - Bugzilla: #497966 (tracker)

Fedora 11 introduces a simplified, PulseAudio-based GNOME volume control applet and Sound Preferences application: see the release notes, section 4.5 Multimedia, for more details on this.

This, and other PA-based volume controls like pavucontrol, rely on PulseAudio to set the volume level. In some cases where the underlying ALSA volumes do not default to sensible values, PulseAudio-based volume control applications cannot properly adjust the volume: for instance, you hear no sound even with the control set to max, or setting the control to its lowest level still results in audible sound.

In these cases, you can use the legacy volume control application installed by default in Fedora 11 to control the underlying ALSA volumes directly. It can be found in the menus under System / Preferences, with the name Advanced Volume Control. If you upgrade from Fedora 10 to Fedora 11, this volume control application may not be installed: install the package Package-x-generic-16.pnggst-mixer to gain access to it.

If you find yourself in this situation, please file a new bug report on the pulseaudio component, according to these instructions, and set it to block the bug AlsaVolume.

Sound Blaster Live! cards (and other emu10k1-based cards) default to digital (S/PDIF) output

link to this item - Bugzilla: #496320

Due to an oversight in the logic for deciding what input/output profile is best, PulseAudio defaults to digital (S/PDIF) output for emu10k1-based sound cards in Fedora 11. This includes many Sound Blaster Live! sound cards, and several others. For many users this will result in the card apparently not working - you will hear nothing when playing back sound. This is because most users use analog rather than digital connections for their speakers or headphones. To switch to analog output, install the pavucontrol package, and run the program (you can run pavucontrol directly, or look in the system menus under Sound & Video for PulseAudio Volume Control). Go to the Configuration tab, and in the drop-down menu for the affected sound card, change to the 'Output Analog Stereo + Input Analog Mono' option. This should cause sound playback to work correctly. The PulseAudio developers are currently working on an update to fix this issue, which should be available shortly after Fedora 11 is released.

Sound Blaster Live! cards (and other emu10k1-based cards) do not work

link to this item - Bugzilla: #502698

Multiple users have reported that emu10k1-based sound cards does not work in Fedora 11. This includes many Sound Blaster Live! sound cards, and several others. When trying to play a sound file, no sound will be heard, and the system logs will record several failure messages from the kernel, similar to this:

ALSA sound/core/pcm_lib.c:166: BUG: stream = 0, pos = 0x2000, buffer size = 0x2000, period size = 0x2000

There is no known workaround for this bug at present. Some users have reported the failure only with S/PDIF output and say analog output is working, but others have reported the same failure in both modes.

Xorg fails to start when using the nvidia kernel module

link to this item - Bugzilla: #489078

Some users have reported that when attempting to use the "nvidia" kernel module (either the official installer or kmod-nvidia*) Xorg will fail to start properly. The end result, Fedora 11 boots to a black screen. Inspection of dmesg may reveal many messages similar to:

$ dmesg | grep vmap
vmap allocation for size 4198400 failed: use vmalloc=<size> to increase size.
vmap allocation for size 4198400 failed: use vmalloc=<size> to increase size.

A workaround is to add an entry to your kernel line in /etc/grub.conf that includes the amount of video memory on your nVidia card, for example for a 128 MB Geforce 8400 GS you would append the following:

vmalloc=128MB

Synaptics touchpad edge scrolling fails to work on Acer Aspire One

link to this item - Bugzilla: #502548

For users installing F11 on an Acer Aspire One laptop there may be a regression in regards to the Synaptics touchpad edge-scrolling feature. There is currently no workaround, however a test RPM is attached to the bugzilla entry which may resolve the issue.

Software issues

Network doesn't connect

link to this item - Bugzilla: #498207

After installation, it might be noticed that programs requiring the network can not connect to the network. If this is the case, the NetworkManager icon may show a red X indicating that the machine is not currently connected. While all networking hardware is correctly wired, and device indicators show the network to be properly connected, a change in default install behaviour means that the network does not immediately connect.

The required procedure from this point is to click the NetworkManager icon, and activate the System eth0 or similar connection. If the red X disappears from the NetworkManager icon, then this was the issue that was stopping the connection from being activated.

However, the above change is only for the current login. To make this change permanent, right click the NetworkManager icon, Edit connections, select the System eth0 or similar, click Edit, provide the root password, check the Connect automatically item at the top of the dialog box, Apply and Close.

Please also see the future release note describing this, and a graphical description of the steps to take to make this setting.

Display goes blank briefly, apparently at random

link to this item - Bugzilla: #501601

Several users have reported that their display will sometimes suddenly go blank for a brief period - a second or two - before coming back. This appears to be related to the GNOME power manager, but the precise cause has yet to be identified. There is no known reliable workaround for this problem, but the bug report contains a test build of a later version of gnome-power-manager which may solve the problem for some users (it definitely does not for others, however). We are working to try and identify the cause of this problem, and find a solution.

Resume from suspend fails, kernel oops notification appears on reboot

link to this item - Bugzilla: #499651

Several users have reported a failure to resume from suspend on various systems. On some systems this happens every time, on others it is quasi-random. When attempting to resume from suspend, the system hangs at a black screen. On rebooting, you are asked to report a kernel oops - ending with [<c040945f>] sysenter_do_call+0x12/0x34 - to the kernel bug tracking system (unless you have this feature disabled).

A workaround for this issue is discussed in the bug report. Create a file /etc/pm/sleep.d/00-cpuspeed.sh with the following contents:

#!/bin/bash
if [ "$1" == "suspend" ]; then
  service cpuspeed stop
  modprobe -r acpi_cpufreq
fi
if [ "$1" == "resume" ]; then
  service cpuspeed start
fi

Make sure it is executable. This should work around the problem on future suspend cycles. We are working to investigate a fix for this issue.

References