From Fedora Project Wiki

Revision as of 23:19, 19 August 2010 by Petersen (talk | contribs) (Network not connected automatically for normal installs)

Release Notes

Read the Fedora 25 release notes for specific information about intentional changes in Fedora 25, and other general information.


My bug is not listed

Not every bug is listed in this page, but Bugzilla should be a comprehensive database of known bugs. This page is a sampling of the bugs most commonly discussed on our mailing lists and forums.

To see if your bug has already been reported, you can search Bugzilla. If it has not yet been reported, we encourage you to do so to help improve Fedora for yourself and others. A guide to Bugs and feature requests has been prepared to assist you.

If you believe an already-reported bug report should be added to this page because it is commonly encountered, you can:

  • Add it yourself, if you have wiki access. Please follow the style and guidelines explained in the comments in the page source.
  • Or, add the CommonBugs keyword to the bug report. Someone from the QA team will then inspect the issue to determine whether the bug should be listed as a common bug. To expedite your request, please add a comment to the bug that includes
    1. a summary of the problem
    2. any known workarounds
    3. an assessment on the impact to Fedora users

For reference, you can query Bugzilla for bugs tagged CommonBugs:

  • CommonBugs? (bugs with CommonBugs keyword, but do not yet have a link to this page)
  • CommonBugs+ (bugs with CommonBugs keyword and contain a link to this page)


Issues when upgrading from previous releases

Installation Issues

System appears to hang with a black screen when installing on systems with ATI/AMD Radeon graphics cards

link to this item - Bugzilla: #596985

Due to a bug in X.org, many testers indicated that, when installing Fedora 14 Alpha using the traditional installer (i.e. installing from the DVD or split CD media, not a live image), the system apparently hangs at a black screen when switching from text to graphical mode early in the installation process. The system is not in fact hung, but the display will remain blank until the system is rebooted. The bug that causes this problem could theoretically manifest with any hardware, depending on the contents of memory, but in practice it appears to occur consistently on many systems with ATI/AMD Radeon graphics cards, and - as far as we are aware - not on other systems.

To work around this issue, when the installer first boots, select the option labelled Install system with basic video driver at the initial boot menu. Now proceed with installation as usual. After installation, your system will still use the 'basic video driver' (vesa), which will lead to sub-optimal performance. If you would prefer to switch to the native driver - which most testers indicated works perfectly well once installation is complete - follow this procedure:

  1. Delete or rename the file /etc/X11/xorg.conf
  2. Remove all occurrences of the word nomodeset from the file /boot/grub/grub.conf
  3. Reboot

Some testers with cards in the Radeon 5xxx series encounter a bug with similar initial symptoms, but which actually affects all ability to use X.org with the native driver, not just the traditional Fedora installer. Installing using the basic video driver option is also a workaround for this case, but you should not revert to the native driver after installation in this case. If you attempt to revert to the native driver and find the system now fails to boot correctly, either reinstall and do not follow the procedure to revert to the native driver after installation, or boot the system with the kernel parameter '3' or in rescue mode, and use the system-config-display tool to select the vesa driver.

Hardware-related Issues

Software Issues

Network not connected automatically for normal installs

link to this item - rhbug:620823

For network installs, the network link does seem to be not configured to connect automatically. It can activated and enabled from the NetworkManager applet.

For media installs this is a known issues from earlier releases: see rhbug:498207.

Live installs seem to be unaffected.