Documentation Monitoring Beat

From FedoraProject

Revision as of 17:13, 5 January 2013 by Volter (Talk | contribs)

Jump to: navigation, search

Zabbix

Zabbix 2.0 introduces a number of changes. Old database schemes must be upgraded, prior to use. All connected nodes and proxies must be updated to version 2.0 as well. External scripts, used by Zabbix server or proxy, should be reviewed.

Additionally, 2.0 packages differ substantially from their 1.8 counterparts:

  • Introduce different system users for agent and server/proxy -- https://support.zabbix.com/browse/ZBX-4916
  • Use Alternatives to switch between database implementations
  • zabbix_sender and zabbix_get are in the base package now
  • SQLite server and web package were dropped, as they never worked
  • Media scripts and external scripts are now expected in sub-directories of the server/proxy user's home directory
  • maintenance.inc.php is now treated as configuration

Please review your configuration settings, as well as ownership and permissions of scripts.

The base package includes detailed instructions in zabbix-fedora.README.

Please refer to: