Features/Blender25

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
(Add addtional package req. blender. More progressive contigency plan.)
(Fix numerous misspellings)
Line 2: Line 2:
  
 
This feature bring blender-2.57 or later on Fedora 16. the aim of the blender 2.5
 
This feature bring blender-2.57 or later on Fedora 16. the aim of the blender 2.5
project is to provide a new release of blender with a new desingned UI. Enhanced tools and animations.
+
project is to provide a new release of blender with a new designed UI. Enhanced tools and animations.
  
 
== Owner ==
 
== Owner ==
Line 9: Line 9:
  
 
== current Status ==
 
== current Status ==
* Targedted Release: [[Release/16/Schedule|Fedora 16]]
+
* Targeted Release: [[Release/16/Schedule|Fedora 16]]
 
* Last Update: 2011-05-17
 
* Last Update: 2011-05-17
 
* Percentage of completion: 30%
 
* Percentage of completion: 30%
Line 17: Line 17:
 
third-party scripts.
 
third-party scripts.
  
Currently existng packages which depend on blender have to migrate to make sure, that they
+
Currently existing packages which depend on blender have to migrate to make sure, that they
 
are works together with this new release.
 
are works together with this new release.
  
 
One packaging related change is the move of the script directory to %{_datadir}/blender/<BLENDERVERSION>/scripts.
 
One packaging related change is the move of the script directory to %{_datadir}/blender/<BLENDERVERSION>/scripts.
Additionaly there is no need for a wrapper which created symlinks in the ~/.blender directory anymore.
+
Additionally there is no need for a wrapper which created symlinks in the ~/.blender directory anymore.
  
  
Line 35: Line 35:
 
* new tools.
 
* new tools.
  
== Depecdencies ==
+
== Dependencies ==
There are two packages wich requires blender:
+
There are two packages which requires blender:
  
 
<pre>
 
<pre>
Line 45: Line 45:
  
  
== Contigency Plan ==
+
== Contingency Plan ==
 
Revert to blender-2.49b. Provide additional blender25 package if possible.
 
Revert to blender-2.49b. Provide additional blender25 package if possible.
  
Line 52: Line 52:
 
migrated to blender-2.57b or above.
 
migrated to blender-2.57b or above.
  
[http://www.blender.org/Development/ Blender Devlopment Page]
+
[http://www.blender.org/Development/ Blender Development Page]
  
 
== Release Notes ==
 
== Release Notes ==
Blender-2.5 provides a new release of blender with a new desingned user Interface and tools which is based on python-3.2.
+
Blender-2.5 provides a new release of blender with a new designed user Interface and tools which is based on python-3.2.
  
 
[[Category:FeatureReadyForWrangler]]
 
[[Category:FeatureReadyForWrangler]]

Revision as of 23:03, 25 May 2011

Contents

Update to Blender 2.5 serires

This feature bring blender-2.57 or later on Fedora 16. the aim of the blender 2.5 project is to provide a new release of blender with a new designed UI. Enhanced tools and animations.

Owner

current Status

  • Targeted Release: Fedora 16
  • Last Update: 2011-05-17
  • Percentage of completion: 30%

Detailed Description

Blender-2.5 provide a new designed UI and tools. It's based on python-3.2 and have a changed ABI for third-party scripts.

Currently existing packages which depend on blender have to migrate to make sure, that they are works together with this new release.

One packaging related change is the move of the script directory to %{_datadir}/blender/<BLENDERVERSION>/scripts. Additionally there is no need for a wrapper which created symlinks in the ~/.blender directory anymore.


Benefit for Fedora

Providing a release of blender which was ported to python-3.2 or above.

How to Test

  • Try out primary blender package
  • Try out addon packages which require blender

User Experience

  • New improved user interface
  • new tools.

Dependencies

There are two packages which requires blender:

LuxRender
YafaRay
yofrankie-bge


Contingency Plan

Revert to blender-2.49b. Provide additional blender25 package if possible.

Documentation

Create a blender249 package which can use for the packages which could not migrated to blender-2.57b or above.

Blender Development Page

Release Notes

Blender-2.5 provides a new release of blender with a new designed user Interface and tools which is based on python-3.2.