From Fedora Project Wiki
(Other packages in the DVD: gimp is done in version 2.6.11-10.fc16)
(Detailed Description: Remove optional TODOs about dependencies on gnome-vfs2 and other deprecated libraries)
Line 54: Line 54:
 
| gnome-power-manager || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=593933 upstream bug 593933]</s>
 
| gnome-power-manager || done || <s>[https://bugzilla.gnome.org/show_bug.cgi?id=593933 upstream bug 593933]</s>
 
|-
 
|-
| gnome-vfs2 || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=698638 Fedora bug 698638]</s><br>
+
| gnome-vfs2 || done || GnomeVFS has been deprecated since 2008, applications should use gvfs instead. Since >100 other packages depend on <code>gnome-vfs2</code>, its HAL support was disabled (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=698638 Fedora bug 698638]</s>), as was recently done also by Debian (<s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599020 Debian bug 599020]</s>), but the [http://lists.fedoraproject.org/pipermail/devel/2011-March/149572.html goal] is to get rid of GnomeVFS too.
GnomeVFS has been deprecated since 2008, applications should use gvfs instead. Packages depending directly on <code>gnome-vfs2</code>:<br>
 
<code>gnome-python2-gnome</code><br>
 
<code>gnome-python2-gnomevfs</code><br>
 
<code>libgnome</code> (required by <code>gnome-python2-bonobo</code>, <code>libbonoboui</code>)<br>
 
<code>libgnomeui</code> (required by <code>gnome-python2-gnome</code>)<br>
 
<br>gnome-python is also deprecated for GNOME3, applications should use PyGObject.
 
<br>[https://bugzilla.gnome.org/show_bug.cgi?id=588321 libbonoboui], [http://live.gnome.org/LibgnomeMustDie libgnome and libgnomeui] are also deprecated for GNOME3.
 
<br><code>at-spi-python</code> is also deprecated, applications should use <code>pyatspi</code>.
 
<br>Since >100 other packages depend on <code>gnome-vfs2</code>, its HAL support was disabled, as was recently done by Debian (<s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599020 Debian bug 599020]</s>), but the [http://lists.fedoraproject.org/pipermail/devel/2011-March/149572.html goal] is to get rid of GnomeVFS too.
 
 
|-
 
|-
 
| gstreamer-plugins-good || done ||
 
| gstreamer-plugins-good || done ||
Line 78: Line 69:
 
|-
 
|-
 
| libmtp || done || <code>libmtp-hal</code> leaf subpackage still requires <code>hal-info</code>
 
| libmtp || done || <code>libmtp-hal</code> leaf subpackage still requires <code>hal-info</code>
|-
 
| orca || optional TODO || Requires <code>gnome-python2-gnome</code>, <code>gnome-python2-bonobo</code> ([https://bugzilla.gnome.org/show_bug.cgi?id=626254 upstream bug 626254]) and <code>at-spi-python</code> ([https://bugzilla.redhat.com/show_bug.cgi?id=617642 Fedora bug 617642])
 
 
|-
 
|-
 
| pm-utils || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=636382 Fedora bug 636382]</s>
 
| pm-utils || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=636382 Fedora bug 636382]</s>
Line 86: Line 75:
 
|-
 
|-
 
| setroubleshoot || done || <s>Requires <code>gnome-python2-gnome</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=678543 Fedora bug 678543]</s>)
 
| setroubleshoot || done || <s>Requires <code>gnome-python2-gnome</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=678543 Fedora bug 678543]</s>)
|-
 
| shotwell || optional TODO || Requires <code>gnome-vfs2</code> (<s>[http://trac.yorba.org/ticket/2987 upstream bug 2987]</s>, [https://bugzilla.redhat.com/show_bug.cgi?id=690563 Fedora bug 690563])
 
 
|-
 
|-
 
| smolt || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=634883 Fedora bug 634883]</s>
 
| smolt || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=634883 Fedora bug 634883]</s>
Line 105: Line 92:
 
| amarok || done || Appears to work fine without <code>libmtp-hal</code> on F15/F16 (which is needed on F14 for some reason)
 
| amarok || done || Appears to work fine without <code>libmtp-hal</code> on F15/F16 (which is needed on F14 for some reason)
 
|-
 
|-
| blueman || optional TODO || Requires <s><code>hal</code></s>, [https://bugzilla.redhat.com/show_bug.cgi?id=561019 Fedora bug 561019], and <code>gnome-python2-gnome</code>
+
| blueman || done || [https://bugzilla.redhat.com/show_bug.cgi?id=561019 Fedora bug 561019]
 
|-
 
|-
 
| eclipse || done || <s>Requires <code>gnome-vfs2</code></s>, <s>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=333759 upstream bug 333759]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=667998 Fedora bug 667998]</s>
 
| eclipse || done || <s>Requires <code>gnome-vfs2</code></s>, <s>[https://bugs.eclipse.org/bugs/show_bug.cgi?id=333759 upstream bug 333759]</s>, <s>[https://bugzilla.redhat.com/show_bug.cgi?id=667998 Fedora bug 667998]</s>
Line 132: Line 119:
 
|-
 
|-
 
| pcsc-lite || done || <s>Requires <code>hal-libs</code></s>, <s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587979 Debian bug 587979]</s>
 
| pcsc-lite || done || <s>Requires <code>hal-libs</code></s>, <s>[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587979 Debian bug 587979]</s>
|-
 
| planner || optional TODO || Requires <code>gnome-vfs2</code> ([http://git.gnome.org/browse/planner/commit/?id=9998b34624472b3f9808ff6e5e97cee41ac7687e done in upstream git]), <code>libgnome</code>, <code>libgnomeui</code> ([https://bugzilla.gnome.org/show_bug.cgi?id=589045 upstream bug 589045]) and <code>libbonoboui</code> (<s>[https://bugzilla.gnome.org/show_bug.cgi?id=349304 upstream bug 349304]</s>)
 
|-
 
| system-config-httpd || optional TODO || Requires <code>gnome-python2-gnome</code>
 
 
|-
 
|-
 
| Thunar || done ||
 
| Thunar || done ||
 
|-
 
|-
 
| thunar-volman || done ||
 
| thunar-volman || done ||
|-
 
| thunderbird || optional TODO || Requires <code>gnome-vfs2</code>
 
 
|-
 
|-
 
| xine-lib || done ||
 
| xine-lib || done ||
Line 154: Line 135:
 
|-
 
|-
 
| camcardsync || TODO || [https://bugzilla.redhat.com/show_bug.cgi?id=698662 Fedora bug 698662]
 
| camcardsync || TODO || [https://bugzilla.redhat.com/show_bug.cgi?id=698662 Fedora bug 698662]
|-
 
| dasher || optional TODO || Requires <code>gnome-vfs2</code> (<s>[https://bugzilla.gnome.org/show_bug.cgi?id=572134 upstream bug 572134]</s>, [https://bugzilla.redhat.com/show_bug.cgi?id=675740 Fedora bug 675740]), <code>libgnome</code>, <code>libgnomeui</code> and <code>libbonoboui</code> ([https://bugzilla.gnome.org/show_bug.cgi?id=571750 upstream bug 571750])
 
|-
 
| dia || optional TODO || Requires <code>gnome-vfs2</code> (<s>[https://bugzilla.gnome.org/show_bug.cgi?id=613133 upstream bug 613133]</s>), <code>libgnome</code>, <code>libgnomeui</code> and <code>libbonoboui</code>
 
 
|-
 
|-
 
| epiphany || done ||
 
| epiphany || done ||
Line 165: Line 142:
 
| gnomad2 || done || <s>Requires <code>hal-libs</code> and <code>libmtp-hal</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=677323 Fedora bug 677323]</s>)
 
| gnomad2 || done || <s>Requires <code>hal-libs</code> and <code>libmtp-hal</code></s> (<s>[https://bugzilla.redhat.com/show_bug.cgi?id=677323 Fedora bug 677323]</s>)
 
|-
 
|-
| gnome-commander || optional TODO || Requires <code>gnome-vfs2-smb</code> ([https://bugzilla.gnome.org/show_bug.cgi?id=589069 upstream bug 589069]), <code>gnome-python2-gnomevfs</code>, <code>libgnome</code> ([https://bugzilla.gnome.org/show_bug.cgi?id=589072 upstream bug 589072]), <code>libgnomeui</code> and <code>libbonoboui</code>
+
| gnome-device-manager || TODO || [https://bugzilla.redhat.com/show_bug.cgi?id=698685 Fedora bug 698685]. Probably dead upstream
|-
 
| gnome-device-manager || TODO || Requires <code>hal-libs</code> ([https://bugzilla.redhat.com/show_bug.cgi?id=698685 Fedora bug 698685]), <code>libgnome</code>, <code>libgnomeui</code> and <code>libbonoboui</code>. Probably dead upstream
 
 
|-
 
|-
 
| gparted || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=586377 Fedora bug 586377]</s>
 
| gparted || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=586377 Fedora bug 586377]</s>
Line 176: Line 151:
 
|-
 
|-
 
| ifuse || done ||
 
| ifuse || done ||
|-
 
| inkscape || optional TODO || Requires <code>gnome-vfs2</code>, [https://bugs.launchpad.net/inkscape/+bug/715215 upstream bug 715215], [https://bugzilla.redhat.com/show_bug.cgi?id=653516 Fedora bug 653516]
 
 
|-
 
|-
 
| libconcord || done ||
 
| libconcord || done ||
Line 200: Line 173:
 
|-
 
|-
 
| pmount || done ||
 
| pmount || done ||
|-
 
| policycoreutils-gui || optional TODO || Requires <code>gnome-python2-gnome</code>
 
 
|-
 
|-
 
| razertool || TODO || Deprecated since Fedora 15, but not yet removed from composes ([https://bugzilla.redhat.com/show_bug.cgi?id=700756 Fedora bug 700756])
 
| razertool || TODO || Deprecated since Fedora 15, but not yet removed from composes ([https://bugzilla.redhat.com/show_bug.cgi?id=700756 Fedora bug 700756])
Line 207: Line 178:
 
| synce-hal || TODO || Needs new package synce-connector ([https://bugzilla.redhat.com/show_bug.cgi?id=678728 Fedora bug 678728])
 
| synce-hal || TODO || Needs new package synce-connector ([https://bugzilla.redhat.com/show_bug.cgi?id=678728 Fedora bug 678728])
 
|-
 
|-
| synce-trayicon || TODO || Requires <code>hal-libs</code>, <code>gnome-vfs2</code>, <code>libgnome</code>, <code>libgnomeui</code> and <code>libbonoboui</code>
+
| synce-trayicon || TODO ||
 
|-
 
|-
 
| thunar-vfs || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=699682 Fedora bug 699682]</s>
 
| thunar-vfs || done || <s>[https://bugzilla.redhat.com/show_bug.cgi?id=699682 Fedora bug 699682]</s>

Revision as of 11:10, 4 May 2011


HAL Removal

Summary

HAL is a behemoth, do-it-all, daemon to access hardware. It is now obsoleted by udisks (né DeviceKit-disks) and upower (né DeviceKit-power), as well as libudev for device discovery.

See also:

GNOME upstream tracker

Ubuntu tracker

Debian tracker

Owner

Current status

  • Targeted release: Fedora 16
  • Last updated: 2011-04-26
  • Percentage of completion: 90%

This feature originally proposed the removal of HAL from the Fedora Desktop spin. This goal has already been accomplished and we are completing the removal from the Fedora DVD. In the meantime, hal package maintainer deprecated it for Fedora 16, and later it was also blocked from composes. So, unless somebody volunteers to maintain it again, this feature will track the complete removal of HAL from the distribution.

Detailed Description

To generate the list of packages still depending on hal in rawhide:

$ repoquery --repofrompath=fedora-rawhide-i386,http://download.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/ --repoid=fedora-rawhide-i386 --qf '%{NAME}' --whatrequires hal hal-devel hal-info hal-libs hal-storage-addon | sort -u

Packages in the Desktop spin

Package name Status Bug reports or discussions
abrt-gui done Requires gnome-python2-gnomevfs (Fedora bug 652423)
cheese done upstream bug 594966
evolution done
evolution-data-server done
gdm done upstream bug 572765, Fedora bug 567432
gnome-power-manager done upstream bug 593933
gnome-vfs2 done GnomeVFS has been deprecated since 2008, applications should use gvfs instead. Since >100 other packages depend on gnome-vfs2, its HAL support was disabled (Fedora bug 698638), as was recently done also by Debian (Debian bug 599020), but the goal is to get rid of GnomeVFS too.
gstreamer-plugins-good done
gvfs done upstream bug 586410
gvfs-obexftp done upstream bug 586411 and upstream bug 511671
hal-info TODO Fedora bug 700446
libfprint done Still requires hal-filesystem
libgpod done
libmtp done libmtp-hal leaf subpackage still requires hal-info
pm-utils done Fedora bug 636382
rhythmbox done Requires hal-libs (Fedora bug 597202) and gnome-vfs2 (upstream bug 604186)
setroubleshoot done Requires gnome-python2-gnome (Fedora bug 678543)
smolt done Fedora bug 634883
system-setup-keyboard done
xorg-x11-server-Xorg done
xulrunner done Requires gnome-vfs2 (upstream bug 494163)

Other packages in the DVD

Package name Status Bug reports or discussions
amarok done Appears to work fine without libmtp-hal on F15/F16 (which is needed on F14 for some reason)
blueman done Fedora bug 561019
eclipse done Requires gnome-vfs2, upstream bug 333759, Fedora bug 667998
exo done Fedora bug 699714
gimp done upstream bug 592364
glade3-libgladeui done Requires gnome-vfs2
gnome-pilot done upstream bug 593936
hplip done upstream bug 401091
k3b done
kdebase-runtime done
kdelibs done
libvirt done
lxsession done upstream bug, Fedora bug 688959
pcmanfm done Fedora bug 698652
pcsc-lite done Requires hal-libs, Debian bug 587979
Thunar done
thunar-volman done
xine-lib done

Other packages outside the DVD

Package name Status Bug reports or discussions
beldi TODO Fedora bug 698656
camcardsync TODO Fedora bug 698662
epiphany done
exaile TODO upstream bug 625209, Fedora bug 698667
gnomad2 done Requires hal-libs and libmtp-hal (Fedora bug 677323)
gnome-device-manager TODO Fedora bug 698685. Probably dead upstream
gparted done Fedora bug 586377
gxine done
halevt TODO Fedora bug 700405
ifuse done
libconcord done
librapi done
libsynce done
matahari done Fedora bug 677367
nut done Fedora bug 698134
odccm TODO Fedora bug 701257
ohm TODO Dead upstream, Fedora bug 698964
olpc-kbdshim TODO Fedora bug 700866
ovirt-server TODO ovirt-server-installer subpackage requires hal (Fedora bug 700455)
oxine TODO Fedora bug 700758
pmount done
razertool TODO Deprecated since Fedora 15, but not yet removed from composes (Fedora bug 700756)
synce-hal TODO Needs new package synce-connector (Fedora bug 678728)
synce-trayicon TODO
thunar-vfs done Fedora bug 699682
xchat-gnome done Requires gnome-vfs2
xfburn done upstream bug 5965, Fedora bug 699692
xfce4-cddrive-plugin TODO
xfce4-power-manager done
xfce4-volstatus-icon done Deprecated since Fedora 15

Benefit to Fedora

Faster boot-up, and removal of obsoleted technology.

Scope

Loads of applications require HAL itself, or libhal. Applications should not rely on HAL, or libhal being available.

How To Test

Need to test:

  • yum remove hal-filesystem hal-libs
  • Check that nothing gets removed because it depends on hal
  • Check that applications that access hardware still work as before

User Experience

  • Faster boot-up
  • Possibly faster applications startup when switching from libhal to libgudev for device enumeration

Dependencies

  • See description

Contingency Plan

  • Undeprecate hal.

Documentation

N/A

Release Notes

  • Fedora now does not ship with the HAL daemon, and libhal by default. If a specific application require libhal to function, please file a bug against it to be ported to the new technology.

Comments and Discussion