Features/Rails 3.2

From FedoraProject

< Features(Difference between revisions)
Jump to: navigation, search
m (Scope)
(Current status)
 
(40 intermediate revisions by 3 users not shown)
Line 11: Line 11:
 
== Current status ==
 
== Current status ==
 
* Targeted release: [[Releases/18 | Fedora 18 ]]  
 
* Targeted release: [[Releases/18 | Fedora 18 ]]  
* Last updated: 2012-6-21
+
* Last updated: 2012-8-13
* Percentage of completion: 0%
+
* Percentage of completion: 100%
  
 
== Detailed Description ==
 
== Detailed Description ==
Line 22: Line 22:
 
== Scope ==
 
== Scope ==
 
* The whole Rails stack has to be updated (8 packages)
 
* The whole Rails stack has to be updated (8 packages)
* Additional 9 Gems will have to be packaged
+
* Additional 10 Gems will have to be packaged
* Circa 15 more packages will need update
+
* Some dependencies of the Rails stack will need update (see below)
 
This update will only affect the RPM-packaged RubyGems with no effect on Ruby itself nor any other languages.
 
This update will only affect the RPM-packaged RubyGems with no effect on Ruby itself nor any other languages.
  
Line 35: Line 35:
 
|rubygem-ref
 
|rubygem-ref
 
|Create
 
|Create
|{{result|fail|vondruch}}
+
|{{result|pass|vondruch}} [https://bugzilla.redhat.com/show_bug.cgi?id=838801 838801]
 
|-
 
|-
 
|rubygem-therubyracer
 
|rubygem-therubyracer
 
|Create
 
|Create
|{{result|fail|bkabrda}}
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=838870 838870]
 
|-
 
|-
 
|rubygem-coffee-script-source
 
|rubygem-coffee-script-source
 
|Create
 
|Create
|{{result|inprogress|fotios}} [https://bugzilla.redhat.com/show_bug.cgi?id=738746 738746]
+
|{{result|pass|vondruch}} [https://bugzilla.redhat.com/show_bug.cgi?id=738746 738746]
 
|-
 
|-
 
|rubygem-execjs
 
|rubygem-execjs
 
|Create
 
|Create
|{{result|inprogress|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=738744 738744]
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=738744 738744]
 
|-
 
|-
 
|rubygem-coffee-script
 
|rubygem-coffee-script
 
|Create
 
|Create
|{{result|inprogress|fotios}} [https://bugzilla.redhat.com/show_bug.cgi?id=738742 738742]
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=738742 738742]
 
|-
 
|-
 
|rubygem-sprockets
 
|rubygem-sprockets
 
|Create
 
|Create
|{{result|fail|bkabrda}}
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=841089 841089]
 +
|-
 +
|rubygem-i18n
 +
|Update to 0.6.0
 +
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=707183 707183]
 +
|-
 +
|rubygem-builder
 +
|Update to 3.0.0
 +
|{{result|pass|vondruch}} [https://bugzilla.redhat.com/show_bug.cgi?id=718973 718973]
 
|-
 
|-
 
|rubygem-activesupport
 
|rubygem-activesupport
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=734746 734746]
 
|-
 
|-
 
|rubygem-activemodel
 
|rubygem-activemodel
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=734743 734743]
 
|-
 
|-
 
|rubygem-activeresource
 
|rubygem-activeresource
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=734745 734745]
 +
|-
 +
|rubygem-arel
 +
|Update to 3.0.2
 +
|{{result|pass|vondruch}} [https://bugzilla.redhat.com/show_bug.cgi?id=701122 701122]
 
|-
 
|-
 
|rubygem-activerecord
 
|rubygem-activerecord
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|vondruch}} [https://bugzilla.redhat.com/show_bug.cgi?id=734744 734744]
 +
|-
 +
|rubygem-erubis
 +
|Update to 2.7.0
 +
|{{result|pass|bkabrda}}
 +
|-
 +
|rubygem-rack-test
 +
|Update to 0.6.1
 +
|{{result|pass|bkabrda}}
 
|-
 
|-
 
|rubygem-actionpack
 
|rubygem-actionpack
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 
|-
 
|-
 
|rubygem-actionmailer
 
|rubygem-actionmailer
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 
|-
 
|-
 
|rubygem-railties
 
|rubygem-railties
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 
|-
 
|-
 
|rubygem-sass-rails
 
|rubygem-sass-rails
 
|Create
 
|Create
|{{result|fail|nobody}}
+
|{{result|pass|vondruch}}
 
|-
 
|-
 
|rubygem-jquery-rails
 
|rubygem-jquery-rails
 
|Create
 
|Create
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 +
|-
 +
|rubygem-uglifier
 +
|Create
 +
|{{result|pass|bkabrda}} [https://bugzilla.redhat.com/show_bug.cgi?id=840422 840422]
 
|-
 
|-
 
|rubygem-coffee-rails
 
|rubygem-coffee-rails
 
|Create
 
|Create
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 
|-
 
|-
 
|rubygem-rails
 
|rubygem-rails
 
|Update to 3.2.x
 
|Update to 3.2.x
|{{result|fail|nobody}}
+
|{{result|pass|bkabrda}}
 
|}
 
|}
  
Line 123: Line 147:
  
 
== Dependencies ==
 
== Dependencies ==
Apart from those mentioned in [[#Scope]], all the packages from the Rails stack are dependencies of other cca 50 packages. These will have to be rebuilt and possibly updated.
+
Apart from those mentioned in [[#Scope]], all the packages that will get updated are dependencies of other cca 40 packages. These will have to be rebuilt and possibly updated.
  
These 22 packages Require at least one package of the Rails stack directly:
+
These 22 packages Require at least one package of the Rails stack directly and should probably be updated, too:
 
<pre>
 
<pre>
 
aeolus-conductor-0:0.10.5-1.fc18.noarch
 
aeolus-conductor-0:0.10.5-1.fc18.noarch
Line 151: Line 175:
 
</pre>
 
</pre>
  
Some other packages might need to be updated to satisfy the dependencies of the new Rails stack, so their depending packages might need to get updated as well. These however will not have such a great impact on other packages.
+
Some other packages will be updated to satisfy the dependencies of the new Rails stack, so their depending packages should be rebuilt (these should however not require update themselves). The packages to rebuild are:
 +
 
 +
<pre>
 +
deltacloud-core-0:0.5.0-3.fc17.rc1.src
 +
rubygem-boxgrinder-build-0:0.10.1-1.fc17.src
 +
rubygem-fog-0:1.1.2-1.fc17.src
 +
rubygem-haml-0:3.1.2-5.fc17.src
 +
rubygem-introspection-0:0.0.2-5.fc17.src
 +
rubygem-rack-protection-0:1.2.0-4.fc17.src
 +
rubygem-rack-ssl-0:1.3.2-4.fc17.src
 +
rubygem-rbvmomi-0:1.2.3-5.fc17.src
 +
rubygem-rsolr-0:1.0.2-3.fc17.src
 +
rubygem-scruffy-0:0.3.0-1.beta1.fc17.src # this seems not to be maintained and requires builder < 3.0.0, so we might need to drop this
 +
rubygem-sinatra-1:1.3.2-8.fc17.src
 +
rubygem-tilt-0:1.3.3-3.fc17.src
 +
</pre>
  
 
== Contingency Plan ==
 
== Contingency Plan ==
Line 169: Line 208:
  
  
[[Category:FeatureReadyForFesco]]
+
[[Category:FeatureAcceptedF18]]
 
<!-- When your feature page is completed and ready for review -->
 
<!-- When your feature page is completed and ready for review -->
 
<!-- remove Category:FeaturePageIncomplete and change it to Category:FeatureReadyForWrangler -->
 
<!-- remove Category:FeaturePageIncomplete and change it to Category:FeatureReadyForWrangler -->
 
<!-- After review, the feature wrangler will move your page to Category:FeatureReadyForFesco... if it still needs more work it will move back to Category:FeaturePageIncomplete-->
 
<!-- After review, the feature wrangler will move your page to Category:FeatureReadyForFesco... if it still needs more work it will move back to Category:FeaturePageIncomplete-->
 
<!-- A pretty picture of the page category usage is at: https://fedoraproject.org/wiki/Features/Policy/Process -->
 
<!-- A pretty picture of the page category usage is at: https://fedoraproject.org/wiki/Features/Policy/Process -->

Latest revision as of 11:47, 13 August 2012

Contents

[edit] Rails 3.2

[edit] Summary

Rails 3.2 is the latest version of Ruby on Rails stack. Fedora 17 still contains Rails 3.0, which are rather old from the Rails community point of view.

[edit] Owner

  • Email: <bkabrda@redhat.com>

[edit] Current status

  • Targeted release: Fedora 18
  • Last updated: 2012-8-13
  • Percentage of completion: 100%

[edit] Detailed Description

The Rails stack is evolving quickly and Fedora needs to keep pace with it. Therefore the whole Rails stack should be updated from 3.0 in Fedora 17 to 3.2 (latest version) in Fedora 18. This will ensure that all the Ruby developers using Fedora have the latest and greatest RPM-packaged Rails.

[edit] Benefit to Fedora

This update will keep Fedora up-to-date and will ensure that the current Rails developers stay with us as they will get support for system-packaged Rails of the latest version. Apart from that, Rails 3.2 also bring improved functionality, speed and security.

[edit] Scope

  • The whole Rails stack has to be updated (8 packages)
  • Additional 10 Gems will have to be packaged
  • Some dependencies of the Rails stack will need update (see below)

This update will only affect the RPM-packaged RubyGems with no effect on Ruby itself nor any other languages.

The packages need to be created/updated approximately in this order:

Package name Task Status
rubygem-ref Create
Pass pass vondruch
838801
rubygem-therubyracer Create
Pass pass bkabrda
838870
rubygem-coffee-script-source Create
Pass pass vondruch
738746
rubygem-execjs Create
Pass pass bkabrda
738744
rubygem-coffee-script Create
Pass pass bkabrda
738742
rubygem-sprockets Create
Pass pass bkabrda
841089
rubygem-i18n Update to 0.6.0
Pass pass bkabrda
707183
rubygem-builder Update to 3.0.0
Pass pass vondruch
718973
rubygem-activesupport Update to 3.2.x
Pass pass bkabrda
734746
rubygem-activemodel Update to 3.2.x
Pass pass bkabrda
734743
rubygem-activeresource Update to 3.2.x
Pass pass bkabrda
734745
rubygem-arel Update to 3.0.2
Pass pass vondruch
701122
rubygem-activerecord Update to 3.2.x
Pass pass vondruch
734744
rubygem-erubis Update to 2.7.0
Pass pass bkabrda
rubygem-rack-test Update to 0.6.1
Pass pass bkabrda
rubygem-actionpack Update to 3.2.x
Pass pass bkabrda
rubygem-actionmailer Update to 3.2.x
Pass pass bkabrda
rubygem-railties Update to 3.2.x
Pass pass bkabrda
rubygem-sass-rails Create
Pass pass vondruch
rubygem-jquery-rails Create
Pass pass bkabrda
rubygem-uglifier Create
Pass pass bkabrda
840422
rubygem-coffee-rails Create
Pass pass bkabrda
rubygem-rails Update to 3.2.x
Pass pass bkabrda

[edit] How To Test

  • No special hardware is needed.
  • To test Rails 3.2 before they actually get into Rawhide, use:
gem install rails
rails new app
cd app && rails s
  • Go to http://127.0.0.1:3000/ and make sure you are running Rails 3.2.x
  • When all packages land in Rawhide, use:
yum install rubygem-{rails,sqlite3}
rails new app
cd app && rails s

[edit] User Experience

Ruby programmers will once again be able to develop using RPM-packaged Rails of the newest version, using all its advantages.

[edit] Dependencies

Apart from those mentioned in #Scope, all the packages that will get updated are dependencies of other cca 40 packages. These will have to be rebuilt and possibly updated.

These 22 packages Require at least one package of the Rails stack directly and should probably be updated, too:

aeolus-conductor-0:0.10.5-1.fc18.noarch
aeolus-configserver-0:0.4.5-1.fc18.noarch
rubygem-acts-as-list-0:0.1.4-3.fc17.noarch
rubygem-aeolus-cli-0:0.5.0-1.fc18.noarch
rubygem-ammeter-0:0.2.2-2.fc17.noarch
rubygem-archivist-0:1.0.5.1-4.fc17.noarch
rubygem-authlogic-0:3.0.3-3.fc17.noarch
rubygem-cucumber-rails-0:1.0.2-9.fc17.noarch
rubygem-declarative_authorization-0:0.5.5-2.fc17.noarch
rubygem-delayed_job-0:3.0.2-1.fc18.noarch
rubygem-factory_girl_rails-0:1.4.0-3.fc17.noarch
rubygem-foreigner-0:1.1.6-1.fc18.noarch
rubygem-formtastic-0:1.2.3-6.fc17.noarch
rubygem-gettext_i18n_rails-0:0.4.0-2.fc17.noarch
rubygem-haml-rails-0:0.3.4-6.fc17.noarch
rubygem-paranoia-0:1.1.0-3.fc18.noarch
rubygem-rails_warden-0:0.5.6-1.fc17.noarch
rubygem-recaptcha-0:0.3.1-3.fc17.noarch
rubygem-rspec-rails-0:2.8.1-2.fc17.noarch
rubygem-rubigen-0:1.5.6-3.fc17.noarch
rubygem-simple-navigation-0:3.5.1-3.fc17.noarch
rubygem-will_paginate-0:3.0.2-3.fc17.noarch

Some other packages will be updated to satisfy the dependencies of the new Rails stack, so their depending packages should be rebuilt (these should however not require update themselves). The packages to rebuild are:

deltacloud-core-0:0.5.0-3.fc17.rc1.src
rubygem-boxgrinder-build-0:0.10.1-1.fc17.src
rubygem-fog-0:1.1.2-1.fc17.src
rubygem-haml-0:3.1.2-5.fc17.src
rubygem-introspection-0:0.0.2-5.fc17.src
rubygem-rack-protection-0:1.2.0-4.fc17.src
rubygem-rack-ssl-0:1.3.2-4.fc17.src
rubygem-rbvmomi-0:1.2.3-5.fc17.src
rubygem-rsolr-0:1.0.2-3.fc17.src
rubygem-scruffy-0:0.3.0-1.beta1.fc17.src # this seems not to be maintained and requires builder < 3.0.0, so we might need to drop this
rubygem-sinatra-1:1.3.2-8.fc17.src
rubygem-tilt-0:1.3.3-3.fc17.src

[edit] Contingency Plan

None needed. Rails stack won't be updated until all its dependencies are in Rawhide. After that, it will be a simple matter of updating the 8 packages (and their dependencies).

[edit] Documentation

[edit] Release Notes

[edit] Comments and Discussion