From Fedora Project Wiki

 
(25 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 +
<big>'''This page is mostly deprecated now except for EPEL: Fedora Haskell now tracks [[Haskell_Stackage_LTS|Stackage LTS]] major versions'''</big>
 +
 
[http://hackage.haskell.org/platform/ Haskell Platform] is the standard distribution of Haskell tools and basic libraries.
 
[http://hackage.haskell.org/platform/ Haskell Platform] is the standard distribution of Haskell tools and basic libraries.
  
 
Fedora's Haskell Platform status is summarized below.
 
Fedora's Haskell Platform status is summarized below.
For more specific details see the [https://admin.fedoraproject.org/community/?package=haskell-platform#package_maintenance Fedora haskell-platform community page].
+
 
 +
For more specific details see also the [https://apps.fedoraproject.org/packages/haskell-platform haskell-platform package page].
 +
 
 +
* See also the [https://www.haskell.org/platform/contents.html Haskell Platform contents page] which lists the package sets.
  
 
== Next releases ==
 
== Next releases ==
* F20 is expected to ship with ghc-7.6.3 and haskell-platform-2013.2
 
** See the [http://trac.haskell.org/haskell-platform/wiki/ReleaseTimetable Haskell Platform release schedule] for details about the next release.
 
  
 
== Current releases ==
 
== Current releases ==
* F19 has ghc-7.4.2 with haskell-platform-2012.4
+
* EPEL7 has ghc-7.6.3 and haskell-platform-2013.2
** The current F19 packages should also work with F18: e.g. <code>sudo yum update --disablerepo="*" --enablerepo=rawhide ghc"*"</code> (with the usual disclaimers).
 
* F18 has ghc-7.4.1 with haskell-platform-2012.2
 
** The current F18 packages should also work with F17: e.g. <code>sudo yum update --nogpgcheck --releasever=18 --disablerepo="*" --enablerepo=fedora ghc"*"</code> (of course the usual disclaimers and warnings apply).
 
* EPEL6 has haskell-platform-2011.4.0.0 and ghc-7.0.4
 
* EPEL5 has ghc-6.12.3
 
  
 
== Former releases ==
 
== Former releases ==
 +
* EPEL6: ghc-7.0.4 and haskell-platform-2011.4
 +
* EPEL5: ghc-7.0.4
 +
* F26 shipped with modified haskell-platform-8.0.2
 +
* F25 has modified haskell-platform-7.10.3
 +
* F24 has haskell-platform-2014.2 (ghc-7.8.4)
 +
* F23 has ghc-7.8.4 and haskell-platform-2014.2.
 +
* F22 has ghc-7.8.4 and haskell-platform-2014.2.
 +
* F21 has ghc-7.6.3 and haskell-platform-2013.2
 +
* F20 has ghc-7.6.3 and haskell-platform-2013.2
 +
* F19 had ghc-7.4.2 and haskell-platform-2012.4
 +
* F18 had ghc-7.4.1 with haskell-platform-2012.2
 +
** The current F18 packages should also work with F17: e.g. <code>sudo yum update --nogpgcheck --releasever=18 --disablerepo="*" --enablerepo=fedora ghc"*"</code> (of course the usual disclaimers and warnings apply).
 
* F17 had haskell-platform-2011.4.0.0 with ghc-7.0.4
 
* F17 had haskell-platform-2011.4.0.0 with ghc-7.0.4
 
* F16 had haskell-platform-2011.2.0.1 with ghc-7.0.4
 
* F16 had haskell-platform-2011.2.0.1 with ghc-7.0.4

Latest revision as of 15:04, 20 February 2021

This page is mostly deprecated now except for EPEL: Fedora Haskell now tracks Stackage LTS major versions

Haskell Platform is the standard distribution of Haskell tools and basic libraries.

Fedora's Haskell Platform status is summarized below.

For more specific details see also the haskell-platform package page.

Next releases

Current releases

  • EPEL7 has ghc-7.6.3 and haskell-platform-2013.2

Former releases

  • EPEL6: ghc-7.0.4 and haskell-platform-2011.4
  • EPEL5: ghc-7.0.4
  • F26 shipped with modified haskell-platform-8.0.2
  • F25 has modified haskell-platform-7.10.3
  • F24 has haskell-platform-2014.2 (ghc-7.8.4)
  • F23 has ghc-7.8.4 and haskell-platform-2014.2.
  • F22 has ghc-7.8.4 and haskell-platform-2014.2.
  • F21 has ghc-7.6.3 and haskell-platform-2013.2
  • F20 has ghc-7.6.3 and haskell-platform-2013.2
  • F19 had ghc-7.4.2 and haskell-platform-2012.4
  • F18 had ghc-7.4.1 with haskell-platform-2012.2
    • The current F18 packages should also work with F17: e.g. sudo yum update --nogpgcheck --releasever=18 --disablerepo="*" --enablerepo=fedora ghc"*" (of course the usual disclaimers and warnings apply).
  • F17 had haskell-platform-2011.4.0.0 with ghc-7.0.4
  • F16 had haskell-platform-2011.2.0.1 with ghc-7.0.4
  • F15 had haskell-platform-2011.2.0.0 with ghc-7.0.2
  • EPEL4 had ghc-6.8.3
  • F14 had haskell-platform-2010.2.0.0 with ghc-6.12.3
  • F13 had haskell-platform-2010.1.0.0 with ghc-6.12.1
  • F12 had haskell-platform-2009.2.0.2 with ghc-6.10.4
  • F11 had haskell-platform-2009.2.0.1 with ghc-6.10.3