Java7 Package Rebuild Status

From FedoraProject

Revision as of 08:31, 28 January 2012 by Akurtakov (Talk | contribs)

Jump to: navigation, search

Contents

This page lists packages that need to be fixed and rebuilt with java-1.7.0-openjdk for F17


There are 2 types of fixes that need to be made in F17. Firstly, packages that fail to build need to be fixed. Secondly, packages that specifically requires java = 1.6 need to be fixed to require java >= 1.6. Affected packages are listed in separate tables below. When you pick a package to work on, please check to see if it exists in the other table too. If it does, both matters can be fixed at once.

List of provenpackagers who can help get your fixes committed and built:

  • Deepak Bhole (dbhole at redhat dot com/IRC: dbhole)


How to edit the tables

  1. When you are ready to taken on a package, edit the table below to add your name in the "Taken by" column
  2. If you want, you can update the status and the color, but please don't set it to green until it is all done and built in Koji. That way a cursory glance would catch anything that needs work.
  3. Once the new package is built in koji, update the status accordingly and change the color to green.


Packages that need to be fixed (see below for issue description)

Package Owner Issue Taken by Status
apache-commons-validator-1.3.1-5.fc16 spike Invalid ASCII chars scop Fixed in 1.3.1-7.fc17
bcel-5.2-9.fc15 arg Invalid ASCII chars scop Fixed in 5.2-10.fc17
cortado-0.6.0-3.fc15 jwrdegoede Invalid ASCII chars New package not built
hibernate-jpa-2.0-api-1.0.1-2.fc17 goldmann Invalid ASCII chars goldmann Fixed in hibernate-jpa-2.0-api-1.0.1-4.fc17
jBCrypt-0.3-4.fc15 sdz Invalid ASCII chars jvanalte New package not built
maven-changelog-plugin-2.2-7.fc16 huwang Invalid ASCII chars New package not built
maven-jflex-plugin-1.4.3-5.fc16 akurtakov Invalid ASCII chars scop Fixed in 1.4.3-7.fc17
metadata-extractor-2.3.1-6.fc15 musuruan Invalid ASCII chars New package not built
MiniCopier-0.5-2.fc15 hicham Invalid ASCII chars New package not built
slf4j-1.6.1-3.fc16 akurtakov Invalid ASCII chars scop Fixed in 1.6.1-4.fc17
xjavadoc-1.1-10.fc15 akurtakov Invalid ASCII chars Deprecated packaga/blocked from rawhide
args4j-2.0.16-4.fc16 jcapik Invalid ASCII chars New package not built
cal10n-0.7.4-6.fc16 akurtakov Invalid ASCII chars New package not built
jakarta-commons-httpclient arg Invalid ASCII chars Fixed in 3.1-7.fc17
maven-scm-1.5-3.fc17 guidograzioli Invalid ASCII chars New package not built
objenesis-1.2-7.fc16 guidograzioli Invalid ASCII chars New package not built
saxon-9.3.0.4-1.fc16 orphan (skip?) Invalid ASCII chars New package not built
avalon-logkit-2.1-6.fc17 orphan Incompatible with new JDBC New package not built
btm-2.1.1-3.fc16 arg Incompatible with new JDBC arg btm-2.1.2-1.fc17
c3p0-0.9.2-0.5.pre1.fc15 mbooth Incompatible with new JDBC dbhole Fixed in c3p0-0.9.2-0.7.pre1.fc17
h2-1.2.147-3.fc16 akurtakov Incompatible with new JDBC dbhole Fixed in h2-1.2.147-5.fc17
hsqldb-1.8.1.3-3.fc15 akurtakov Incompatible with new JDBC dbhole Fixed in hsqldb-1.8.1.3-5.fc17
jakarta-taglibs-standard-1.1.2-1.fc16 fnasser Incompatible with new JDBC dbhole Fixed in jakarta-taglibs-standard-1.1.2-3.fc17
javasqlite-20110827-1.fc17 scop Incompatible with new JDBC dbhole Fixed in javasqlite-20110827-3.fc17
mchange-commons-0.2-0.3.20110130hg.fc15 mbooth Incompatible with new JDBC dbhole Fixed in mchange-commons-0.2-0.5.20110130hg.fc17
mysql-connector-java-5.1.17-1.fc17 mjakubicek Incompatible with new JDBC dbhole Fixed in mysql-connector-java-5.1.17-4.fc17
tomcat-7.0.23-1.fc17 van Incompatible with new JDBC van Fixed in 7.0.25-2.fc17
velocity-1.7-1.fc16 sochotni Incompatible with new JDBC New package not built
libreoffice-3.4.99.1-1.fc17 caolanm Incompatible with new JDBC New package not built
apache-commons-dbcp-1.4-7.fc16 spike Incompatible with new JDBC New package not built
batik-1.7-12.fc16 akurtakov Uses com.sun.image.codec New package not built
jcharts-0.7.5-5.fc15 lotharlutz Uses com.sun.image.codec New package not built
jrefactory-2.9.19-3.fc15 jcapik Uses com.sun.image.codec Deprecated packaga/blocked from rawhide
xmlgraphics-commons-1.4-3 rlandmann Uses com.sun.image.codec New package not built
bouncycastle-1.46-1.fc16 oget -source/-target mismatch New package not built
bouncycastle-mail-1.46-1.fc16 oget -source/-target mismatch New package not built
bouncycastle-tsp-1.46-1.fc16 oget -source/-target mismatch New package not built
easymock2-2.5.2-4.fc15 akurtakov Same type erasure New package not built
jide-oss-2.7.6-4.1340svn.fc15 hicham Same type erasure New package not built
gstreamer-java lfarkas Same type erasure New package not built
plexus-containers-1.5.5-3.fc16 fnasser Needs tools.jar in build/runtime classpath New package not built
scala-2.9.1-2.fc17 geoff Needs tools.jar in build/runtime classpath New package not built
libgda-4.2.11-1.fc17 hguemar Needs update to config file to detect Java 1.7 New package not built
apache-commons-lang-2.6-4.fc16 sochotni Other (test failure) New package not built
junit4-4.8.2-2.fc15 fnasser Other (test failure) Obsolete by junit package and pending removal

Packages that need an update for BuildRequires/Requires

Package Taken by Status
bolzplatz2006 New package not built
db4 New package not built
dbus-java omajid Fixed in 2.7-8.fc17
eclipse-slide New package not built
electric New package not built
freecol New package not built
ice New package not built
intellij-idea New package not built
java-1.5.0-gcj* New package not built
jboss-marshalling New package not built
jing-trang scop Fixed in 20091111-10.fc17
junit4 Obsoleted by junit package
libbluray New package not built
libdb New package not built
libgda New package not built
mapserver New package not built
munin New package not built
mysql-connector-java New package not built
netbeans-platform omajid Fixed in 7.0.1-5.fc17
nyquist New package not built
openvrml New package not built
opticalraytracer New package not built
OSGi-bundle-ant-task New package not built
postgresql-jdbc New package not built
scala New package not built
tetex-tex4ht New package not built
tomcat van Fixed in 7.0.25-2.fc17
tomcat5 New package not built
x11vnc New package not built
* For java-1.5.0-gcj, change to Req. java-openjdk and update %build as needed

Issues descriptions and how to fix them

I have tried my best to categorize packages by issue. If there are any mistakes, feel free to update accordingly.

Issue Explanation How to fix
Invalid ASCII chars Prior to Java 7, unmappable characters in the source were treated as warnings. Java treats them as errors. To fix it, simply build, look at the error locations and patch to replace the unmappable characters with appropriate characters.
Incompatible with new JDBC Java 7 contains a newer version of JDBC. Some of the abstract classes/interfaces in the new version specify new methods. Because the newer API needs additional methods, fixing just involves patching to add those methods (either as stubs, or proper implementations) to the classes. Most (if not all) new methods look like they would just be one-liners.
com.sun.image.codec Java 7 has completely removed support for com.sun.image.codec.* classes (deprecated since Java 1.4). These are probably the most complex of all issues to fix. The first thing is to check if upstream has fixed it and then just backport that fix. If not fixed upstream, patch to use ImageIO instead, as specified here.
-source/-target mismatch The -source argument to javac specifies a newer version than the -target argument. Patch to use the same -source and -target. Only bouncycastle seems to be affected, and for it, -source 1.5 -target 1.5 would be best.
Same type erasure This is a bug in the original code itself. The Java 6 compiler incorrectly accepted bad input. Java 7 does not. The issue is that the code is specifying multiple methods with the same name and one takes an argument type that is the parent type of what the other takes. See this for more explanation. The code needs to be matched to change method names for methods that have the same type erasure. If the method is part of a public api, we need to contact upstream to get it fixed correctly.
Needs tools.jar in build/runtime classpath Java 6 and lower used to provide tools.jar on the classpath by default. Java 7 no longer does it, and as a result, error related to missing classes (that exist in tools.jar) are seen. The package should be patched to supply tools.jar when building, and to ensure that tools.jar is on run-time classpath if it is needed during runtime as well.