Perl/updates

From FedoraProject

< Perl(Difference between revisions)
Jump to: navigation, search
(Created page with '= Updates of perl modules = DRAFT For updates has been developed [http://search.cpan.org/dist/Fedora-App-MaintainerTools/ Fedora::App::MaintainerTools] Usage: <pre> maintainer...')
 
(Updates of perl modules)
Line 1: Line 1:
= Updates of perl modules =
+
= Updates - tips&tricks =
  
 
DRAFT
 
DRAFT
 +
== Updates of Perl core modules ==
 +
Now: update whole perl core package. Creating updates of modules in main perl package is complicated, sometimes almost impossible
 +
because of change in directories/paths inside of the main package.
  
 +
Why we need updated modules: e.g. Module::Build is used for build and installation. New packages need the latest version, which
 +
makes the process of packaging perl modules slower and painful.
 +
 +
How update core modules e.g. Module::Build
 +
# create separated module with cpanspec
 +
# check whether module has Epoch in perl.spec
 +
# add Obsoletes: perl(Module::Build) < version-of-perl-Module-Build-in-perl.spec Without this won't be package updated because every core module requires perl-N-V-R.
 +
# check with rpmdev-vercmp whether version is really higher because of difference in rpm/cpan versions
 +
# review in bz, cvs, build, update
 +
Be carefull with update into older releases of Fedora, because some older packages could have troubles e.g. with new build module.
 
For updates has been developed [http://search.cpan.org/dist/Fedora-App-MaintainerTools/ Fedora::App::MaintainerTools]
 
For updates has been developed [http://search.cpan.org/dist/Fedora-App-MaintainerTools/ Fedora::App::MaintainerTools]
  
 +
== Updates of perl modules ==
 
Usage:
 
Usage:
 
<pre>
 
<pre>
Line 10: Line 24:
 
</pre>
 
</pre>
  
This should help with changes in (Build)Requirements, provides and many more...
+
This should help with changes in (Build)Requirements, provides and many more... This module is still under development and at the moment isn't packaged into Fedora.

Revision as of 12:10, 12 March 2010

Updates - tips&tricks

DRAFT

Updates of Perl core modules

Now: update whole perl core package. Creating updates of modules in main perl package is complicated, sometimes almost impossible because of change in directories/paths inside of the main package.

Why we need updated modules: e.g. Module::Build is used for build and installation. New packages need the latest version, which makes the process of packaging perl modules slower and painful.

How update core modules e.g. Module::Build

  1. create separated module with cpanspec
  2. check whether module has Epoch in perl.spec
  3. add Obsoletes: perl(Module::Build) < version-of-perl-Module-Build-in-perl.spec Without this won't be package updated because every core module requires perl-N-V-R.
  4. check with rpmdev-vercmp whether version is really higher because of difference in rpm/cpan versions
  5. review in bz, cvs, build, update

Be carefull with update into older releases of Fedora, because some older packages could have troubles e.g. with new build module. For updates has been developed Fedora::App::MaintainerTools

Updates of perl modules

Usage:

maintainertool updatespec perl-Something.spec

This should help with changes in (Build)Requirements, provides and many more... This module is still under development and at the moment isn't packaged into Fedora.