Python26

From FedoraProject

(Difference between revisions)
Jump to: navigation, search
m (EPEL5 Packaging Guidelines)
m (Packaging Guidelines EPEL5)
Line 40: Line 40:
 
* python26-psycopg2 - A PostgreSQL database adapter for Python ([https://bugzilla.redhat.com/show_bug.cgi?id=574586 bug 574586])
 
* python26-psycopg2 - A PostgreSQL database adapter for Python ([https://bugzilla.redhat.com/show_bug.cgi?id=574586 bug 574586])
  
== Packaging Guidelines EPEL5 ==
+
== Packaging Guidelines for EPEL5 ==
  
 
This is only a draft at this stage.
 
This is only a draft at this stage.

Revision as of 21:55, 2 March 2011

On EL5, the "system" python binary, /usr/bin/python is Python 2.4, and all add-on python packages are for the 2.4 syntax, and byte-compiled for 2.4.

EPEL5 provides a parallel-installable Python 2.6 stack. The core runtime is in the "python26" package, and there are a number of "python26-*" extension modules already in EPEL5.


Contents

Available Packages for EPEL5

  • python26
  • python26-devel
  • python26-babel
  • python26-dirq
  • python26-distribute - fork of python-setuptools and provides the same functionality.
  • python26-dns
  • python26-gdata
  • python26-greenlet
  • python26-greenlet-devel
  • python26-httplib2
  • python26-imaging
  • python26-imaging-devel
  • python26-imaging-sane
  • python26-imaging-tk
  • python26-inotify
  • python26-libs
  • python26-markupsafe
  • python26-mod_python
  • python26-mod_wsgi
  • python26-nose
  • python26-pbs
  • python26-PyXML
  • python26-simplejson
  • python26-sqlalchemy
  • python26-test
  • python26-tools
  • python26-ZSI


Not Yet Available Packages for EPEL5

  • python26-cheetah - Template engine and code-generator (User:tuju, take src.rpm and maintain if you want.)
  • python26-psycopg2 - A PostgreSQL database adapter for Python (bug 574586)

Packaging Guidelines for EPEL5

This is only a draft at this stage.

--Dmalcolm 20:48, 2 March 2011 (UTC): some python packages are provided as part of the RHEL5 product. Others are add-ons provided as part of EPEL5.

If you want a python26 version of a package that's already in RHEL5, I suggest creating a separate src.rpm, and filing a review request for it.

If you want a python26 version of a package that's in EPEL5, I suggest opening an RFE bug against the existing src.rpm, and attaching a patch to it, adding a new python26-foo subpackage to the build.

TODO:

  • byte-compiling
  • should %{__python26} be defined somewhere? in /etc/rpm/macros.python26 ?

Python26 Bugs in Bugzilla