QA/TestPlans/Networking

From FedoraProject

< QA | TestPlans
Revision as of 01:36, 19 November 2008 by Agent86 (Talk | contribs)

Jump to: navigation, search

Contents

XO Hardware

Status: NOT TESTED

We should check if XO built in wireless adapter (Marvell Libertas 88W8388 controller and 88W8015 radio) works as specified (http://laptop.org/laptop/hardware/specs.shtml).

  • Wireless adapter identified by the system and working properly
  • Status leds work as in speciffications (on = registered, blinking = activity) - (atodorov - PASS)
  • 802.11b/g/s connectivity
  • 802.11s functionality when CPU is powered down (BLOCKED by bug #465284 - can't suspend)

Basic Functionality

Status: NOT TESTED

Testing XO built in wireless adapter to work with standard security protocols/encryption methods.

  • Ability to work with standard protocols and encryption methods:
    • WEP Open/Shared with ASCII/HEX key (atodorov - PR - PASS)
    • WPA/WPA2 with TKIP/AES encryption - need a radius server here...
    • WPA-PSK/WPA2-PSK with TKIP/AES encryption

Advanced Functionality

Status: NOT TESTED

Ability of the XO built in wireless adapter to operate in more advanced modes like AP-bridge or rfmon.

  • Mode Managed / Ad-Hoc / Master (AP)
  • Ability to change output power
  • RAW monitoring mode (rfmon) support

USB network adapters

Status: NOT TESTED

  • Belkin USB 10/100 Ethernet Adapter, model # F5D5050 - works out of the box with NM on Snap#3 and PR (atodorov)
  • ZoWii USB2.0 LAN Adapter - works out of the box with NM on PR (sharkcz)
  • Motorola SURFboard Cable Modem SB5100 - works like a charm with NM and network scripts (rvokal)
  • Ralink RT2501USB wifi dongle - works like a charm on Snap#3 with NM (rvokal)
  • Linksys USB100TX - pegasus driver, works out of the box with NM on Snap#3 (aligas)
  • Linksys USB200M - asix driver, works out of the box with NM on Snap#3 (aligas)
  • D-Link DWL-G122 B1 - rt2500usb driver, works out of the box with NM on Snap#3 (aligas)

Applications

Network Manager

Status: NOT TESTED

  • WPA & WPA2 works with NM from Shapshot 3 (rvokal)
  • WEP works with NM (qark, in progress), (atodorov - snap#3 and PR open system/shared key - PASS )

Networking configuration using Network Manager

  • VPN connection
    • vpnc (Cisco compatible) (qark, in progress), (atodorov - snap#3 and PR - PASS )
    • OpenVPN (qark, in progress)

System Config Network

Status: NOT TESTED

Networking configuration using system-config-network.

Test results

Please file your test results in the table below and link to the test case executed. Thanks!

Test Case Result Bug(s) or more info
QA/TestCases/TestCaseTemplate User:YOUR_NAME_HERE bug_number
QA/TestCases/USB_RJ45_Adapter User:atodorov Belkin USB 10/100 Ethernet Adapter, model # F5D5050
QA/TestCases/USB_RJ45_Adapter User:sharkcz ZoWii USB2.0 LAN Adapter (0b95:7720) manufactured as ZU-80
QA/TestCases/NM_WEP User:atodorov Open system/Shared key w/ password
QA/TestCases/NM_VPN_vpnc User:atodorov
QA/TestCases/NM_VPN_OpenVPN Are we going to test all of certificate/password, etc?
QA/TestCases/NM_Mobile_Broadband User:Jstanley Tested with Sierra Wireless Aircard 595U (Sprint)

AP/Encryption tests

Tested with Preview 1 (fedora-release-9.93-1) and NetworkManager 0.7.0-0.11.svn4229

Test Case/Encryption AP type Bug(s)
Public ESSID Hidden ESSID Ad-hoc
QA/TestCases/NM_WEP NM + WEP 40/128 bit User:rvokal User: lsmid, User:jlaska User:atodorov, User:rvokal See 469835
QA/TestCases/NM_WPA NM + WPA / WPA2 User:lsmid User: lsmid, User:jlaska User:rvokal See 469835
QA/TestCases/NM_Wifi NM + No encryption User:rvokal User:lsmid User:atodorov, User:rvokal
SystemConfigNetworkWifiWEP s-c-network + WEP 64/128 bit User:vgrinco User:vgrinco
SystemConfigNetworkWifiWPA s-c-network + WPA/WPA2
SystemConfigNetworkWifiPlain s-c-network + no encryption User:rvokal User:atodorov, User:rvokal
Anything else?

Color legend

Please use the following format when posting results to this page

Untested
Indicates an inprogress or test that needs further review
Indicates a test that has passed
Indicates a failed test ... see Notes for details

Known issues

  • 469835 - NM doesn't identify wireless devices on the XO - usability issue since the XO has 2 wireless devices, mesh and regular. Waiting on upstream work from OLPC.
  • _djr2 reported on IRC that if you set txpower to 20 via iwconfig it drops back to 10ish after a while. Could be related to some internal hardware power management.
  • on some XOs ifwconfig eth0 reports a bit rate of 1/2 Mb/s. Not sure if bug or not. Sugar also reports the same.