SIGs/KDE/Meetings/2007-11-20

From FedoraProject

< SIGs | KDE | Meetings
Revision as of 20:38, 3 June 2008 by Anubis (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Meeting Time

Important.png
Please notice that the meeting time is now back to an hour earlier

Participants

  • RexDieter
  • KevinKofler
  • ThanNgo
  • SebastianVahl
  • ArthurPemberton (pembo13_com)
  • MaryEllenFoster

Agenda

  • The weekly talk about KDE4
  • Preparations for KDE4: Initial Builds
  • Needed but not yet included BuildRequires (eg. libzip, decibel)
  • Preparations of kdelibs3, kdebase3
  • Planning of inclusion in Rawhide
  • Informations for Package Maintainers (BR: kdelibs -> kdelibs3, building packages for KDE4)

Transcript

Summary

Preparations for KDE4:Initial Builds:

  • The KDE4 Development Platform was updated to 3.96.0
  • SebastianVahl has worked on KDE 4 full desktop packages (KDE 4 as default and kdebase-workspace packaged). This packages doesn't exist in rawhide, yet.
  • New kdeartwork-icons contains crystalsvg-icon-theme. We'll need to verify if it's complete and usuable for KDE3 applications as a fallback. Otherwise we'll need to ship the KDE3 version instead.

Preparations of kdelibs3, kdebase3:

  • Initial version of non-conflicting kdelibs3 is done, version for kdebase3 will be prepared.
  • both versions needs to be re-checked if removed files still really conflict.

Needed but not yet included BuildRequires:

  • libzip (dependency of kdeutils) will be submitted for review
  • decibel (optional dependency for kdenetwork) isn't packaged yet
  • Tapioca-Qt (for decibel) isn't packaged yet
  • tpctl (optional dependency of kdeutils) isn't packaged yet

Planning of inclusion in Rawhide:

  • kdebase-workspace as a new package needs to be reviewed
  • the other packages won't need a formal review
  • kdelibs(4), kdebase(4), kdebase-runtime, kdebase-workspace and kdelibs3, kdebase3 needs to be updated in rawhide in a short timeframe
  • Dec 1-7 was choosen as a window of the inclusion in rawhide
  • We'll need to send out a notice to the mailing lists that KDE may be unstable
  • package maintainers also needs to be informed about the changed build requires
  • RexDieter will prepare this announcements

Comments