SIGs/bigdata/packaging/Hbase

From FedoraProject

< SIGs | bigdata | packaging(Difference between revisions)
Jump to: navigation, search
(Missing Java Dependencies)
Line 6: Line 6:
 
  |+ <div id="deps">Missing/Questionable Dependencies</div>
 
  |+ <div id="deps">Missing/Questionable Dependencies</div>
 
  ! Project !! State !! Review BZ !! Packager !! Notes
 
  ! Project !! State !! Review BZ !! Packager !! Notes
|-
 
| doxia-sink-api
 
| '''<span style="color:darkviolet">Available</span>'''
 
|
 
|
 
|
 
|-
 
| gshell
 
| '''<span style="color:darkviolet">Available</span>'''
 
|
 
|
 
| This is EOLed in Fedora.  Need to find workaround.
 
 
  |-
 
  |-
 
  | high-scale-lib
 
  | high-scale-lib
Line 54: Line 42:
 
  | [[User:gil|gil]]
 
  | [[User:gil|gil]]
 
  |
 
  |
|-
 
| oro
 
| '''<span style="color:darkviolet">Available</span>'''
 
|
 
|
 
|
 
|-
 
| ow2
 
| '''<span style="color:darkviolet">Available</span>'''
 
|
 
|
 
|
 
|-
 
| plastic
 
| '''<span style="color:darkviolet">Available</span>'''
 
|
 
|
 
| Part of jgoodies
 
 
  |}
 
  |}
  

Revision as of 19:56, 23 September 2013

This is a preliminary evaluation by the Big Data SIG of the work required to get Apache Hbase into Fedora. This work has been done based upon the 0.96 branch building against the hadoop 2.0.5-alpha package in Fedora 20.

Contents

Issues To Be Resolved

Missing Java Dependencies

Missing/Questionable Dependencies

Project State Review BZ Packager Notes
high-scale-lib Review RHBZ #865893 gil
htrace, htrace-core, htrace-zipkin Available
jamon-api, javon-java-parent, jamon-maven-plugin, jamon-processor, jamon-runtime Available
jruby-common, jruby-complete Available jruby 1.7.2 is packaged in Fedora, but 1.6.8 is requested by Hbase. gid:aids differ, might need porting.
libthrift Review RHBZ #982285 willb Will Benton has some RPM artifacts at http://freevariable.com/thrift/
metrics-core Review RHBZ #861502 gil

Commons-math Version

HBase wants to use commons-math2. It will need to be ported to the latest version of commons-math.

Commons-logging Version

Need to correct import statements for commons-logging. Should be compile issue only.

Jetty Version

HBase wants to use jetty 6. It will need to be ported to support the latest version of jetty in Fedora.

Tomcat Version

Hbase wants to use tomcat/jasper version 5.x. It will need to be ported to use the latest version of tomcat in Fedora.

Runs As a Webapp

Hbase runs as a webapp with its own configuration of tomcat. This is problematic since the shell scripts needed to run this type of configuration are not currently packaged in the Fedora version of tomcat. The bug bz990588 has been logged to get the tomcat scripts packaged.

It might also be possible to modify the installation of Hbase to run as a webapp within the Fedora tomcat package.