From FedoraProject

< SIGs | bigdata | packaging
Revision as of 15:04, 27 January 2014 by Willb (Talk | contribs)

Jump to: navigation, search


Spark packaging


See Scala packaging for details on Fedora support for the Scala toolchain; briefly, we have version 2.10.3 of Scala in F19, F20, and Rawhide and sbt 0.13.1 is under review in Fedora as well.

There is no official release of Spark that works with Scala 2.10.3 (or SBT 0.13.x), but the 0.9 branch of the upstream Spark repository works with Scala 2.10.

Current Status

With some light Fedora-specific patching, we are able to build and run the Scala 2.10 branch of Spark locally in Fedora against our SBT and Scala. Once SBT is available, other things should follow pretty quickly. Detailed dependency information is below.


Spark requires Scala and SBT in order to build. (Note that there is a Maven build option as well, but it requires artifacts that need to be built with SBT.)

The easiest and most up-to-date place to see the dependency list is in the Spark repository itself, but here we will call out some notable dependencies that aren't already in Fedora:


Project State Review BZ Packager Notes
sbt under review sbt-package BZ willb
lift-json packaging in progress willb
akka awaiting a packager willb (feel free to take this one if you're interested)
Squeryl awaiting a reviewer 1057770 willb dependency of lift
scalaz awaiting a reviewer 1055809 willb dependency of lift-json
metrics available in F20 861502 gil Coda Hale's metrics (Java/Maven build).