From Fedora Project Wiki
(Add note about system dependencies)
(Runtime gems: Update to 6.5)
Line 86: Line 86:
  
 
==Runtime gems==
 
==Runtime gems==
 
 
{| class="wikitable sortable" border="1" style="text-align: center;" cellpadding="10"
 
{| class="wikitable sortable" border="1" style="text-align: center;" cellpadding="10"
|+GitLab gem runtime dependencies
+
|+ GitLab gem runtime dependencies
 
|-
 
|-
 
! scope="col" |Ruby gem
 
! scope="col" |Ruby gem
Line 94: Line 93:
 
! scope="col" class="unsortable" |Fedora (rawhide)
 
! scope="col" class="unsortable" |Fedora (rawhide)
 
! scope="col" class="unsortable" |Upstream (rubygems.org)
 
! scope="col" class="unsortable" |Upstream (rubygems.org)
! scope="col" |GitLab == Upstream
+
! scope="col" |GitLab same as Upstream?
 
|-
 
|-
 
|actionmailer
 
|actionmailer
Line 109: Line 108:
 
|-
 
|-
 
|actionpack-action_caching
 
|actionpack-action_caching
|1.1.0
+
|1.1.1
 
|None
 
|None
|1.1.0
+
|1.1.1
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 145: Line 144:
 
|-
 
|-
 
|acts-as-taggable-on
 
|acts-as-taggable-on
|2.4.1
+
|3.0.1
|2.4.1
+
|3.0.1
|2.4.1
+
|3.0.1
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|arel
 
|arel
|4.0.1
+
|4.0.2
 
|4.0.0
 
|4.0.0
 
|5.0.0
 
|5.0.0
Line 170: Line 169:
 
|axiom-types
 
|axiom-types
 
|0.0.5
 
|0.0.5
|0.0.5
+
|0.1.0
|0.0.5
+
|0.1.0
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|bcrypt-ruby
 
|bcrypt-ruby
Line 181: Line 180:
 
|-
 
|-
 
|bootstrap-sass
 
|bootstrap-sass
 +
|3.1.0.2
 
|2.3.2.2
 
|2.3.2.2
|2.3.2.2
+
|3.1.1.0
|3.0.3.0
 
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 208: Line 207:
 
|0.6.9.4
 
|0.6.9.4
 
|0.6.9.4
 
|0.6.9.4
|<font color="green">'''YES'''</font>
 
|-
 
|chosen-rails
 
|1.0.1
 
|None
 
|1.0.1
 
|<font color="green">'''YES'''</font>
 
|-
 
|chunky_png
 
|1.2.9
 
|1.2.7
 
|1.2.9
 
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 241: Line 228:
 
|-
 
|-
 
|coffee-script-source
 
|coffee-script-source
|1.6.3
+
|1.7.0
 
|1.6.1
 
|1.6.1
|1.6.3
+
|1.7.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 251: Line 238:
 
|1.2
 
|1.2
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
|-
 
|compass
 
|0.12.2
 
|0.12.2
 
|0.12.2
 
|<font color="green">'''YES'''</font>
 
|-
 
|compass-rails
 
|1.1.1
 
|1.0.3
 
|1.1.2
 
|<font color="red">'''NO'''</font>
 
 
|-
 
|-
 
|connection_pool
 
|connection_pool
Line 273: Line 248:
 
|3.1.10
 
|3.1.10
 
|None
 
|None
|3.3.11
+
|3.4.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 304: Line 279:
 
|0.8.0
 
|0.8.0
 
|0.9.0
 
|0.9.0
 +
|<font color="green">'''YES'''</font>
 +
|-
 +
|email_validator
 +
|1.4.0
 +
|None
 +
|1.4.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 313: Line 294:
 
|-
 
|-
 
|equalizer
 
|equalizer
|0.0.8
+
|0.0.9
|0.0.8
+
|0.0.9
|0.0.8
+
|0.0.9
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 327: Line 308:
 
|0.2.4
 
|0.2.4
 
|None
 
|None
|1.0.0
+
|1.0.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 335: Line 316:
 
|1.0.3
 
|1.0.3
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 +
|-
 +
|excon
 +
|0.13.4
 +
|0.25.3
 +
|0.31.0
 +
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|execjs
 
|execjs
Line 343: Line 330:
 
|-
 
|-
 
|faraday
 
|faraday
 +
|0.8.9
 
|0.8.8
 
|0.8.8
|0.8.8
+
|0.9.0
|0.8.8
+
|<font color="red">'''NO'''</font>
|<font color="green">'''YES'''</font>
 
 
|-
 
|-
 
|faraday_middleware
 
|faraday_middleware
Line 353: Line 340:
 
|0.9.0
 
|0.9.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 +
|-
 +
|fog
 +
|1.3.1
 +
|1.15.0
 +
|1.20.0
 +
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|font-awesome-rails
 
|font-awesome-rails
 
|3.2.1.3
 
|3.2.1.3
 
|None
 
|None
|4.0.3.0
+
|4.0.3.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 366: Line 359:
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
|fssm
+
|formatador
|0.2.10
+
|0.2.4
|0.2.7
+
|0.2.4
|0.2.10
+
|0.2.4
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 381: Line 374:
 
|0.5.5
 
|0.5.5
 
|None
 
|None
|0.6.3
+
|0.6.4
|<font color="red">'''NO'''</font>
 
|-
 
|github-markup
 
|0.7.5
 
|None
 
|1.0.0
 
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 397: Line 384:
 
|-
 
|-
 
|gitlab-gollum-lib
 
|gitlab-gollum-lib
|1.0.2
+
|1.1.0
 
|None
 
|None
|1.0.2
+
|1.1.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 409: Line 396:
 
|-
 
|-
 
|gitlab-grit
 
|gitlab-grit
|2.6.3
+
|2.6.4
 
|None
 
|None
|2.6.3
+
|2.6.4
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|gitlab-linguist
 
|gitlab-linguist
|2.9.6
+
|3.0.0
 
|None
 
|None
|2.9.6
+
|3.0.0
|<font color="green">'''YES'''</font>
 
|-
 
|gitlab-pygments.rb
 
|0.5.4
 
|None
 
|0.5.4
 
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|gitlab_git
 
|gitlab_git
|4.0.0.pre
+
|5.3.0
 
|None
 
|None
|3.1.0
+
|5.4.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 439: Line 420:
 
|-
 
|-
 
|gitlab_omniauth-ldap
 
|gitlab_omniauth-ldap
|1.0.3
+
|1.0.4
 
|None
 
|None
|1.0.3
+
|1.0.4
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 +
|-
 +
|gon
 +
|5.0.1
 +
|None
 +
|5.0.4
 +
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|grape
 
|grape
Line 453: Line 440:
 
|0.3.0
 
|0.3.0
 
|None
 
|None
|0.3.0
+
|0.4.1
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|haml
 
|haml
|4.0.4
+
|4.0.5
|3.1.7
+
|4.0.5
|4.0.4
+
|4.0.5
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|haml-rails
 
|haml-rails
|0.5.1
+
|0.5.3
 
|0.4
 
|0.4
|0.5.2
+
|0.5.3
|<font color="red">'''NO'''</font>
+
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|hashie
 
|hashie
 +
|1.2.0
 
|2.0.5
 
|2.0.5
 
|2.0.5
 
|2.0.5
|2.0.5
+
|<font color="red">'''NO'''</font>
|<font color="green">'''YES'''</font>
 
 
|-
 
|-
 
|hike
 
|hike
Line 481: Line 468:
 
|-
 
|-
 
|hipchat
 
|hipchat
|0.9.0
 
|0.14.0
 
 
|0.14.0
 
|0.14.0
 +
|1.0.1
 +
|1.0.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 493: Line 480:
 
|-
 
|-
 
|httparty
 
|httparty
|0.12.0
+
|0.11.0
 
|0.10.2
 
|0.10.2
|0.12.0
+
|0.13.0
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|httpauth
 
|httpauth
|0.2.0
+
|0.2.1
 
|None
 
|None
|0.2.0
+
|0.2.1
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 511: Line 498:
 
|-
 
|-
 
|ice_nine
 
|ice_nine
|0.10.0
+
|0.11.0
|0.10.0
+
|0.11.0
|0.10.0
+
|0.11.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 519: Line 506:
 
|0.3.3
 
|0.3.3
 
|None
 
|None
|0.4.1
+
|0.4.5
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 525: Line 512:
 
|2.1.3
 
|2.1.3
 
|3.0.4
 
|3.0.4
|3.0.4
+
|3.1.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 531: Line 518:
 
|2.0.1
 
|2.0.1
 
|None
 
|None
|2.0.1
+
|2.0.2
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|jquery-ui-rails
 
|jquery-ui-rails
Line 539: Line 526:
 
|4.1.1
 
|4.1.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
|-
 
|json
 
|1.8.1
 
|1.7.7
 
|1.8.1
 
|<font color="green">'''YES'''</font>
 
 
|-
 
|-
 
|jwt
 
|jwt
|0.1.8
+
|0.1.11
 
|None
 
|None
|0.1.8
+
|0.1.11
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|kaminari
 
|kaminari
|0.14.1
+
|0.15.1
 
|None
 
|None
|0.15.0
+
|0.15.1
|<font color="red">'''NO'''</font>
+
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|kgio
 
|kgio
|2.8.1
+
|2.9.1
 
|2.8.0
 
|2.8.0
|2.8.1
+
|2.9.2
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
|-
 
|libv8
 
|3.16.14.3
 
|None
 
|3.16.14.3
 
|<font color="green">'''YES'''</font>
 
 
|-
 
|-
 
|mail
 
|mail
Line 579: Line 554:
 
|1.25.1
 
|1.25.1
 
|1.19
 
|1.19
|2.0
+
|2.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 585: Line 560:
 
|4.7.5
 
|4.7.5
 
|4.7.0
 
|4.7.0
|5.2.0
+
|5.2.3
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 595: Line 570:
 
|-
 
|-
 
|multi_json
 
|multi_json
|1.8.2
+
|1.8.4
|1.7.7
+
|1.8.4
|1.8.2
+
|1.8.4
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 609: Line 584:
 
|1.2.0
 
|1.2.0
 
|1.2.0
 
|1.2.0
|1.2.0
+
|2.0.0
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|mysql2
 
|mysql2
|0.3.11
+
|0.3.15
|0.3.13
+
|0.3.15
|0.3.14
+
|0.3.15
|<font color="red">'''NO'''</font>
+
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|net-ldap
 
|net-ldap
Line 622: Line 597:
 
|0.3.1
 
|0.3.1
 
|0.3.1
 
|0.3.1
 +
|<font color="green">'''YES'''</font>
 +
|-
 +
|net-scp
 +
|1.0.4
 +
|1.1.0
 +
|1.1.2
 +
|<font color="red">'''NO'''</font>
 +
|-
 +
|net-ssh
 +
|2.8.0
 +
|2.6.6
 +
|2.8.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|nokogiri
 
|nokogiri
|1.5.10
+
|1.5.11
|1.6.0
+
|1.6.1
 
|1.6.1
 
|1.6.1
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
Line 639: Line 626:
 
|0.8.1
 
|0.8.1
 
|None
 
|None
|0.9.2
+
|0.9.3
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 645: Line 632:
 
|1.1.4
 
|1.1.4
 
|1.1.4
 
|1.1.4
|1.1.4
+
|1.2.1
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|omniauth-github
 
|omniauth-github
Line 655: Line 642:
 
|-
 
|-
 
|omniauth-google-oauth2
 
|omniauth-google-oauth2
|0.2.1
+
|0.2.2
 
|None
 
|None
|0.2.1
+
|0.2.2
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 669: Line 656:
 
|1.1.1
 
|1.1.1
 
|None
 
|None
|1.1.1
+
|1.1.2
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|omniauth-twitter
 
|omniauth-twitter
Line 680: Line 667:
 
|orm_adapter
 
|orm_adapter
 
|0.5.0
 
|0.5.0
|0.4.0
+
|0.5.0
 
|0.5.0
 
|0.5.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|pg
 
|pg
|0.15.1
+
|0.17.1
 
|0.14.1
 
|0.14.1
|0.17.0
+
|0.17.1
|<font color="red">'''NO'''</font>
+
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|polyglot
 
|polyglot
Line 697: Line 684:
 
|-
 
|-
 
|posix-spawn
 
|posix-spawn
|0.3.6
 
|None
 
 
|0.3.8
 
|0.3.8
|<font color="red">'''NO'''</font>
+
|0.3.8
 +
|0.3.8
 +
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|protected_attributes
 
|protected_attributes
Line 745: Line 732:
 
|-
 
|-
 
|rack-protection
 
|rack-protection
|1.5.1
+
|1.5.2
 
|1.5.0
 
|1.5.0
|1.5.1
+
|1.5.2
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 781: Line 768:
 
|-
 
|-
 
|rake
 
|rake
|10.1.0
+
|10.1.1
 
|10.0.4
 
|10.0.4
|10.1.0
+
|10.1.1
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 795: Line 782:
 
|2.2.2
 
|2.2.2
 
|2.1.1
 
|2.1.1
|3.0.0
+
|3.1.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|redis
 
|redis
|3.0.6
+
|3.0.7
 
|3.0.4
 
|3.0.4
|3.0.6
+
|3.0.7
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 840: Line 827:
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
|ref
+
|ruby-hmac
|1.0.5
+
|0.4.0
|1.0.0
+
|0.4.0
|1.0.5
+
|0.4.0
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 851: Line 838:
 
|0.4.0
 
|0.4.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 +
|-
 +
|rugged
 +
|0.19.0
 +
|0.19.0
 +
|0.19.0
 +
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|sanitize
 
|sanitize
 
|2.0.6
 
|2.0.6
|2.0.6
+
|2.1.0
|2.0.6
+
|2.1.0
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|sass
 
|sass
|3.2.12
+
|3.2.14
|3.2.6
+
|3.2.14
|3.2.12
+
|3.2.14
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 889: Line 882:
 
|-
 
|-
 
|sidekiq
 
|sidekiq
|2.17.0
+
|2.17.4
 
|None
 
|None
|2.17.0
+
|2.17.4
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 945: Line 938:
 
|1.5.1
 
|1.5.1
 
|None
 
|None
|2.1.2
+
|2.2.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 952: Line 945:
 
|0.6.3
 
|0.6.3
 
|0.6.7
 
|0.6.7
|<font color="green">'''YES'''</font>
 
|-
 
|therubyracer
 
|0.12.0
 
|0.11.0
 
|0.12.0
 
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 981: Line 968:
 
|1.1.0
 
|1.1.0
 
|1.1.0
 
|1.1.0
|1.1.0
+
|2.0.0
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|tinder
 
|tinder
|1.9.3
+
|1.9.2
 
|None
 
|None
 
|1.9.3
 
|1.9.3
|<font color="green">'''YES'''</font>
+
|<font color="red">'''NO'''</font>
 
|-
 
|-
 
|treetop
 
|treetop
Line 997: Line 984:
 
|-
 
|-
 
|turbolinks
 
|turbolinks
|2.0.0
+
|2.2.1
 
|1.1.1
 
|1.1.1
|2.0.0
+
|2.2.1
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|-
 
|-
Line 1,015: Line 1,002:
 
|-
 
|-
 
|uglifier
 
|uglifier
|2.3.2
+
|2.2.1
 
|2.3.0
 
|2.3.0
|2.3.3
+
|2.4.0
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 
|-
 
|-
Line 1,029: Line 1,016:
 
|4.6.3
 
|4.6.3
 
|None
 
|None
|4.7.0
+
|4.8.2
 
|<font color="red">'''NO'''</font>
 
|<font color="red">'''NO'''</font>
 +
|-
 +
|unicorn-worker-killer
 +
|0.4.2
 +
|None
 +
|0.4.2
 +
|<font color="green">'''YES'''</font>
 
|-
 
|-
 
|virtus
 
|virtus
Line 1,042: Line 1,035:
 
|1.2.1
 
|1.2.1
 
|1.2.3
 
|1.2.3
|<font color="green">'''YES'''</font>
 
|-
 
|yajl-ruby
 
|1.1.0
 
|None
 
|1.1.0
 
 
|<font color="green">'''YES'''</font>
 
|<font color="green">'''YES'''</font>
 
|}
 
|}

Revision as of 16:51, 15 February 2014

GitLab for Fedora

An effort to package GitLab for Fedora.

System dependencies

Note.png
Do you need all these packages?
Most of these packages are needed if you compile ruby from sources, or install/build gems with native extensions.

The equivalent of Debian's build-essential is:

# yum groupinstall 'Development Tools' 'Development Libraries'

The rest of the packages can be installed with:

# yum install zlib-devel libyaml-devel openssl-devel gdbm-devel readline-devel ncurses-devel libffi-devel curl git openssh-server redis libxml2-devel libxslt-devel libcurl-devel libicu-devel python

Below is the table for an easy reference.

GitLab system dependencies
Debian Fedora 19
sudo sudo
zlib1g-dev zlib-devel
libyaml-dev libyaml-devel
libssl-dev openssl-devel
libgdbm-dev gdbm-devel
libreadline-dev readline-devel
libncurses5-dev ncurses-devel
libffi-dev libffi-devel
curl curl
git-core git
openssh-server openssh-server
redis-server redis
postfix postfix
checkinstall
Fail fail
libxml2-dev libxml2-devel
libxslt-dev libxslt-devel
libcurl4-openssl-dev libcurl-devel
libicu-dev libicu-devel
python python

Runtime gems

GitLab gem runtime dependencies
Ruby gem GitLab (Gemfile) Fedora (rawhide) Upstream (rubygems.org) GitLab same as Upstream?
actionmailer 4.0.2 4.0.2 4.0.2 YES
actionpack 4.0.2 4.0.2 4.0.2 YES
actionpack-action_caching 1.1.1 None 1.1.1 YES
actionpack-page_caching 1.0.2 None 1.0.2 YES
activemodel 4.0.2 4.0.2 4.0.2 YES
activerecord 4.0.2 4.0.2 4.0.2 YES
activerecord-deprecated_finders 1.0.3 1.0.3 1.0.3 YES
activesupport 4.0.2 4.0.2 4.0.2 YES
acts-as-taggable-on 3.0.1 3.0.1 3.0.1 YES
arel 4.0.2 4.0.0 5.0.0 NO
asciidoctor 0.1.4 0.1.3 0.1.4 YES
atomic 1.1.14 1.1.9 1.1.14 YES
axiom-types 0.0.5 0.1.0 0.1.0 NO
bcrypt-ruby 3.1.2 3.1.2 3.1.2 YES
bootstrap-sass 3.1.0.2 2.3.2.2 3.1.1.0 NO
builder 3.1.4 3.1.4 3.2.2 NO
carrierwave 0.9.0 None 0.9.0 YES
celluloid 0.15.2 None 0.15.2 YES
charlock_holmes 0.6.9.4 0.6.9.4 0.6.9.4 YES
coercible 1.0.0 1.0.0 1.0.0 YES
coffee-rails 4.0.1 4.0.0 4.0.1 YES
coffee-script 2.2.0 2.2.0 2.2.0 YES
coffee-script-source 1.7.0 1.6.1 1.7.0 YES
colored 1.2 1.2 1.2 YES
connection_pool 1.2.0 None 1.2.0 YES
d3_rails 3.1.10 None 3.4.1 NO
descendants_tracker 0.0.3 0.0.3 0.0.3 YES
devise 3.0.4 None 3.2.2 NO
devise-async 0.8.0 None 0.9.0 NO
diff-lcs 1.2.5 1.1.3 1.2.5 YES
dotenv 0.9.0 0.8.0 0.9.0 YES
email_validator 1.4.0 None 1.4.0 YES
enumerize 0.7.0 None 0.7.0 YES
equalizer 0.0.9 0.0.9 0.0.9 YES
erubis 2.7.0 2.7.0 2.7.0 YES
escape_utils 0.2.4 None 1.0.1 NO
eventmachine 1.0.3 1.0.3 1.0.3 YES
excon 0.13.4 0.25.3 0.31.0 NO
execjs 2.0.2 1.4.0 2.0.2 YES
faraday 0.8.9 0.8.8 0.9.0 NO
faraday_middleware 0.9.0 None 0.9.0 YES
fog 1.3.1 1.15.0 1.20.0 NO
font-awesome-rails 3.2.1.3 None 4.0.3.1 NO
foreman 0.63.0 None 0.63.0 YES
formatador 0.2.4 0.2.4 0.2.4 YES
gemoji 1.3.1 None 1.5.0 NO
github-markdown 0.5.5 None 0.6.4 NO
gitlab-flowdock-git-hook 0.4.2.2 None 0.4.2.2 YES
gitlab-gollum-lib 1.1.0 None 1.1.0 YES
gitlab-grack 2.0.0.pre None 1.1.0 NO
gitlab-grit 2.6.4 None 2.6.4 YES
gitlab-linguist 3.0.0 None 3.0.0 YES
gitlab_git 5.3.0 None 5.4.0 NO
gitlab_meta 6.0 None 6.0 YES
gitlab_omniauth-ldap 1.0.4 None 1.0.4 YES
gon 5.0.1 None 5.0.4 NO
grape 0.6.1 None 0.6.1 YES
grape-entity 0.3.0 None 0.4.1 NO
haml 4.0.5 4.0.5 4.0.5 YES
haml-rails 0.5.3 0.4 0.5.3 YES
hashie 1.2.0 2.0.5 2.0.5 NO
hike 1.2.3 1.2.1 1.2.3 YES
hipchat 0.14.0 1.0.1 1.0.1 NO
http_parser.rb 0.5.3 None 0.6.0 NO
httparty 0.11.0 0.10.2 0.13.0 NO
httpauth 0.2.1 None 0.2.1 YES
i18n 0.6.9 0.6.9 0.6.9 YES
ice_nine 0.11.0 0.11.0 0.11.0 YES
jquery-atwho-rails 0.3.3 None 0.4.5 NO
jquery-rails 2.1.3 3.0.4 3.1.0 NO
jquery-turbolinks 2.0.1 None 2.0.2 NO
jquery-ui-rails 2.0.2 None 4.1.1 NO
jwt 0.1.11 None 0.1.11 YES
kaminari 0.15.1 None 0.15.1 YES
kgio 2.9.1 2.8.0 2.9.2 NO
mail 2.5.4 2.5.4 2.5.4 YES
mime-types 1.25.1 1.19 2.1 NO
minitest 4.7.5 4.7.0 5.2.3 NO
modernizr 2.6.2 None 2.6.2 YES
multi_json 1.8.4 1.8.4 1.8.4 YES
multi_xml 0.5.5 0.5.2 0.5.5 YES
multipart-post 1.2.0 1.2.0 2.0.0 NO
mysql2 0.3.15 0.3.15 0.3.15 YES
net-ldap 0.3.1 0.3.1 0.3.1 YES
net-scp 1.0.4 1.1.0 1.1.2 NO
net-ssh 2.8.0 2.6.6 2.8.0 YES
nokogiri 1.5.11 1.6.1 1.6.1 NO
oauth 0.4.7 0.4.7 0.4.7 YES
oauth2 0.8.1 None 0.9.3 NO
omniauth 1.1.4 1.1.4 1.2.1 NO
omniauth-github 1.1.1 None 1.1.1 YES
omniauth-google-oauth2 0.2.2 None 0.2.2 YES
omniauth-oauth 1.0.1 None 1.0.1 YES
omniauth-oauth2 1.1.1 None 1.1.2 NO
omniauth-twitter 1.0.1 None 1.0.1 YES
orm_adapter 0.5.0 0.5.0 0.5.0 YES
pg 0.17.1 0.14.1 0.17.1 YES
polyglot 0.3.3 0.3.3 0.3.3 YES
posix-spawn 0.3.8 0.3.8 0.3.8 YES
protected_attributes 1.0.5 1.0.3 1.0.5 YES
pyu-ruby-sasl 0.0.3.3 None 0.0.3.3 YES
rack 1.5.2 1.5.2 1.5.2 YES
rack-accept 0.4.5 0.4.3 0.4.5 YES
rack-attack 2.3.0 None 2.3.0 YES
rack-cors 0.2.9 None 0.2.9 YES
rack-mount 0.8.3 0.8.3 0.8.3 YES
rack-protection 1.5.2 1.5.0 1.5.2 YES
rack-test 0.6.2 0.6.2 0.6.2 YES
rails 4.0.2 4.0.2 4.0.2 YES
rails-observers 0.1.2 0.1.2 0.1.2 YES
railties 4.0.2 4.0.2 4.0.2 YES
raindrops 0.12.0 0.10.0 0.12.0 YES
rake 10.1.1 10.0.4 10.1.1 YES
raphael-rails 2.1.2 None 2.1.2 YES
redcarpet 2.2.2 2.1.1 3.1.0 NO
redis 3.0.7 3.0.4 3.0.7 YES
redis-actionpack 4.0.0 None 4.0.0 YES
redis-activesupport 4.0.0 None 4.0.0 YES
redis-namespace 1.4.1 1.4.1 1.4.1 YES
redis-rack 1.5.0 None 1.5.0 YES
redis-rails 4.0.0 None 4.0.0 YES
redis-store 1.1.4 None 1.1.4 YES
ruby-hmac 0.4.0 0.4.0 0.4.0 YES
rubyntlm 0.1.1 None 0.4.0 NO
rugged 0.19.0 0.19.0 0.19.0 YES
sanitize 2.0.6 2.1.0 2.1.0 NO
sass 3.2.14 3.2.14 3.2.14 YES
sass-rails 4.0.1 4.0.0 4.0.1 YES
seed-fu 2.3.0 None 2.3.0 YES
select2-rails 3.5.2 None 3.5.2 YES
settingslogic 2.0.9 None 2.0.9 YES
sidekiq 2.17.4 None 2.17.4 YES
simple_oauth 0.1.9 None 0.2.0 NO
sinatra 1.4.4 1.4.3 1.4.4 YES
six 0.2.0 None 0.2.0 YES
slim 2.0.2 1.3.8 2.0.2 YES
sprockets 2.10.1 2.8.2 2.10.1 YES
sprockets-rails 2.0.1 2.0.0 2.0.1 YES
stamp 0.5.0 None 0.5.0 YES
state_machine 1.2.0 1.1.2 1.2.0 YES
stringex 1.5.1 None 2.2.0 NO
temple 0.6.7 0.6.3 0.6.7 YES
thor 0.18.1 0.18.1 0.18.1 YES
thread_safe 0.1.3 0.1.3 0.1.3 YES
tilt 1.4.1 1.3.7 2.0.0 NO
timers 1.1.0 1.1.0 2.0.0 NO
tinder 1.9.2 None 1.9.3 NO
treetop 1.4.15 1.4.14 1.4.15 YES
turbolinks 2.2.1 1.1.1 2.2.1 YES
twitter-stream 0.1.16 None 0.1.16 YES
tzinfo 0.3.38 0.3.37 1.1.0 NO
uglifier 2.2.1 2.3.0 2.4.0 NO
underscore-rails 1.4.4 None 1.5.2 NO
unicorn 4.6.3 None 4.8.2 NO
unicorn-worker-killer 0.4.2 None 0.4.2 YES
virtus 1.0.1 None 1.0.1 YES
warden 1.2.3 1.2.1 1.2.3 YES

Missing gems

This is the list of the gems to be packaged. These pending review have a link to bugzilla. List of gems pending review

The raw list can be found here.

GitLab missing gems
Ruby gem Bugzilla id Status
actionpack-action_caching - -
actionpack-page_caching - -
carrierwave - -
celluloid - -
chosen-rails 967396 ASSIGNED
connection_pool 967334 ASSIGNED
d3_rails - -
devise - -
devise-async - -
enumerize - -
escape_utils - -
faraday_middleware - -
font-awesome-rails - -
foreman - -
gemoji - -
github-markdown 1026052 ASSIGNED
github-markup - -
gitlab-flowdock-git-hook - -
gitlab-gollum-lib - -
gitlab-grack - -
gitlab-grit - -
gitlab-linguist - -
gitlab-pygments.rb - -
gitlab_git - -
gitlab_meta - -
gitlab_omniauth-ldap - -
grape - -
grape-entity - -
http_parser.rb - -
httpauth - -
jquery-atwho-rails - -
jquery-turbolinks - -
jquery-ui-rails - -
jwt - -
kaminari - -
libv8 - -
modernizr - -
oauth2 - -
omniauth-github - -
omniauth-google-oauth2 - -
omniauth-oauth - -
omniauth-oauth2 - -
omniauth-twitter - -
posix-spawn - -
pyu-ruby-sasl - -
rack-attack - -
rack-cors - -
raphael-rails - -
redis-actionpack - -
redis-activesupport - -
redis-rack - -
redis-rails - -
redis-store - -
rubyntlm - -
seed-fu - -
select2-rails - -
settingslogic - -
sidekiq - -
simple_oauth - -
six - -
stamp - -
stringex - -
tinder - -
twitter-stream - -
underscore-rails - -
unicorn 786636 NEW
virtus 1040180 NEW
yajl-ruby 823351 ASSIGNED

Statistics


Gitlab runtime gems  :  145
Gems in Fedora repos :  389
Common gems          :  70
To be packaged       :  75
Pending review in BZ :  11
When BZ go in repos  :  64


Unofficial repository

Hosted at fedorapeople.org: http://repos.fedorapeople.org/repos/axilleas/gitlab/