From Fedora Project Wiki

Line 1: Line 1:
 
'''''Javi Roman:''''' [https://twitter.com/javiromanrh Twitter] [http://es.linkedin.com/in/javiroman Linkedin] [http://www.viewbug.com/member/javiroman Photography]
 
'''''Javi Roman:''''' [https://twitter.com/javiromanrh Twitter] [http://es.linkedin.com/in/javiroman Linkedin] [http://www.viewbug.com/member/javiroman Photography]
 +
 +
= Fedora Big Data Package Ecosystem =
 +
 +
{| class="wikitable" style="color:black; background-color:#CCFFFF;" cellpadding="10"
 +
! Package !! Bugzilla !! Status
 +
|-
 +
|Apache Hadoop
 +
|<s>{{bz|976049}}</s>
 +
|Package is available in Rawhide and in Fedora 21 as an update
 +
|-
 +
|Apache HBase
 +
|<s>{{bz|1178861}}</s>
 +
|Package is available in Rawhide and in Fedora 21 as an update
 +
|-
 +
|Apache Hive
 +
|No BZ ticket
 +
|No added for revision in Bugzilla
 +
|-
 +
Apache Pig
 +
|No BZ ticket
 +
|aynchbase dependency. No added for revision in Bugzilla
 +
|-
 +
|Apache Zookeeper
 +
|{{bz|1179355}}
 +
|Patched in order to support Fedora Guava version (partial support).
 +
|-
 +
|Apache Oozie
 +
|<s>{{bz|1073017}}</s>
 +
|kite package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
 +
|-
 +
|Apache Ambari
 +
|<s>{{bz|1073014}}</s>
 +
|parquet package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
 +
|-
 +
|maxmind-db-java
 +
|<s>{{bz|1179309}}</s>
 +
|kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
 +
|-
 +
|ua-parser-java
 +
|<s>{{bz|1179342}}</s>
 +
|kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
 +
|-
 +
|elasticsearch
 +
|<s>{{bz|902086}} {{bz|1181564}}</s>
 +
|Package is available in Rawhide and in Fedora 22 as an update
 +
|}
  
 
= Apache Flume package status =
 
= Apache Flume package status =

Revision as of 08:40, 12 May 2015

Javi Roman: Twitter Linkedin Photography

Fedora Big Data Package Ecosystem

Apache Pig
Package Bugzilla Status
Apache Hadoop RHBZ #976049 Package is available in Rawhide and in Fedora 21 as an update
Apache HBase RHBZ #1178861 Package is available in Rawhide and in Fedora 21 as an update
Apache Hive No BZ ticket No added for revision in Bugzilla
No BZ ticket aynchbase dependency. No added for revision in Bugzilla
Apache Zookeeper RHBZ #1179355 Patched in order to support Fedora Guava version (partial support).
Apache Oozie RHBZ #1073017 kite package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
Apache Ambari RHBZ #1073014 parquet package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
maxmind-db-java RHBZ #1179309 kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
ua-parser-java RHBZ #1179342 kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
elasticsearch RHBZ #902086 RHBZ #1181564 Package is available in Rawhide and in Fedora 22 as an update

Apache Flume package status

Package status

The package builds with this assumptions (we are working on this issues)

  • The code is not ready for Thrift v0.9.1 available in Fedora 21, however Flume code can builds using legacy Thrift built-in code available in the upstream Flume TGZ.
  • Disable ElasticSearch Sink
  • Disable Morphline Solr Sink
  • Disable Twitter Source
  • Disable Kite Dataset Sink

Testing the package

git clone https://github.com/fedora-bigdata-rpms/flume-rpm.git
cd flume-rpm
spectool -g flume.spec
rpmbuild -bs --nodeps --define "_sourcedir ." --define "_srcrpmdir ." flume.spec
sudo mock flume-1.5.2-1.fc21.src.rpm

Dependency packages

  • In order to build Flume with full features those are the dependency packages and their status:
Package Bugzilla Status
irclib RHBZ #976049 Package is available in Rawhide and in Fedora 21 as an update
mapdb RHBZ #1178861 Package is available in Rawhide and in Fedora 21 as an update
asynchbase No BZ ticket No added for revision in Bugzilla
suasync No BZ ticket aynchbase dependency. No added for revision in Bugzilla
kite RHBZ #1179355 Patched in order to support Fedora Guava version (partial support).
parquet RHBZ #1073017 kite package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
parquet-format RHBZ #1073014 parquet package dependency. Package is available in Rawhide and was submitted to Fedora 22 and 21 as an update
maxmind-db-java RHBZ #1179309 kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
ua-parser-java RHBZ #1179342 kite package dependency. Package is available in Rawhide and in Fedora 21 as an update
elasticsearch RHBZ #902086 RHBZ #1181564 Package is available in Rawhide and in Fedora 22 as an update

Apache Storm package status

sources

Apache Kafka package status

sources

Apache Tez package status

sources

Apache Crunch package status

sources