User:Ktdreyer/Gitorious

From FedoraProject

< User:Ktdreyer(Difference between revisions)
Jump to: navigation, search
(Dependencies: add more dependencies)
(Dependencies: use icons)
Line 20: Line 20:
  
 
== Dependencies ==
 
== Dependencies ==
 +
 +
* [[File:Test-result-fail.png|alt=Fail|link=]] - The package is missing
 +
* [[File:Test-result-warn.png|alt=Pass|link=]] - The package is present and versions differ from upstream
 +
* [[File:Test-result-pass.png|alt=Pass|link=]] - The package is present and versions match upstream
 +
 
{|
 
{|
 
! Gem !! Upstream Gemfile !! Fedora 17 !! EPEL 6
 
! Gem !! Upstream Gemfile !! Fedora 17 !! EPEL 6
 
|-
 
|-
| rake            || 0.8.7  || 0.9.2.2 || 0.8.7
+
| rake            || 0.8.7  || 0.9.2.2 || {{result|pass}} 0.8.7
 
|-
 
|-
| SystemTimer    || 1.2.3  || (gone from Ruby?) || not in EPEL
+
| SystemTimer    || 1.2.3  || (gone from Ruby?) || {{result|fail}}
 
|-
 
|-
| activesupport  || 2.3.8  || 3.0.11  || not in EPEL
+
| activesupport  || 2.3.8  || 3.0.11  || {{result|fail}}
 
|-
 
|-
| activemessaging || 0.7.1  || (gone from rails?) || not in EPEL
+
| activemessaging || 0.7.1  || (gone from rails?) || {{result|fail}}
 
|-
 
|-
| activerecord    || 2.3.8  || 3.0.11  || not in EPEL
+
| activerecord    || 2.3.8  || 3.0.11  || {{result|fail}}
 
|-
 
|-
| acts-as-taggable-on || 2.0.6 || not in Fedora || not in EPEL
+
| acts-as-taggable-on || 2.0.6 || not in Fedora || {{result|fail}}
 
|-
 
|-
| addressable    || 2.2.6  || 2.2.6   || not in EPEL
+
| addressable    || 2.2.6  || {{result|pass}} 2.2.6 || {{result|fail}}
 
|-
 
|-
| builder        || 3.0.0  || 2.1.2  || not in EPEL
+
| builder        || 3.0.0  || 2.1.2  || {{result|fail}}
 
|-
 
|-
 
| json            || 1.5.4  || 1.6.5  || 1.4.6
 
| json            || 1.5.4  || 1.6.5  || 1.4.6
 
|-
 
|-
| capillary      || 1.0.0  || not in Fedora || not in EPEL
+
| capillary      || 1.0.0  || not in Fedora || {{result|fail}}
 
|-
 
|-
| mime-types      || 1.16  || 1.16   || 1.16
+
| mime-types      || 1.16  || {{result|pass}} 1.16 || {{result|pass}} 1.16
 
|-
 
|-
 
| nokogiri        || 1.5.0  || 1.5.5  || 1.4.3.1
 
| nokogiri        || 1.5.0  || 1.5.5  || 1.4.3.1
Line 51: Line 56:
 
| rack-test      || 0.6.1  || 0.6.0  || 0.5.4
 
| rack-test      || 0.6.1  || 0.6.0  || 0.5.4
 
|-
 
|-
| ffi            || 1.0.9  || 1.0.9   || not in EPEL
+
| ffi            || 1.0.9  || {{result|pass}} 1.0.9 || {{result|fail}}
 
|-
 
|-
| childprocess    || 0.2.1  || 0.2.0  || not in EPEL
+
| childprocess    || 0.2.1  || 0.2.0  || {{result|fail}}
 
|-
 
|-
 
| json_pure      || 1.5.0  || 1.6.3  || 1.6.3
 
| json_pure      || 1.5.0  || 1.6.3  || 1.6.3
 
|-
 
|-
| rubyzip        || 0.9.4  || 0.9.4   || not in EPEL
+
| rubyzip        || 0.9.4  || {{result|pass}} 0.9.4 || {{result|fail}}
 
|-
 
|-
| selenium-webdriver || 2.4.0 || 2.3.2 || not in EPEL
+
| selenium-webdriver || 2.4.0 || 2.3.2 || {{result|fail}}
 
|-
 
|-
| xpath          || 0.1.4  || 0.1.4   || not in EPEL
+
| xpath          || 0.1.4  || {{result|pass}} 0.1.4 || {{result|fail}}
 
|-
 
|-
| capybara        || 1.0.1  || 1.1.2  || not in EPEL
+
| capybara        || 1.0.1  || 1.1.2  || {{result|fail}}
 
|-
 
|-
| chronic        || 0.3.0  || 0.6.6  || not in EPEL
+
| chronic        || 0.3.0  || 0.6.6  || {{result|fail}}
 
|-
 
|-
| cocaine        || 0.2.1  || not in Fedora || not in EPEL
+
| cocaine        || 0.2.1  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
 
| daemons        || 1.1.0  || 1.0.10 || 1.0.10
 
| daemons        || 1.1.0  || 1.0.10 || 1.0.10
Line 73: Line 78:
 
| diff-lcs        || 1.1.2  || 1.1.2  || 1.1.2
 
| diff-lcs        || 1.1.2  || 1.1.2  || 1.1.2
 
|-
 
|-
| gemcutter      || 0.6.1  || 0.3.0  || not in EPEL
+
| gemcutter      || 0.6.1  || 0.3.0  || {{result|fail}}
 
|-
 
|-
| rubyforge      || 2.0.4  || 2.0.4 || not in EPEL
+
| rubyforge      || 2.0.4  || {{result|pass}} 2.0.4 || {{result|fail}}
 
|-
 
|-
| echoe          || 4.3.1  || 4.3.1  || not in EPEL
+
| echoe          || 4.3.1  || 4.3.1  || {{result|fail}}
 
|-
 
|-
| eventmachine    || 0.12.10 || 0.12.10 || 0.12.10
+
| eventmachine    || 0.12.10 || {{result|pass}} 0.12.10 || {{result|pass}} 0.12.10
 
|-
 
|-
| exception_notification || 1.0.20090728 || not in Fedora || not in EPEL
+
| exception_notification || 1.0.20090728 || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| factory_girl    || 1.3.3  || 2.3.2 || not in EPEL
+
| factory_girl    || 1.3.3  || 2.3.2 || {{result|fail}}
 
|-
 
|-
| thor            || 0.14.6 || 0.14.6 || not in EPEL
+
| thor            || 0.14.6 || {{result|pass}} 0.14.6 || {{result|fail}}
 
|-
 
|-
| foreman        || 0.41.0 || not in Fedora || not in EPEL
+
| foreman        || 0.41.0 || not in Fedora || {{result|fail}}
 
|-
 
|-
| geoip          || 0.8.9  || not in Fedora || not in EPEL
+
| geoip          || 0.8.9  || not in Fedora || {{result|fail}}
 
|-
 
|-
| hodel_3000_compliant_logger || 0.1.0 || not in Fedora || not in EPEL
+
| hodel_3000_compliant_logger || 0.1.0 || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| hoe            || 2.8.0  || 2.12.5  || not in EPEL
+
| hoe            || 2.8.0  || 2.12.5  || {{result|fail}}
 
|-
 
|-
 
| launchy        || 2.0.5  || 0.4.0 || 0.3.7
 
| launchy        || 2.0.5  || 0.4.0 || 0.3.7
Line 101: Line 106:
 
| mysql          || 2.8.1  || 2.8.2? || 2.8.2?
 
| mysql          || 2.8.1  || 2.8.2? || 2.8.2?
 
|-
 
|-
| oauth          || 0.4.4  || not in Fedora || not in EPEL
+
| oauth          || 0.4.4  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| paperclip      || 2.4.5  || not in Fedora || not in EPEL
+
| paperclip      || 2.4.5  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| proxymachine    || 1.2.4  || not in Fedora || not in EPEL
+
| proxymachine    || 1.2.4  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| rdiscount      || 1.3.1.1 || not in Fedora || not in EPEL
+
| rdiscount      || 1.3.1.1 || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| redis          || 2.2.0  || not in Fedora || not in EPEL
+
| redis          || 2.2.0  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| redis-namespace || 0.7.0  || not in Fedora || not in EPEL
+
| redis-namespace || 0.7.0  || {{result|fail}} || {{result|fail}}
 
|-
 
|-
| sinatra        || 1.0    || not in Fedora || not in EPEL
+
| sinatra        || 1.0    || {{result|fail}} || {{result|fail}}
 
|}
 
|}

Revision as of 14:59, 3 August 2012

This document outlines the steps to get Gitorious into Fedora and EPEL.

High Level Steps and Issues

  1. Get all Gitorious' dependencies into Fedora.
  2. Get Gitorious into Fedora.
    • Bundled libraries: Gitorious bundles several things, including Rails. Upstream bug for Rails
    • Bundler issues: If we use different Gem versions than upstream, Bundler wants to write to Gemfile and Gemfile.lock. We must patch Gemfile
    • Init scripts: Create equivalent systemd unit files for Fedora & RHEL 7.
    • Ruby version: Upstream master works with Ruby 1.8; verify Ruby 1.9.x compatability. Same for newer rails.

EPEL

  1. Get all Gitorious's dependencies into EPEL.
    • Rails. I don't have experience packaging Rails, and there's been questions about which version to put into EPEL.
    • Various Rubygems must be branched for EPEL.
    • mod_passenger. RHBZ#470696
  2. Get Gitorious into EPEL.
    • Ruby 1.8

Dependencies

  • Fail - The package is missing
  • Pass - The package is present and versions differ from upstream
  • Pass - The package is present and versions match upstream
Gem Upstream Gemfile Fedora 17 EPEL 6
rake 0.8.7 0.9.2.2
Pass pass
0.8.7
SystemTimer 1.2.3 (gone from Ruby?)
Fail fail
activesupport 2.3.8 3.0.11
Fail fail
activemessaging 0.7.1 (gone from rails?)
Fail fail
activerecord 2.3.8 3.0.11
Fail fail
acts-as-taggable-on 2.0.6 not in Fedora
Fail fail
addressable 2.2.6
Pass pass
2.2.6
Fail fail
builder 3.0.0 2.1.2
Fail fail
json 1.5.4 1.6.5 1.4.6
capillary 1.0.0 not in Fedora
Fail fail
mime-types 1.16
Pass pass
1.16
Pass pass
1.16
nokogiri 1.5.0 1.5.5 1.4.3.1
rack 1.0.1 1.4.0 1.1.0
rack-test 0.6.1 0.6.0 0.5.4
ffi 1.0.9
Pass pass
1.0.9
Fail fail
childprocess 0.2.1 0.2.0
Fail fail
json_pure 1.5.0 1.6.3 1.6.3
rubyzip 0.9.4
Pass pass
0.9.4
Fail fail
selenium-webdriver 2.4.0 2.3.2
Fail fail
xpath 0.1.4
Pass pass
0.1.4
Fail fail
capybara 1.0.1 1.1.2
Fail fail
chronic 0.3.0 0.6.6
Fail fail
cocaine 0.2.1
Fail fail
Fail fail
daemons 1.1.0 1.0.10 1.0.10
diff-lcs 1.1.2 1.1.2 1.1.2
gemcutter 0.6.1 0.3.0
Fail fail
rubyforge 2.0.4
Pass pass
2.0.4
Fail fail
echoe 4.3.1 4.3.1
Fail fail
eventmachine 0.12.10
Pass pass
0.12.10
Pass pass
0.12.10
exception_notification 1.0.20090728
Fail fail
Fail fail
factory_girl 1.3.3 2.3.2
Fail fail
thor 0.14.6
Pass pass
0.14.6
Fail fail
foreman 0.41.0 not in Fedora
Fail fail
geoip 0.8.9 not in Fedora
Fail fail
hodel_3000_compliant_logger 0.1.0
Fail fail
Fail fail
hoe 2.8.0 2.12.5
Fail fail
launchy 2.0.5 0.4.0 0.3.7
mocha 0.9.10 0.11.0 0.9.8
mysql 2.8.1 2.8.2? 2.8.2?
oauth 0.4.4
Fail fail
Fail fail
paperclip 2.4.5
Fail fail
Fail fail
proxymachine 1.2.4
Fail fail
Fail fail
rdiscount 1.3.1.1
Fail fail
Fail fail
redis 2.2.0
Fail fail
Fail fail
redis-namespace 0.7.0
Fail fail
Fail fail
sinatra 1.0
Fail fail
Fail fail