User:Salimma/FeatureDocs/Clojure

From FedoraProject

< User:Salimma(Difference between revisions)
Jump to: navigation, search
(Package Leiningen dependencies)
m (Package Leiningen dependencies)
Line 16: Line 16:
 
  | leiningen || clojure-contrib, clucy, lancet, hooke ||  ||  ||  
 
  | leiningen || clojure-contrib, clucy, lancet, hooke ||  ||  ||  
 
  |-   
 
  |-   
  | lancet ||ant, ant-nodeps || https://bugzilla.redhat.com/show_bug.cgi?id=830398 #830398 || ||
+
  | lancet ||ant, ant-nodeps || [https://bugzilla.redhat.com/show_bug.cgi?id=830398 #830398] || ||
 
  |-
 
  |-
 
  |}
 
  |}

Revision as of 06:44, 9 June 2012

Contents

Documentation for the Clojure feature

Fix Clojure packaging to comply with our guidelines

This is almost complete -- will land the changes once Kushal and myself can verify that the change works on RHEL 6 as well

Package Leiningen dependencies

Dependencies
Package Depends on Bugzilla# Koji Bodhi URL
clojure-contrib clojure-maven-plugin #830287
clojure-maven-plugin fest-assert #830278
leiningen clojure-contrib, clucy, lancet, hooke
lancet ant, ant-nodeps #830398

Package Leiningen

Ensure Leiningen is configured to use the system Maven repository

Ensure that the default Leiningen project templates refer to the packaged versions of Clojure libraries

Package Clojure frameworks

Create a packaging guideline for Clojure packages