From Fedora Project Wiki

(→‎Build dependencies: add already packaged build deps)
(add link to npm-generated dependency list)
 
Line 2: Line 2:
  
 
== Required dependencies and their status in Fedora ==
 
== Required dependencies and their status in Fedora ==
 +
 +
List of dependencies on [https://www.npmjs.com/package/web-ext?activeTab=dependencies npm].
  
 
* {{result|fail}} - The package is not in Fedora
 
* {{result|fail}} - The package is not in Fedora

Latest revision as of 23:35, 16 November 2020

This page documents the effort to get web-ext packaged in Fedora.

Required dependencies and their status in Fedora

List of dependencies on npm.

  • Fail fail
    - The package is not in Fedora
  • Inprogress
    pend
    - The package is being prepared
  • Warning warn
    - Package is retired
  • Pass pass
    - The package is present in Fedora

Runtime dependencies

Upstream Fedora package Status
@babel/polyfill N/A
Fail fail
@babel/runtime N/A
Fail fail
@cliqz-oss/firefox-client N/A
Fail fail
@cliqz-oss/node-firefox-connect N/A
Fail fail
@devicefarmer/adbkit N/A
Fail fail
addons-linter N/A
Fail fail
bunyan nodejs-bunyan
Warning warn
camelcase nodejs-camelcase
Pass pass
chrome-launcher N/A
Fail fail
debounce N/A
Fail fail
decamelize nodejs-decamelize
Pass pass
es6-error N/A
Fail fail
event-to-promise N/A
Fail fail
firefox-profile N/A
Fail fail
fs-extra N/A
Fail fail
fx-runner N/A
Fail fail
import-fresh N/A
Fail fail
mkdirp nodejs-mkdirp
Pass pass
multimatch nodejs-multimatch
Warning warn
mz nodejs-mz
Pass pass
node-notifier N/A
Fail fail
open nodejs-open
Pass pass
parse-json N/A
Fail fail
sign-addon N/A
Fail fail
source-map-support nodejs-source-map-support
Warning warn
strip-bom nodejs-strip-bom
Pass pass
strip-json-comments nodejs-strip-json-comments
Pass pass
tmp nodejs-tmp
Warning warn
update-notifier N/A
Fail fail
watchpack N/A
Fail fail
ws nodejs-ws
Pass pass
yargs nodejs-yargs
Pass pass
zip-dir N/A
Fail fail

Build dependencies

Upstream Fedora package Status
@babel/core N/A
Fail fail
@babel/plugin-proposal-class-properties N/A
Fail fail
@babel/plugin-transform-runtime N/A
Fail fail
@babel/preset-env N/A
Fail fail
@babel/preset-flow N/A
Fail fail
@babel/register N/A
Fail fail
@commitlint/cli N/A
Fail fail
@commitlint/config-conventional N/A
Fail fail
babel-eslint N/A
Fail fail
babel-loader N/A
Fail fail
babel-plugin-istanbul N/A
Fail fail
chai nodejs-chai
Warning warn
chai-as-promised nodejs-chai-as-promised
Pass pass
copy-dir N/A
Fail fail
coveralls nodejs-coveralls
Warning warn
cross-env N/A
Fail fail
deepcopy N/A
Fail fail
doctoc N/A
Fail fail
eslint N/A
Fail fail
eslint-plugin-async-await N/A
Fail fail
eslint-plugin-flowtype N/A
Fail fail
eslint-plugin-import N/A
Fail fail
flow-bin N/A
Fail fail
git-rev-sync N/A
Fail fail
html-entities N/A
Fail fail
mocha N/A
Fail fail
nyc N/A
Fail fail
prettyjson N/A
Fail fail
shelljs nodejs-shelljs
Pass pass
sinon nodejs-sinon
Warning warn
webpack N/A
Fail fail
webpack-node-externals N/A
Fail fail
yauzl N/A
Fail fail