Archive:PackagingDrafts/PythonNumpy

From FedoraProject

Jump to: navigation, search

Draft

This is proposed addendum to Packaging/Python

PyGTK2 and Numpy

Note.png
This is a temporary workaround which may be resolved in the future. It will no longer be necessary when [gnome bug #591745] is fixed.

If your package uses pygtk2, and calls the gtk.gdk.get_pixels_array() function, that package needs to explicitly Require: numpy. In the past, pygtk2 had a Requires on numpy, but since it is only used for that one function (and that function is not commonly used), the Requires has been removed to minimize the install footprint of pygtk2.