DebarshiRay/Opyum

From FedoraProject

Jump to: navigation, search

Contents

Opyum

Note.png 0.0.3 released on 27 Oct, 07
It provides system-install-yumpacks for easily installing or updating from Yum-Packs and a repository manager.


Introduction

Opyum is an application designed to enable users, who do not have a good network (eg., Internet) connection at their ready disposal, to easily install new packages or update existing ones through the conventional package management system available in Fedora. It is a GUI utility written in Python based on the existing Pirut interface and modules.

DebarshiRay Opyum opyum-about.png

Features

Right now it does two things:

  • Profile management -- export, import and deletion of profiles.
  • Creating Yum-Packs.
  • Installing and updating from Yum-Packs.

Jargon

Profiles are a representation of a machine's rpmdb usually located at /var/lib/rpm. When we export a profile, we create a Tar archive containing the /var/lib/rpm of our local system. Importing a profile causes us to extract the contents of /var/lib/rpm of the system whose rpmdb had been exported into the archive.

Yum-Packs are a collection of all the packages that the user intends to install and their associated dependencies.

The profile and Yum-Pack are currently represented as non-compressed tarballs.

User Guide

Since most of the looks and behaviour are similar to that in Pirut , we shall only highlight the differences here.

Starting Off

Opyum can be invoked from the binary named 'opyum'.

$ opyum

DebarshiRay Opyum opyum-start.png

At start-up you shall be presented with the Profile Manager dialog. To proceed further you would need to select a profile to work on. You can import a new one if you do not have any. If you wish to use the profile of your local Fedora installation on a foreign machine, you may export your profile.

Idea.png Please note
* An exported profile of the local machine can be imported on it too.
* Make sure that you do not have two similarly named profiles.


The Menus

DebarshiRay Opyum opyum-file.png

DebarshiRay Opyum opyum-edit.png

The 'File' menu provides you with the option to export or import new profiles, while the 'Edit' menu can be used to access the Profile Manager or Repository Manager dialogs. The rest of the menus are similar to what we have in Pirut.

Exporting The Profile

There are two ways you can start off-- File->Export Profile or Edit->Profiles->Export.

You need to specify the name and location of the file to which you want to export the profile in order to proceed.

DebarshiRay Opyum rum-export-pbar.png

Importing A Profile

There are two ways you can start off-- File->Import Profile or Edit->Profiles->Import.

You need to specify the name and location of the file from which you want to import the profile in order to proceed.

DebarshiRay Opyum rum-import-pbar.png

Managing Different Profiles

The Profile Manager is reachable from Edit->Profiles.

DebarshiRay Opyum opyum-profile.png

This allows you to select the current profile that you would be working with, export or import a profile, and delete an existing profile.

Creating A Yum-Pack

Creating a Yum-Pack is very similar to the way we install or update packages using Pirut . Just select all the packages that you want to install or update and click the Apply button or go to File->Apply in the main application window.

After having navigated through the usual click stream you would need to provide the name and location where the Yum-Pack would be saved.

DebarshiRay Opyum rum-yumpack-pbar.png

Using A Yum-Pack

Right-clicking on the Yum-Pack (you can select multiple Yum-Packs too) will provide you with an option to open it with the Yum-Pack Installer.

DebarshiRay Opyum system-install-yumpacks-dropdown.png

Select the Yum-Pack Installer, provide the root password, click Apply in the resulting window and you are done installing or updating from the Yum-Pack.

DebarshiRay Opyum system-install-yumpacks-start.png

External Links

  • APTonCD is a tool with a graphical interface which allows you to create one or more CDs or DVDs (you choose the type of media) with all of the packages you've downloaded via APT-GET or APTITUDE, creating a removable repository that you can use on other computers.